Contribute
Register

Solved > Hackintosh Crashing (Photoshop/Final Cut/4K)

Joined
Jan 8, 2019
Messages
42
Motherboard
Gigabyte Z370 AORUS Ultra Gaming
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
It looks like I spoke too soon guys. It's back to crashing randomly. :mad::banghead::mad: I'm really ready to give up with this machine but I've spent so much money on it that it's hard to think about starting over from scratch or even maybe buying an older Mac Pro.

I did try a clean install of High Sierra again which didn't work as usual and also tried a different Samsung SSD I had, still the same crashes. I just know that it happens randomly when working with Photoshop files, Final Cut Pro projects with a lot of clips/transitions/overlays etc. and rare instances when watching 4k video. The only other thing I know to try is a different power supply but I highly doubt that could be an issue.

Anyway, if there is anyone out there that's ever run into a problem like this and has the same setup I would appreciate your help.
 
Joined
Jul 13, 2016
Messages
597
Motherboard
ASUS ROG STRIX Z370-F
CPU
I5-8600K
Graphics
Vega 56
Mac
Mac mini, Mac Pro
Mobile Phone
iOS
It looks like I spoke too soon guys. It's back to crashing randomly. :mad::banghead::mad:

I feel your pain however, I do not really have a solution hopefully you will find one.
 
Last edited:
Joined
Jan 8, 2019
Messages
42
Motherboard
Gigabyte Z370 AORUS Ultra Gaming
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
I did some digging around on the forum and found that disabling Open CL in Photoshop helped people with crashing. It seems to work for the time being but I need to keep testing more files before calling this solved.
 
Joined
Jan 8, 2019
Messages
42
Motherboard
Gigabyte Z370 AORUS Ultra Gaming
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
Alright, 2 days in and no crashes. This is what has finally done the trick for me (fingers crossed). I did some digging around and found out that there is a toggle switch on my video card that apparently switches the card from UEFI to Legacy from what I understand. It was toggled to the right and I flipped it to the left as you can see in this picture. From then on everything has worked perfectly with no crashes. I have no idea why this switch even exists but I'm glad that I found it, otherwise I was ready to sell this card and try something else. Obviously I still need to keep testing things out this week but everything I've been working on is stable on Mojave 10.14.2 - if anyone else has this issue I advise flipping this switch to see if it helps.
 

Attachments

Joined
Jul 13, 2016
Messages
597
Motherboard
ASUS ROG STRIX Z370-F
CPU
I5-8600K
Graphics
Vega 56
Mac
Mac mini, Mac Pro
Mobile Phone
iOS
I have no idea why this switch even exists but I'm glad that I found it, otherwise I was ready to sell this card and try something else.
Glad that solved your problem however, normally that switch is a bios switch it allows the card to have dual bios's and allows you to switch between them. Normally one is locked and can not be changed while the other one can be altered to use a different bios flash.
 
Joined
Jan 8, 2019
Messages
42
Motherboard
Gigabyte Z370 AORUS Ultra Gaming
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
Glad that solved your problem however, normally that switch is a bios switch it allows the card to have dual bios's and allows you to switch between them. Normally one is locked and can not be changed while the other one can be altered to use a different bios flash.
Weird. Yeah, I have no experience with it. If anyone has info on what this particular switch does I'd like to know. I couldn't find any info on it, nor could I find a manual for my RX 580... I must have thrown mine away by accident.
 
Joined
Jan 8, 2019
Messages
42
Motherboard
Gigabyte Z370 AORUS Ultra Gaming
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
One last reply on this. I'm a week in and officially calling this solved as flipping the graphics card switch fixed all of my issues - no crashes whatsoever. I still have no idea why or how this fixed it but if anyone is having this issue I suggest trying it. Hopefully this thread can help someone.
 
Top