Hackintosh can't boot: all kexts assertion failed

Jul 16, 2016
Worked late on my Hackintosh build I've been using for a year now. I peacefully shut it down, and went to sleep. The next morning as I woke up, my Hackintosh didn't want to boot up so I booted in verbose mode (my bootloader is Chimera) to see what's going on.

The system did a fsck at the beginning, returning "The volume appears to be OK", after which every single Apple kext prints out an "assertion failed" message which leaves my system hanging.

My specs are as follows:
  • 500GB HDD as only internal storage device, partition table (GPT) as follows:
EFI Partition (200MB), OSX Partition (100GB), Recovery HD (650MB), Windows 10 Partition (80GB), MSR, Data Partition (250GB FAT32), Ubuntu 16.04 Partition (50 GB)

Happens consistently on every reboot, so I can easily reproduce it.

Things I've tried:
  • -f flag
  • kext-dev-mode=1 flag
  • toggling GraphicsEnabler
  • combinations of the three above
  • trying to boot from GRUB (though probably fails because my OSX is installed in BIOS mode even though it's a GPT disk, while Windows and Ubuntu are running on UEFI mode)
  • Deleting VoodooHDA.kext, as I've had minor troubles with it a while back
None of these helped at all. I do have access to single-user mode though.

I've also noticed a strange line of output during verbose, something along the lines of BSD root: major 0, minor 7. Assuming this means disk0s7, does this mean my OSX is trying to boot off the wrong partition (the Ubuntu one) instead, explaining why it fails on all kexts (because they aren't there)? My OSX partition is located at disk0s2. I feel like this has something to do with the issue.

I'm just about ready to reinstall OSX entirely, I've already backed up all of my data and ready to wipe the partition if needed, though it would be nice to see if the problem is fixable on its own. Anyone got ideas?