Contribute
Register

Hackintosh Broken After 2 Years

Joined
Jul 1, 2015
Messages
22
Motherboard
Gigabyte Black Edition | GA-Z97X-UD5H-BK
CPU
Intel Core i7-4790K
Graphics
Gigabyte GTX960 G1 Gaming
Howdy!

I built my first (and only so far) hackintosh a little over 2 years ago (I think. haven't looked at exact dates). It has worked phenomenally, and was running my dual 27" displays perfectly for web development and video editing. The problem now is USB3.0, audio, and iMessage no longer work. iMessage was always spotty, but I need audio and USB3.0! It recognizes USB2.0 devices plugged into 3.0 ports, but not 3.0 devices (such as my 3TB external drive and USB hub).

My question is this: Based on the hardware below, would it be a good idea / compatible to wipe it and start over with high sierra and the newest bootloader powering it? The only data on the drive is the OS and a few programs. Nothing irreplaceable or difficult to replace. My main question is one of compatibility (I'm not very knowledgeable about this process).

Build:

GPU:
GTX960
CPU: i7-4790k
MB: UD5H-Bk
RAM: Gigabyte 16GB
WNA: TP-Link WDN4800

Everything except the monitor (I moved to 2 curved 27") is still true. Please view that for any specific part numbers!

Let me know if more information is needed. I am willing to be helped in debugging the current system, but i wonder if installing high sierra would be easier.

P.S. I bent a few of the pins in the USB3.0 header that connects the front panel of my case. That wouldn't cause the entire system to reject USB3.0 right? I'm plugging directly into the motherboard not through that plug.
 
Last edited by a moderator:
Top