Contribute
Register

HackinDROM App for OpenCore EFI Creation and Update

Joined
May 22, 2020
Messages
12
Motherboard
Gigabyte Z490 Vision D
CPU
i9 10900k
Graphics
Sapphire Radeon Pulse RX 580
Are you trying to update to Gigabyte Z490 Vision D Intel Wifi or Broadcom ?
Broadcom, I have a Fenvi fv-t919 card.
I was able to update the OC using the app and do a fresh OC install to a blank USB stick so that part is now working on the app. The only problem is that install page with these "info, ACPI, kexts, drivers". If I click on info, it seems to show everything right, the drivers tab shows the drivers but I cannot make any changes (update & enable switches aren't responding at all) and if I click on ACPI or kexts tab the app crashes and quits.
 
Joined
May 15, 2020
Messages
1,169
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KF
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Broadcom, I have a Fenvi fv-t919 card.
I was able to update the OC using the app and do a fresh OC install to a blank USB stick so that part is now working on the app. The only problem is that install page with these "info, ACPI, kexts, drivers". If I click on info, it seems to show everything right, the drivers tab shows the drivers but I cannot make any changes (update & enable switches aren't responding at all) and if I click on ACPI or kexts tab the app crashes and quits.
Thank you for reporting
It is again Xcode issue, I'm fixing it and will publish the release soon
 
Joined
Feb 1, 2011
Messages
123
Motherboard
Gigabyte Z490 Vision D rev 1.1
CPU
i7-10700
Graphics
RX 570
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I'm on Catalina on Vision D Z490, and OpenCore is reported to me as 0.6.0, but the EFI panel says OC Beta? and no option to update. I'm running HDR 2.0.4. Trying to prepare to upgrade to Big Sur.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,331
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
I'm on Catalina on Vision D Z490, and OpenCore is reported to me as 0.6.0, but the EFI panel says OC Beta? and no option to update. I'm running HDR 2.0.4. Trying to prepare to upgrade to Big Sur.
Because you are using a fairly old version of OpenCore, I would recommend downloading the 0.7.4 EFI folder from the mini-guide and transferring your PlatformInfo credentials (serial numbers). Also change SecureBootModel to Disabled (in Misc --> Security section of OpenCore Configurator). This is mentioned in the 0.7.4 mini-guide (for Catalina).

See How to use in the post below, which is for OC 0.6.2 so just mentally change the references to OC 0.7.4 and OpenCore Configurator 2.51.0.0.
 
Joined
Feb 1, 2011
Messages
123
Motherboard
Gigabyte Z490 Vision D rev 1.1
CPU
i7-10700
Graphics
RX 570
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Because you are using a fairly old version of OpenCore, I would recommend downloading the 0.7.4 EFI folder from the mini-guide and transferring your PlatformInfo credentials (serial numbers). Also change SecureBootModel to Disabled (in Misc --> Security section of OpenCore Configurator). This is mentioned in the 0.7.4 mini-guide (for Catalina).

See How to use in the post below, which is for OC 0.6.2 so just mentally change the references to OC 0.7.4 and OpenCore Configurator 2.51.0.0.

Thanks, the 0.7.4 zip download replacement worked fine. I'll be looking at upgrading to Big Sur next.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,331
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Thanks, the 0.7.4 zip download replacement worked fine. I'll be looking at upgrading to Big Sur next.
Making a full bootable backup first is essential!
 
Top