Contribute
Register

H77n-wifi usb 3.0

Status
Not open for further replies.
Joined
Dec 31, 2012
Messages
59
Motherboard
CustoMac Mini 2012
CPU
Intel i3 3225
Graphics
HD4000
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
Mobile Phone
Don't know about USB sticks, but my WD "My Passport" is merrily copying away on the rear USB3 port with no problems. If you have a front port on your case then it need to be a USB3 port, (1 and 2 have a different pinout), to work and need to be connected to the correct headers on the MB.
 
Joined
Nov 10, 2011
Messages
1,340
Motherboard
GA-H77N-WIFI F4
CPU
i7-3770
Graphics
HD 4000
Mobile Phone
  1. Android
Don't know about USB sticks, but my WD "My Passport" is merrily copying away on the rear USB3 port with no problems. If you have a front port on your case then it need to be a USB3 port, (1 and 2 have a different pinout), to work and need to be connected to the correct headers on the MB.

I hava one (USB 3.0) front port (which is connected to the board via internal cable) and two on the back of the case, but the result is one and the same with all of them - when I plug a flash drive (no matter USB 2.0 or USB 3.0), nothing happens - nothing in Finder, nothing in CleanMyDrive etc. And this is happening only with flash drives, the USB 3.0 ports work with keyboards and mouses just like it should, even my USB SmartCard reader works with these ports without any problem.
 

DBP

Joined
Nov 1, 2012
Messages
1,012
Motherboard
GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD4000 / GTX 1050 Ti
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. eMac
  2. iBook
  3. iMac
  4. Power Mac
  5. PowerBook
Mobile Phone
  1. Android
  2. iOS
Did you set up your BIOS properly?
Did you enable XHCI and EHCI hand-off?

Of course, when you do get USB3.0 working you'll still find that USB2.0 storage devices only work on those ports if connected via an external USB3.0 hub. This is a known issue with all Z77/H77 USB3 ports (some motherboards [not yours] have onboard hubs which hide the issue).
 
Joined
Mar 24, 2011
Messages
1,009
Motherboard
ASUS Z10PE-D8 WS
CPU
2x E5-2683 v3
Graphics
W9100
There is a way to fix it by multi-plexing the USB2 and USB3 ports together in your DSDT. I have this working on my ASUS Maximus V Gene and USB2 media devices now work fine from all my USB ports, USB3 ports included.
 
Joined
Nov 10, 2011
Messages
1,340
Motherboard
GA-H77N-WIFI F4
CPU
i7-3770
Graphics
HD 4000
Mobile Phone
  1. Android
Did you set up your BIOS properly?
Did you enable XHCI and EHCI hand-off?

Of course.

Of course, when you do get USB3.0 working you'll still find that USB2.0 storage devices only work on those ports if connected via an external USB3.0 hub. This is a known issue with all Z77/H77 USB3 ports (some motherboards [not yours] have onboard hubs which hide the issue).

Alright then, can you recommend me any USB 3.0 hub, which should work? Or any cheap chinese hub should work?

There is a way to fix it by multi-plexing the USB2 and USB3 ports together in your DSDT. I have this working on my ASUS Maximus V Gene and USB2 media devices now work fine from all my USB ports, USB3 ports included.

Sounds good, but can you tell me how can be done this or at least provide a source for this information?
 
Joined
Jan 30, 2013
Messages
1
Motherboard
CustoMacMini
CPU
i3-3225
Graphics
HD4000
Mac
Classic Mac
Mobile Phone
I read (and confirmed) from the customac thread that the USB 3.0 only works for USB 3.0 devices and keyboard/mouse. My 2.0 thumb drive didn't work but Seagate USB 3.0 HD works fine. Apparently this is a known issue. A USB 3.0 hub will let you let you use 2.0 on that port.
 
Joined
Mar 24, 2011
Messages
1,009
Motherboard
ASUS Z10PE-D8 WS
CPU
2x E5-2683 v3
Graphics
W9100
Well I can def tell you I fixed my and now all usb2 devices including usb2 HDDs and flash drives work in every port. Every mobo is different so I can't just say what I did and it would work for you because it won't, I have tried. So far I have it working for 2 boards.
 

DBP

Joined
Nov 1, 2012
Messages
1,012
Motherboard
GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD4000 / GTX 1050 Ti
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. eMac
  2. iBook
  3. iMac
  4. Power Mac
  5. PowerBook
Mobile Phone
  1. Android
  2. iOS
Alright then, can you recommend me any USB 3.0 hub, which should work? Or any cheap chinese hub should work?
The ones I have were eBay specials, so you should be fine with pretty much anything.
 
Status
Not open for further replies.
Top