Contribute
Register

Guide: Update OS X Mavericks to OS X Yosemite Using UniBeast and MultiBeast

Joined
Mar 3, 2011
Messages
103
Motherboard
Z77X-UP5 TH
CPU
i7-3770K
Graphics
Nvidia GTX 650
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac Pro
Classic Mac
Mobile Phone
Interesting since I have the same concern as above here.

I am only able to boot form USB stick onto the HDD. I have been tinkering around but no luck. I was wondering what logs I can upload which would assist in determining the issue. So far, everything work with the exception of the iMessage, however if I reboot several times , there will be that instance where it will not go past USBM while booting in -v , leading me to reinstall Yosemite for the nth time.

What logs can I supply?

Thanks,

Dali

Here's what I had to do that did work. Download the separate Chimera installer and use it to install the boot loader. MultiBeast has some sort of problem installing it properly or at all despite being checked.

If you still have a problem, then try the fix here: http://www.tonymacx86.com/25-boot0-error-official-guide.html
 
Last edited:
Joined
Sep 16, 2012
Messages
10
Motherboard
Sabertooth Z77 - Patched Bios - 10.10
CPU
i5 2500K @4.4GHz
Graphics
EVGA GTX 670 FTW
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. Android
Try this:
- boot with <key>Kernel Flags</key> <string>kext-dev-mode=1</string>

- rebuid cache sudo kextcache -m /System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext /System/Library/Extensions

Something like this should be displayed "kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakeSMC.kext"

- reboot and see if it's working


This worked for me. Thanks!
 
Joined
Feb 6, 2014
Messages
10
Motherboard
ASUS
CPU
Quad-Core Intel Core i5
Graphics
Intel HD Graphics 4000
Mac
  1. iMac
Classic Mac
  1. iMac
Thanks.

Yes attempted this earlier in my troubleshooting and just tried again. The boot to HDD process cannot get past "decompressing kernel cache lvzn" it then loops with another boot attempt. The only successful way for me to boot is via booting from USB. At times there is a chimera\chameleon GUI image of both the HDD and USB drive with a RED drive light, wondering if the means anything at all to the supporting audience. I really would like to stay away from a new install.

Thanks,
Dali
 
Joined
Feb 6, 2014
Messages
10
Motherboard
ASUS
CPU
Quad-Core Intel Core i5
Graphics
Intel HD Graphics 4000
Mac
  1. iMac
Classic Mac
  1. iMac
Thanks.

Yes attempted this earlier in my troubleshooting and just tried again. The boot to HDD process cannot get past "decompressing kernel cache lvzn" it then loops with another boot attempt. The only successful way for me to boot is via booting from USB. At times there is a chimera\chameleon GUI image of both the HDD and USB drive with a RED drive light, wondering if the means anything at all to the supporting audience. I really would like to stay away from a new install.

Thanks,
Dali

For the record also tried the below with NO success:

Petes-Mac-Pro-2:~ petegonzalez$ sudo kextcache -m /System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext /System/Library/Extensions
Password:
kext file:///System/Library/Extensions/RealtekRTL81xx.kext/ is in hash exception list, allowing to load
kext file:///System/Library/Extensions/PowerGadgetDriver.kext/ is in hash exception list, allowing to load
kext file:///System/Library/Extensions/NullCPUPowerManagement.kext/ is in hash exception list, allowing to load
kext file:///System/Library/Extensions/JMicronATA.kext/ is in hash exception list, allowing to load
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext GenericUSBXHCI.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakeSMC.kext
kext file:///System/Library/Extensions/EvOreboot.kext/ is in hash exception list, allowing to load
kext file:///System/Library/Extensions/ElliottForceLegacyRTC.kext/ is in hash exception list, allowing to load
kext file:///System/Library/Extensions/BoomDevice.kext/ is in hash exception list, allowing to load
kext file:///System/Library/Extensions/BJUSBLoad.kext/ is in hash exception list, allowing to load
kext-dev-mode allowing invalid signature -67030 0xFFFFFF
 
Joined
Feb 6, 2014
Messages
10
Motherboard
ASUS
CPU
Quad-Core Intel Core i5
Graphics
Intel HD Graphics 4000
Mac
  1. iMac
Classic Mac
  1. iMac
For the record also tried the below with NO success:

Petes-Mac-Pro-2:~ petegonzalez$ sudo kextcache -m /System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext /System/Library/Extensions
Password:
kext file:///System/Library/Extensions/RealtekRTL81xx.kext/ is in hash exception list, allowing to load
kext file:///System/Library/Extensions/PowerGadgetDriver.kext/ is in hash exception list, allowing to load
kext file:///System/Library/Extensions/NullCPUPowerManagement.kext/ is in hash exception list, allowing to load
kext file:///System/Library/Extensions/JMicronATA.kext/ is in hash exception list, allowing to load
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext GenericUSBXHCI.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakeSMC.kext
kext file:///System/Library/Extensions/EvOreboot.kext/ is in hash exception list, allowing to load
kext file:///System/Library/Extensions/ElliottForceLegacyRTC.kext/ is in hash exception list, allowing to load
kext file:///System/Library/Extensions/BoomDevice.kext/ is in hash exception list, allowing to load
kext file:///System/Library/Extensions/BJUSBLoad.kext/ is in hash exception list, allowing to load
kext-dev-mode allowing invalid signature -67030 0xFFFFFF


I just used the latest unibeast and did upgrade to Yosemite with same results, still unable to boot independently from HDD. Only successful using USB all works with the exception of the expected (iMessage).

Are there any logs which will assist in determining the condition or fix?

Thanks,

Dali
 
Joined
Feb 6, 2014
Messages
10
Motherboard
ASUS
CPU
Quad-Core Intel Core i5
Graphics
Intel HD Graphics 4000
Mac
  1. iMac
Classic Mac
  1. iMac
I just used the latest unibeast and did upgrade to Yosemite with same results, still unable to boot independently from HDD. Only successful using USB all works with the exception of the expected (iMessage).

Are there any logs which will assist in determining the condition or fix?

Thanks,

Dali


Ok, finally I could put this to rest.


Make sure this the /Extra directory has none other than org.chameleon.Boot.plist-In my case I had a org.org.chameleon.Boot.plist and a old.org.chameleon.Boot.plist. A unix practice of backing up my file before anything, Also make sure your modules folder is clean of any renamed files.

Petes-Mac-Pro-2:modules petegonzalez$ ls
FileNVRAM.dylib HDAEnabler.dylib Keylayout.dylib
Petes-Mac-Pro-2:modules petegonzalez$

Rebooted off the HDD successfully.

Now waiting for any new iMessage developments to fix iMessage.

Hope this helps another one attempting to find a resolution to the HDD concern.

-Dali
 
Joined
Apr 27, 2012
Messages
4
Motherboard
Hackn
CPU
INTEL
Graphics
GeForce GT640
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
Followed and only thing I get is a Flash of the Apple Logo when I boot USB with any triggers. Odd thing is on USB icon is not Yosemite icon, it is a generic USB picture. Maverick works great with no issues..... Help!!
1. Mother board GA-B75M-D3H
2. INTEL i3 BX80637i33225
3. CORSAIR 2X4GB DDR3 1600MHZ
4. EVGA GEFORCE GT 640 2048MB 02G-P4-2643-KR
5. SANDISK SDSSDX-240G-G25
6. TP-LINK TL-WDN4800
 
Joined
Jun 13, 2011
Messages
2
Motherboard
Windows-Sony Vaio VGN-AR71m
CPU
Core2Duo
Graphics
Nvidia Geforce 8400m gt
Mac
Classic Mac
Mobile Phone
I followed the steps and updated to Yosemite. Managed to run MB but after restarting I keep getting stuck at the screen with the apple and the loading line. I booted into verbose mode so I have attached a picture with what I get if someone can help me. Thank you!
 

Attachments

  • IMG_0001.jpg
    IMG_0001.jpg
    780.1 KB · Views: 184
Joined
Mar 3, 2011
Messages
103
Motherboard
Z77X-UP5 TH
CPU
i7-3770K
Graphics
Nvidia GTX 650
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac Pro
Classic Mac
Mobile Phone
Audio out from FaceTime is not working. All else is fine. Audio input works.

I can see my voice being picked up by the mic and on the sound input level in Sound preferences my voice is being picked up just fine. But the audio never leaves the computer. No one I connect with via FaceTime is able to hear me. I'm afraid I haven't a clue why.

If anyone has a suggestion or solution I would appreciate the help.
 
Joined
Feb 10, 2014
Messages
5
Motherboard
osx
CPU
i7
Graphics
760
Mac
Classic Mac
Mobile Phone
Here's how I got around the "can't find; mach_kernel" error.
I followed the steps in this guide and still got the error. My problem was that there are two ways to boot from your usb:

1. let chimera load, press any key to bring up the device list, and choose usb.
This resulted in the error

2. press F12 before Chimera loads to bring up the boot menu and choose usb or in my case PMAP.
Using the bios boot menu instead of the chimera boot menu allowed me to boot to the installer without any trouble.

Hope this helps someone!


Dude you are my HERO!!! I've been sitting here for hours trying to figure that out!
 
Top