Contribute
Register

Guide to Installing Mavericks on HP Probook

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,951
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I used lower case for "ssdt.aml" and it worked fine.

Yes, it doesn't matter. You can call it SsDt.AmL if you want.
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,951
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
just checked my stick, Mac OS Extended (Case-sensitive, Journaled)
that would explain the issue.

Yup. I guess you made just a slight mistake in step #2... Details, details!
 
Joined
Oct 7, 2011
Messages
12
Motherboard
HP 8470p
CPU
Intel i5 2.5GHz
Graphics
Intel HD4000
Mac
Classic Mac
  1. XL
Mobile Phone
  1. Android
  2. iOS
Problem is probably that you don't have an active partition in your MBR. Use fdisk to mark your "Mavericks HD" partition as active.



As it states in the guide, make sure you have "Wake on LAN" and "Wake on USB" disabled in BIOS.


Thanks for the replies, I will try both option to see if that work, will update if it work.
 
Joined
Mar 9, 2011
Messages
79
Motherboard
Gigabyte Z68X-UD3H-B3
CPU
i5
Graphics
HD3000
Mac
Classic Mac
Mobile Phone
didn't think I'd be back this quick !
I'm installed and at the point where I'm trying to run the probook installer. I copied it onto my desktop, enabled the app to run from preferences, and followed the guide to the letter.
When I click install and it starts to validate packages, it fails. The system log just says it encountered an error.
Should I try an older installer ? this is a 4530s i5, with a 1920x1080 panel, it's a fresh install on an ssd disk.
one other small issue is the keyboard and mouse dont work yet, no biggie as I'm presuming the installer will fix that (when it works)
 
Joined
Mar 9, 2011
Messages
79
Motherboard
Gigabyte Z68X-UD3H-B3
CPU
i5
Graphics
HD3000
Mac
Classic Mac
Mobile Phone
narrowed it down slightly, this appears in the logs

06/11/2013 09:19:31.107 launchservicesd[101]: Application App:"Installer" asn:0x0-19019 pid:300 refs=7 @ 0x7fbf08545e80 tried to be brought forward, but isn't in fPermittedFrontApps ( ( "LSApplication:0x0-0x1c01c pid=316 "SecurityAgent"")), so denying. : LASSession.cp #1481 SetFrontApplication() q=LSSession 100006/0x186a6 queue
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,951
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
narrowed it down slightly, this appears in the logs

06/11/2013 09:19:31.107 launchservicesd[101]: Application App:"Installer" asn:0x0-19019 pid:300 refs=7 @ 0x7fbf08545e80 tried to be brought forward, but isn't in fPermittedFrontApps ( ( "LSApplication:0x0-0x1c01c pid=316 "SecurityAgent"")), so denying. : LASSession.cp #1481 SetFrontApplication() q=LSSession 100006/0x186a6 queue

Did you remember step 13a?
 
Joined
Mar 9, 2011
Messages
79
Motherboard
Gigabyte Z68X-UD3H-B3
CPU
i5
Graphics
HD3000
Mac
Classic Mac
Mobile Phone
yes, I did loads of installs yesterday on another system so got used to doing it. I repaired permissions, that didn't help either.
I just went back into the console when I changed it (again), and it has a similar message saying SecurityAgent isn't a permitted app, so denying. I presume thats not taking the setting, even though the frontend says it's changed.
Now I'm downloading Mavericks App again, will rebuild a new stick and start a fresh install. I hope that fixes it.
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,951
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
yes, I did loads of installs yesterday on another system so got used to doing it. I repaired permissions, that didn't help either.
I just went back into the console when I changed it (again), and it has a similar message saying SecurityAgent isn't a permitted app, so denying. I presume thats not taking the setting, even though the frontend says it's changed.
Now I'm downloading Mavericks App again, will rebuild a new stick and start a fresh install. I hope that fixes it.

Show a screen shot of SysPrefs -> Security & Privacy.
 
Joined
Aug 16, 2011
Messages
9
Motherboard
Windows 7
CPU
Intel i7-3930k
Graphics
Geforce 560Ti
Mac
Classic Mac
Mobile Phone
I have problem by repatch DSDT from Probook Installer .9 to .10 by followed to 'BIOS updates/hardware upgrades' guide, but after boot by flag -f I struck with Apple boot screen.

Tried with -v and last message is '[iobluetoothhcicontroller] -- completed

Tried with GraphicsEnabler=yes/no, -x, -v but no luck.
 
Top