Contribute
Register

Guide To Install Yosemite on HP Laptops with Clover UEFI

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,075
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Joined
Mar 1, 2015
Messages
56
CPU
i5 4210U Haswell
Graphics
Intel HD Graphics 4400 1536 MB
Mac
Classic Mac
Mobile Phone
I installed it because it didn't work with the one that PBI CE installed, so I decided to get creative and I followed that link about patching kexts on the fly.

But after following your and RehabMan's advice I was able to get it working.

I have removed the kext (sudo rm -rf S/L/E/AppleHDAIDT.kext ), and re-run PBI CE ticking the box for the 4x40s kexts. I've done Repair permissions (via Disk Utility). Boot without caches (pressing space in clover). Rebuild cache (Kext Wizard). Reboot 2x. On the second time the sound was working (The volume didn't appear in the menu bar but the sound was working, added the volume to the menu bar in the System Preferences). The buttons in the keyboard that control the volume also work (although I don't need to press the fn key to activate it, I might have to check if that is toggled in the BIOS or what)

I don't really know why it didn't work on the other times I installed via PBI CE (I've formatted the disk and followed the guide several times). But I think it might be RehabMan's trick of "Repair permissions (via Disk Utility). Boot without caches (pressing space in clover). Rebuild cache (Kext Wizard). Reboot 2x.".

Thank you very much, I think you guys are awesome. Judging by the 4540s booting OSX perfectly is very easy. I bought the 4540s because I needed a working OSX. It had it with Chameleon + Mavericks for some months and now I'm very happy that it is working with Yosemite (I needed to update XCode).

Thank You!

You saved my life!
 
Joined
Sep 26, 2017
Messages
8
CPU
i3 3210
Graphics
intel hd 2500
Mac
MacBook Air
Mobile Phone
Android, iOS
I have sucessfully booted yosemite from hard drive but there seem to be some issues

1.no sound.
2.any media file would not open(error 101 or 51)
3.no battery percentage.

i have uploaded troubleshooting archive please help.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,075
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I have sucessfully booted yosemite from hard drive but there seem to be some issues

1.no sound.
2.any media file would not open(error 101 or 51)
3.no battery percentage.

i have uploaded troubleshooting archive please help.
From where did you download Yosemite?
What hardware do you have?
Please fill out your profile as per FAQ.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/

Note that this guide is deprecated.
New guide:
https://www.tonymacx86.com/threads/guide-hp-probook-elitebook-zbook-using-clover-uefi-hotpatch-10-11.189416/
 
Joined
Sep 26, 2017
Messages
8
CPU
i3 3210
Graphics
intel hd 2500
Mac
MacBook Air
Mobile Phone
Android, iOS
Joined
Sep 26, 2017
Messages
8
CPU
i3 3210
Graphics
intel hd 2500
Mac
MacBook Air
Mobile Phone
Android, iOS

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,075
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
i have my ethernet working. can i start to impliment the procedure from the terminal part ?
Assuming you didn't already do things not on the guide, yes (eg. installing kexts you shouldn't have/etc).
 
Top