Contribute
Register

Guide To Install Yosemite on HP Laptops with Clover UEFI

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,969
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi guys, I have a HP Probook 650 G1 with Intel i5 4200M, 1920x1080 display and AMD HD 8750M currently running on Win8. I'd like to create a dual-boot clean install with Yosemite + Win8 but I'm not sure if my laptop is supported or not... Post #1 says the guide is for 4x0 G1 (which is very similar to mine as far I know), but it also says laptops with AMD graphic cards are not supported (I know well the AMD card won't work in OS X which is fine).

I've already and successfully made a dual-boot Yosemite + Win8 on a Probook 4540s thanks to your guides so I'm confident enough to work on the G1, if possible. Thank in advance :)

Is it just Radeon or Radeon+Intel (switched dual-GPU)?
 
Joined
Jul 18, 2014
Messages
7
Motherboard
Gygabyte Z170X-UD5 TH
CPU
Intel i7 6700K
Graphics
EVGA GeForce GTX 970 FTW+
Mac
  1. iMac
  2. MacBook Air
Classic Mac
Mobile Phone
  1. iOS
GPU-Z shows 2 entries: Intel HD Graphics 4600 and AMD Radeon HD 8750M, so I guess it's switched dual-GPU.
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,969
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
GPU-Z shows 2 entries: Intel HD Graphics 4600 and AMD Radeon HD 8750M, so I guess it's switched dual-GPU.

Yes, switched... so the Radeon is irrelevant, except for hopefully the DSDT/SSDT patcher in PBI will disable it.

You should probably just try the 4x0 G2 option and see what happens. It may not work, in which case, you'll have some investigation to do...
 
Joined
Jul 18, 2014
Messages
7
Motherboard
Gygabyte Z170X-UD5 TH
CPU
Intel i7 6700K
Graphics
EVGA GeForce GTX 970 FTW+
Mac
  1. iMac
  2. MacBook Air
Classic Mac
Mobile Phone
  1. iOS
OK, thank you very much. I'm on it, let's what happens! :wave:
 
Joined
Jul 18, 2014
Messages
7
Motherboard
Gygabyte Z170X-UD5 TH
CPU
Intel i7 6700K
Graphics
EVGA GeForce GTX 970 FTW+
Mac
  1. iMac
  2. MacBook Air
Classic Mac
Mobile Phone
  1. iOS
It's me again... OS X installation went fine, but while in "OS X configuration" at first boot the OS was really slow (cursor movement, UI animations, everything). I didn't pay much attention and I was able to login into Yosemite. Here I encountered some graphic glitches and the OS was still running slow, but I managed to run HP Probook Installer. I noticed the installer shows 6x0 G1 model as supported and indeed has a option for kexts, so I went for it. I selected the version that matched my laptop under "OS X support kexts" and "Config and DSDT patcher" then under "Display type" I selected HD screen and Intel HD4600. In "Misc OS X files" I selected Probook logos and color profiles.

After restart the only thing the only thing I see has been changed is display resolution, now expectedly in 1920x1080. But still A LOT of graphic glitches system wide and the OS behaving very slow.

I noticed that if I rebuild cache with Kext Wizard after every boot, the OS becomes fast and responsive as you expect it to be, but only until next boot. Regarding graphics, I used the Probook Installer to select and install "Fix EDID", but it didn't fix the problem... What should I do?

Oh, I also have another major problem: ethernet not working (network panel says cable not connected) but when I plug the cable into the computer, the green light actually turns on. The port has always worked fine on Win... Weird, right?
 
Joined
Oct 21, 2012
Messages
3,464
Motherboard
HP Elitebook 8470p
CPU
i5 3320M
Graphics
HD 4000, 1600x900
Mobile Phone
  1. iOS
It's me again... OS X installation went fine, but while in "OS X configuration" at first boot the OS was really slow (cursor movement, UI animations, everything). I didn't pay much attention and I was able to login into Yosemite. Here I encountered some graphic glitches and the OS was still running slow, but I managed to run HP Probook Installer. I noticed the installer shows 6x0 G1 model as supported and indeed has a option for kexts, so I went for it. I selected the version that matched my laptop under "OS X support kexts" and "Config and DSDT patcher" then under "Display type" I selected HD screen and Intel HD4600. In "Misc OS X files" I selected Probook logos and color profiles.

After restart the only thing the only thing I see has been changed is display resolution, now expectedly in 1920x1080. But still A LOT of graphic glitches system wide and the OS behaving very slow.

I noticed that if I rebuild cache with Kext Wizard after every boot, the OS becomes fast and responsive as you expect it to be, but only until next boot. Regarding graphics, I used the Probook Installer to select and install "Fix EDID", but it didn't fix the problem... What should I do?

Oh, I also have another major problem: ethernet not working (network panel says cable not connected) but when I plug the cable into the computer, the green light actually turns on. The port has always worked fine on Win... Weird, right?

Try installing HD4600 OpenCL in PBI CE.
 
Joined
Jul 18, 2014
Messages
7
Motherboard
Gygabyte Z170X-UD5 TH
CPU
Intel i7 6700K
Graphics
EVGA GeForce GTX 970 FTW+
Mac
  1. iMac
  2. MacBook Air
Classic Mac
Mobile Phone
  1. iOS
OK, I did but the installation failed due to missing Xcode, so I installed Xcode and tried again. No luck, PCE said Installation Failed once again. I restarted the computer and the graphics eventually got screwed up :cry: (see attachment)
 

Attachments

  • IMG_1508_2.JPG
    IMG_1508_2.JPG
    869.1 KB · Views: 67

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,969
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
It's me again... OS X installation went fine, but while in "OS X configuration" at first boot the OS was really slow (cursor movement, UI animations, everything). I didn't pay much attention and I was able to login into Yosemite. Here I encountered some graphic glitches and the OS was still running slow, but I managed to run HP Probook Installer. I noticed the installer shows 6x0 G1 model as supported and indeed has a option for kexts, so I went for it. I selected the version that matched my laptop under "OS X support kexts" and "Config and DSDT patcher" then under "Display type" I selected HD screen and Intel HD4600. In "Misc OS X files" I selected Probook logos and color profiles.

After restart the only thing the only thing I see has been changed is display resolution, now expectedly in 1920x1080. But still A LOT of graphic glitches system wide and the OS behaving very slow.

I noticed that if I rebuild cache with Kext Wizard after every boot, the OS becomes fast and responsive as you expect it to be, but only until next boot. Regarding graphics, I used the Probook Installer to select and install "Fix EDID", but it didn't fix the problem... What should I do?

Download patchmatic: https://github.com/RehabMan/OS-X-MaciASL-patchmatic.
Extract the 'patchmatic' binary from the ZIP. Copy it to /usr/bin, such that you have the binary at /usr/bin/patchmatic.

In terminal,
Code:
rm -Rf ~/Downloads/RehabMan
mkdir ~/Downloads/RehabMan
cd ~/Downloads/RehabMan
patchmatic -extract

Post contents of Downloads/RehabMan directory (as ZIP).

Also, post ioreg: http://www.tonymacx86.com/audio/58368-guide-how-make-copy-ioreg.html. Please, use the IORegistryExplorer v2.1 attached to the post! DO NOT reply with an ioreg from any other version of IORegistryExplorer.app.

Also post native ACPI files from /EFI/Clover/ACPI/origin.

Oh, I also have another major problem: ethernet not working (network panel says cable not connected) but when I plug the cable into the computer, the green light actually turns on. The port has always worked fine on Win... Weird, right?

Which Ethernet device does your computer have?
 
Joined
Nov 27, 2013
Messages
20
Motherboard
HP 8460P
CPU
Intel Core i5 (2nd Gen) 2520M / 2.5 GHz/ QM67
Graphics
AMD HD 6470M 1366 x 768
Mac
Classic Mac
Mobile Phone

Attachments

  • IMAG0107_BURST002_COVER.jpg
    IMAG0107_BURST002_COVER.jpg
    581.1 KB · Views: 73
Joined
Oct 21, 2012
Messages
3,464
Motherboard
HP Elitebook 8470p
CPU
i5 3320M
Graphics
HD 4000, 1600x900
Mobile Phone
  1. iOS
Top