[GUIDE] Sierra on the GA-Z170X-UD3

Not open for further replies.
Hey @cnrd,

Sorry to bother but I had a question for you. I'm getting ready to build my first Hackintosh, and I'm using the same motherboard as you.

For these steps (12 and 13):
  1. Copy files from Clover Files to these places
    • config.plist
    • kexts/Other/FakeSMC.kext
    • kexts/Other/IntelMausiEthernet.kext
    • kexts/Other/CodecCommander.kext
    • drivers64UEFI/HFSPlus.efi
    • ACPI/patched/XOSI-WIN10.aml
    • ACPI/patched/SSDT-HDEF-HDAS-1.aml
  2. Delete these files and folders
    • kexts/10.*
    • drivers64UEFI/VBoxHfs-64.efi

Where exactly am I copying from and going to? If I understand right, once I open the EFI partition, that's where the "Clover Files" folder is located, correct? Am I just copying the files from that folder to the corresponding directory elsewhere on the USB drive? (With the exception of config.plist, which would presumably go on the root directory as you didn't list a folder path?)

Just wanting to make sure I understand everything before I order my parts from Amazon. :)

Clover Files should be the ones you download from the guide in this post. You will copy those to your clover installation folder (which will be on your EFI partition or USB, depending on where you are installing to). When you open your clover folder on the EFI partition, you should see a folder structure similar to the files you downloaded from this guide - so move them into the corresponding folders.
Hi, I've waited long time for Pascal Nvidia Driver (Nvidia GTX1060) and yesterday I've tried to install Sierra into my Hackintosh iMac 6700.
My MB firmware is last F22.
I followed the guide but I could not configure the USB ports because I do not have an OSX already installed on this computer.
I created the USB drive and I got to the point 3 because the boot stops with the Prohibited sign.
Please help me!
You do not need to configure the USB ports on the same mac. You can use any other mac.

As I saw on this thread, F22 doesn't seem to work. I'm on F21 and it works.
After striking out with the official guide, I gave this guide a shot and I've got pretty convincing results.

What works for me on 10.12.3:

USB3: External HDD at over 80MB/s, SSD over 250MB/s
Firewire: RME Fireface 800 works flawlessly with StarTech FW card
Bluetooth: Keyboard and trackpad work as expected with OSXWIFI hackintosh card
App Store: works
iTunes: works after fix found on forum
GTX 980 ti: no issues and plenty of power

One thing I haven't been able to work through is that the system will restart itself after shutdown. If boot into my windows 10 drive, shutdown works as expected, so I don't think the BIOS settings are at issue. Any hints?
Last edited:
Hey, first off amazingly thorough guide, THANK YOU! I have the ud5 board but it's basically identical.

I've got everything working at this point but when I boot up (I do have two monitors, DVI & DP) It says that it's on the Nvidia Drivers but it's not. The drivers loaded are the 355.x.x.x and not the 367.x.x.x I've confirmed this through the extensions tab and CUDA-z.

Is anyone else having this problem?
Have you managed to solve your problem?

I took a look in CUDA-Z and I have the same problem.

Driver installed in NVIDIA Driver Manager shows up as : 378.05.05.05f01

In CUDA-Z i see 355.10.05.35f05.

I'm getting weird issues with Premiere Pro. Sometimes the all of the playback monitors turn to black and don't work until i restart premiere. I've noticed that if I change the renderer from CUDA to OpenCL, the picture is back.

Any ideas?
I'm about to start this fresh install build and would like to know if anything has changed from post #1 since we're now on 10.12.4 which requires a newer (newest) version of Clover? Also, when I ran the USB-SSDT it produced only 1 file the this a problem?
I'm about to start this fresh install build and would like to know if anything has changed from post #1 since we're now on 10.12.4 which requires a newer (newest) version of Clover? Also, when I ran the USB-SSDT it produced only 1 file the this a problem?
10.12.4 resolves a number of issues for displays and doesn't seem to create new problems so I vote for you to use it. It doesn't require the very latest I don't think, I'm on 4035, and I think there's a newer. I was using the 530 on dual displays up until just now, and have now migrated to the new Nvidia drivers for my 1060 so 4035 supports all that too. But I don't know there's a reason NOT to use the latest clover and I'm sure I'll get there soon. I have had bad experiences upgrading clover so I'm cautious about upgrading clover as I am about any upgrade, always leaving myself a blackout plan.

I think the USB thing creating a single file is exactly as intended.
Quick post to let folks on this board know I had no issues installing the Nvidia web drivers for pascal for my 1060 and I now have dual displays working. Haven't tested display sleep, system sleep, or shutdown/restart, will test those and report back. None of that worked for me on the 530 with dual displays. I am on 10.12.4 and had already disabled most of the 530 patches, leaving in the 4 display patch and the connector type patches, so leaving those in have apparently not caused any issue. For me, I ticked NvidiaWeb in Clover Configurator -> System Parameters, installed the drivers, rebooted, and it Just Worked.

This guide had already had us install the VRAM emulator EmuVariablesEFI_64.kext and disable SIP, two pre-reqs on this board.

I turned on the second display at the desktop so still not sure if it works from boot but will test and report back.
my hackintosh is very similar to the @cnrd one, it changes only in cpu (i7 6700K) and GPU (GTX1060) I've also BCM94360CD Bluetooth / WiFi combo mini card.
I did a 10.12.4 clean install (iMac 17,1).
I can boot and video is working, Bluetooth too but wifi and Handoff/Continuity no!
I moved BCM94360CD card to this computer from my other hackintosh (10.12.4 where it works OOB)
Airplay don't work and I've not yet tested audio.
There is someone who has had these problems?
Last edited:
Not open for further replies.