Contribute
Register

[GUIDE] Sierra on the GA-Z170X-UD3

Joined
Sep 19, 2015
Messages
18
Motherboard
Gigabyte Z170X-UD3
CPU
Core i5-6500 LG1151
Graphics
eVGA Geforce GTX 950
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
sleeman2007 - Thanks for posting your clover config & directory. As someone who after a month of tinkering still doesn't have everything working quite right, I am wondering why I wouldn't just replace my clover directory + config (adding in my serial and id) and try booting from that? I'm assuming most of the variation would be from timings from the CPU and graphics injection, but if we all have the same board / chipset? Curious. Thanks.
 
Joined
Sep 19, 2015
Messages
18
Motherboard
Gigabyte Z170X-UD3
CPU
Core i5-6500 LG1151
Graphics
eVGA Geforce GTX 950
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hello all. I'm trying to get 5.1 (or 2.1) analog audio working with this board. I've followed the bits in the other thread for this (How to enable 5.1-channel analogue audio in OS X | tonymacx86.com) to make a composite device, and I can hear audio out of just the subwoofer if I really crank it up. Any other tricks you folks are doing to get audio working?
 

PFG

Joined
Dec 15, 2016
Messages
93
Motherboard
Gigabyte Z170X-UD3
CPU
i7-6700K
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Air
Mobile Phone
  1. iOS
GCZZI

The trick is to get a working install on you HDD, then add the config.plist entries and kext to be able the "see" the SSDs. Format them then install clover on them and copy the config.plist and kext from your working HDD install. You should be able to clone the macOS installation from the HDD to the SSD. I used carboncopy.
 
Joined
Jan 15, 2017
Messages
22
Motherboard
Z170MX Gaming 5
CPU
i7 6700k OC 4.6 Ghz
Graphics
GTX 980 Ti 6Gb
Mac
  1. iMac
Thanks so much for your guide, I have the OSX desktop and I am currently trying to run through the post-install.

It is not clear if I should be running 'freqVectorsEdit.sh' on the new Hackintosh, or the old Mac?

"Triggering a kernelcache refresh ..." is scaring me
 
Joined
Jan 15, 2017
Messages
22
Motherboard
Z170MX Gaming 5
CPU
i7 6700k OC 4.6 Ghz
Graphics
GTX 980 Ti 6Gb
Mac
  1. iMac
When running the "ssdtPRGen.sh" script, I get:

ssdtPRGen.sh v0.9 Copyright (c) 2011-2012 by † RevoGirl

v6.6 Copyright (c) 2013 by † Jeroen

v21.4 Copyright (c) 2013-2017 by Pike R. Alpha

-----------------------------------------------------------

Bugs > https://github.com/Piker-Alpha/ssdtPRGen.sh/issues <

./ssdtPRGen.sh: line 3862: /Users/me/Library/ssdtPRGen/Data/Versions.cfg: No such file or directory


System information: Mac OS X 10.12.2 (16C68)

Brandstring: "Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz"


Notice: Downloading extractACPITables.zip ...

unzip: cannot find or open /Users/me/Library/ssdtPRGen/extractACPITables.zip, /Users/al/Library/ssdtPRGen/extractACPITables.zip.zip or /Users/al/Library/ssdtPRGen/extractACPITables.zip.ZIP.

rm: /Users/me/Library/ssdtPRGen/extractACPITables.zip: No such file or directory

Fixing executing bit of extractACPITables ...

chmod: /Users/me/Library/ssdtPRGen/Tools/extractACPITables: No such file or directory

mkdir: /Users/me/Library/ssdtPRGen/ACPI: Permission denied

./ssdtPRGen.sh: line 2674: /Users/me/Library/ssdtPRGen/Tools/extractACPITables: No such file or directory

grep: /Users/me/Library/ssdtPRGen/ACPI/SSDT*.aml: No such file or directory

Error: /Users/me/Library/ssdtPRGen/ACPI/DSDT.aml not found!

Aborting ...

Done.



No PM for me?
 
Joined
Dec 30, 2010
Messages
39
Motherboard
GA-Z170X-UD3
CPU
i7 6700K
Graphics
Gigabyte GTX970 G1 GAMING
Mac
  1. MacBook Pro
Can I edit my config.plist from Clover before booting into the OS? The NVidia = true completely shuts down my machine.
You may boot from the USB stick and then select your main drive. Then you can change your config.plist in your main drive's EFI
 
Joined
Jan 15, 2017
Messages
22
Motherboard
Z170MX Gaming 5
CPU
i7 6700k OC 4.6 Ghz
Graphics
GTX 980 Ti 6Gb
Mac
  1. iMac
I just can't get my Nvidia 980 Ti work work with the web drivers. I've purchased all the recommended gear and I still can't get the video card to work after 3 days of trying. I've tried every thread and youtube video I can find. I'm starting to wonder if Hackintosh is really worth the time.
 
Top