Contribute
Register

[Guide] Sierra 10.12.2 on the AsRock Z170 Pro4

Joined
Nov 12, 2018
Messages
1
Motherboard
Asrock Z170 Pro4
CPU
Intel i3-6100
Graphics
Gigabyte GTX 950
Hi,

It is work with installing of MacOS X High Sierra 10.13.6?

I have:
ASRock Z170 Pro4 (UEFI version: 7.50P)
Intel i3-6100 (it will exchange to i5-7400)
Gigabyte GTX 950
2 x 4GB 2400 Mhz RAM

I think it good, that this guide is good for me to install the MacOS X High Sierra 10.13.6?
 
Joined
Nov 21, 2019
Messages
5
Motherboard
Asrock Z170 Extreme 6+
CPU
i5-6600K
Graphics
GTX 970
Mac
MacBook Pro
I have an Asrock Z170 Extreme 6+ with High Sierra, I loaded 100/200/300 series audio support and ALC1150 as stated in this thread but still no audio. Anybody can suggest any workaround or further troubleshooting step?

Thanks a lot.
 

Attachments

Joined
Apr 14, 2016
Messages
35
Motherboard
ASROCK Z170 Extreme 3
CPU
Intel Core i7 6700k
Graphics
Radeon RX 570
Mobile Phone
iOS
I have an Asrock Z170 Extreme 6+ with High Sierra, I loaded 100/200/300 series audio support and ALC1150 as stated in this thread but still no audio. Anybody can suggest any workaround or further troubleshooting step?

Thanks a lot.
AppleALC.kexts not work?
 
Joined
Apr 14, 2016
Messages
35
Motherboard
ASROCK Z170 Extreme 3
CPU
Intel Core i7 6700k
Graphics
Radeon RX 570
Mobile Phone
iOS
I have an Asrock Z170 Extreme 6+ with High Sierra, I loaded 100/200/300 series audio support and ALC1150 as stated in this thread but still no audio. Anybody can suggest any workaround or further troubleshooting step?

Thanks a lot.
AppleALC.kexts not work?
 
Joined
Apr 14, 2016
Messages
35
Motherboard
ASROCK Z170 Extreme 3
CPU
Intel Core i7 6700k
Graphics
Radeon RX 570
Mobile Phone
iOS
So I need all three AppleALC, 100/200/300 Series AND ALC1150 in order to let it work? :eek:
I think there is only one AppleALC, it works for all 100/200/300 Series motherboards.
 

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
5,996
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
iMac
I think there is only one AppleALC, it works for all 100/200/300 Series motherboards.
So I need all three AppleALC, 100/200/300 Series AND ALC1150 in order to let it work? :eek:
Applealckext needs an injection number, in Audio settings.

Screen Shot 2019-12-03 at 7.28.00 PM.png

Layout ID needs to be assigned based on the codec.

Screen Shot 2019-12-03 at 7.31.36 PM.png
 
Joined
Apr 14, 2016
Messages
35
Motherboard
ASROCK Z170 Extreme 3
CPU
Intel Core i7 6700k
Graphics
Radeon RX 570
Mobile Phone
iOS
Applealckext needs an injection number, in Audio settings.

View attachment 438678

Layout ID needs to be assigned based on the codec.

View attachment 438679
For my cace, I just use Kextbeat to install AppleALC kext to /System/Library/Extensions/, then it works in 10.14.x ~ 10.15.x. I haven't noticed the injection number, or you could find from my config.plist file which located in /EFI/CLOVER/.
 

Attachments

Top