Contribute
Register

[Guide] Sapphire Radeon RX 5700 XT Nitro+ with macOS Catalina

Joined
Jul 21, 2019
Messages
8
Motherboard
ASUS Rog Strix Z390-E
CPU
Core i9-9900K
Graphics
Sapphire Radeon 5700XT Nitro+
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi,

I have spend the last few days getting my new Radeon 5700 XT fully running under macOS Catalina. Since I read many posts and tried a lot of different things I wanted to share my findings here, hope to help other users with similar problems.

My goal was to get a two monitor setup running, my main 34'' display over DisplayPort and my secondary 27'' screen via HDMI.

But I want to point out that what worked for me does not necessaryly need to work for you. Since I read so many different approaches and solutions in other threads there might be other pitfalls in your case.

Prerequisites
I would strongly advice to create a bootable usb stick with a copy of your currently working boot loader from your hard drives EFI partition.
Every time something goes wrong and you are not able to boot your system you can just select the stick as boot device and revert changes made to your EFI folder.

Steps
1) Upgrade to macOS Catalina

So first of all you should upgrade your system to the latest macOS Catalina version, since the card is only fully supported since 10.15.2. I've chosen the direct update route from Mojave described here. All this can be done with your currently installed graphic card.
The only error I got was "apfs_module_start:1683" during the installation process. So if your installation seems to stuck, restart it in verbose mode by pressing space bar on the Clover boot entry and choosing the "-v" boot option.
There are several threads here in the forum the point out that you need to install SSDT-EC.aml in the /EFI/CLOVER/ACPI/patched folder of your EFI partition.

I then swapped the graphic card to the Radeon 5700XT and run into different problems, which I describe at the beginning of each step. You can easily boot with your old card and do all the setup before having to change between the two cards back and forth!

1) Deactivate GPU Injection
I got a black screen directly after choosing my Clover boot entry (no macOS load bar or Apple logo appeared).

To avoid this mount your EFI partition with Clover Configurator, load your config.plist from /EFI/CLOVER and choose the Graphics section. Deactivate Inject ATI, Inject Intel and Inject NVidia.
Save your configuration with CMD+S.

2) Config your macOS model
After step one my system booted with a progress bar and the Apple logo, but right before the login screen the monitor got back into stand by and stood black.

I could work around this by configuring an accurate macOS model with the help of Clover Configurator. Load you config.plist like described in step one and navigate to the SMBIOS section.
Go to everymac.com and navigate to the exact processor you have. In my case I own a Core i5 6600 which brought me to the following detail page. Just below the headline the model is mentioned - in my case iMac17,1.
Back at the SMBIOS section i could choose this exact model by clicking at the double arrow on the right side just below the model image. Afterwards all the other fields at this page got filled out automatically.
Save your configuration with CMD+S.

3) Update WhatEverGreen.kext and Lilu.kext to the latest version
After step two my system booted till the login screen but only the secondary screen at the HDMI port worked. The main monitor still stood black.

Download the latest version of WhatEverGreen.kext (1.3.6 for me) and Lilu.kext (1.4.1 for me) from the Download Section. These files need to be put under /Library/Extensions but can not be copied directly. Just follow the instructions here by using Hackintool to install any kind of kext file.

As a last step go back to Clover Configurator and choose the Boot section. With a right click in the Boot Arguments window you can choose "agdpmod=pikera" from the WhatEverGreen submenu.
Save with CMD+S as always.

Sidenote: I also updated AppleALC.kext and FakeSMC.kext in the same way but I can't tell if this was necessary.

After this my system booted with both monitors working as I might expect it.
 

Attachments

  • EFI.zip
    29.2 MB · Views: 278
Last edited:

m+t

Joined
Jul 9, 2019
Messages
3
Motherboard
Gigabyte GA-Z170N-Gaming 5
CPU
i7-6700K
Graphics
RX 5700 XT
Great success, thanks you SplitGamer!

Step 3) I choose to put the .kext files in /EFI/CLOVER/kext/Others (faster and more flexible)
I also replaced FakeSMC.kext with VirtualSMC.kext since that works better for my system, now reporting temperatures and fan speeds correctly.

Step 4) Moved the /EFI directory from USB drive to the SSD by mounting both partitions and copying the contents.

Background: Had a Geforce without support for Catalina, so bought a Nitro+ RX 5700 XT. Had to modify my Node 202 casing with an angle grinder to fit the Nitro, but it now all fits very nicely. Did a clean install, install was very straight forward without any issues (first formatted the disks in disk utility in the Installer).
Super quiet and awesome performance.

System: iMac 17,1 (iMac Retina 5K, 27-inch, Late 2015)
OS: macOS 10.15.2 Catalina
Motherboard: Gigabyte GA-Z170N-Gaming 5
Processor: Intel Core i7-6700K CPU @ 4.00Ghz
Memory: 32 GB 2133 MHz DDR4
Graphics: Sapphire Nitro+ Radeon RX 5700 XT
Disk 1 NVME: Samsung SSD 970 EVO Plus 2TB (primary boot)
Disk 2 SATA: Samsung SSD 860 EVO 1TB
Disk 3 SATA: Samsung SSD 850 EVO 1TB
 
Joined
Nov 6, 2018
Messages
1
Motherboard
Gigabyte Z170N gaming 5
CPU
i7-6700K
Graphics
GTX1060
Great success, thanks you SplitGamer!

Step 3) I choose to put the .kext files in /EFI/CLOVER/kext/Others (faster and more flexible)
I also replaced FakeSMC.kext with VirtualSMC.kext since that works better for my system, now reporting temperatures and fan speeds correctly.

Step 4) Moved the /EFI directory from USB drive to the SSD by mounting both partitions and copying the contents.

Background: Had a Geforce without support for Catalina, so bought a Nitro+ RX 5700 XT. Had to modify my Node 202 casing with an angle grinder to fit the Nitro, but it now all fits very nicely. Did a clean install, install was very straight forward without any issues (first formatted the disks in disk utility in the Installer).
Super quiet and awesome performance.
hi,thanks for your sharing. Could you upload your efi folder ? I have exactly the same configuration.
 
Joined
Apr 26, 2014
Messages
141
Motherboard
Asus Z270-WS
CPU
i7-6700K
Graphics
RX 5700 XT
Mac
  1. iMac
Classic Mac
  1. Power Mac
Mobile Phone
  1. Other
Thank god for this thread! Nice to find others with similar configaration to share notes. I just got a Sapphire Nitro 5700 XT other day and having an issue with a black box appearing hovering over the cursor. Goes away if I shake the mouse around but comes back. On 15.2 as of right now. Running card off of HDMI port. You guys experiencing similar issue?

thank you
 
Joined
Jan 3, 2018
Messages
39
Motherboard
Z390 Gaming X
CPU
i7 9700k
Graphics
5700XT
Mac
  1. iMac
Great success, thanks you SplitGamer!

Step 3) I choose to put the .kext files in /EFI/CLOVER/kext/Others (faster and more flexible)
I also replaced FakeSMC.kext with VirtualSMC.kext since that works better for my system, now reporting temperatures and fan speeds correctly.

Step 4) Moved the /EFI directory from USB drive to the SSD by mounting both partitions and copying the contents.

Background: Had a Geforce without support for Catalina, so bought a Nitro+ RX 5700 XT. Had to modify my Node 202 casing with an angle grinder to fit the Nitro, but it now all fits very nicely. Did a clean install, install was very straight forward without any issues (first formatted the disks in disk utility in the Installer).
Super quiet and awesome performance.
Hi, I used 5700xt gaming oc but I don't have the temps show up disregarding kexts :(
1586229295813.png

1586229348468.png

Do you have any tip?
 
Joined
Apr 26, 2014
Messages
141
Motherboard
Asus Z270-WS
CPU
i7-6700K
Graphics
RX 5700 XT
Mac
  1. iMac
Classic Mac
  1. Power Mac
Mobile Phone
  1. Other
@SplitGamer Are you on 15.4 and stable? My Nitro 5700 XT not liking 15.4.
 
Joined
Jan 3, 2018
Messages
39
Motherboard
Z390 Gaming X
CPU
i7 9700k
Graphics
5700XT
Mac
  1. iMac
@SplitGamer Are you on 15.4 and stable? My Nitro 5700 XT not liking 15.4.
hi, what problem you experienced? So far good on mine except for:
- Screen off/Wake requires unplug replug DP
- Minor stutter lag , not buttery smooth some random times
 
Joined
Apr 26, 2014
Messages
141
Motherboard
Asus Z270-WS
CPU
i7-6700K
Graphics
RX 5700 XT
Mac
  1. iMac
Classic Mac
  1. Power Mac
Mobile Phone
  1. Other
Random lockups and freezes. Crash report points to the AMD drivers.
 
Top