Contribute
Register

[GUIDE] Remove extra Clover BIOS boot entries & prevent further problems

Joined
Jan 1, 2011
Messages
126
Motherboard
Gigabyte Z170X-UD5
CPU
i7-6700K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
THIS WORKS (If you have Windows installed as well on a different drive):
In OSX:
1. Use EFI Mounter (download from Tonymacx86 downloads section) utility to open EFI and go to the BOOT folder.
2. Rename BOOT folder to LAUNCHER
3. Reboot to Windows
In Windows:
1. Download and use EasyUEFI utility to delete any extra boot options.
2. Use EasyUEFI to add a new boot entry, select other OS, name it what you want (I just called it El Capitan) so you can identify it when you boot, and click Browse and go through the file directory \EFI\LAUNCHER\BOOTX64.efi
3. Done

Reboot to OSX then restart several times and make sure you aren't getting extra boot options

Very happy to report that this solution worked perfectly for me. No more typing "bcfg boot dump..." after months...
 
Joined
Mar 17, 2017
Messages
6
Graphics
gtx 1660 ti
Mobile Phone
  1. Android
If not have Windows OS then what have to do? How to remove these entries permanently?
 
Joined
Mar 17, 2017
Messages
6
Graphics
gtx 1660 ti
Mobile Phone
  1. Android
My mobo is g1 sniper z87 and last bios f4 is shity and from 2015. Last stable bios is f3 and I use it.
 
Joined
Jan 23, 2016
Messages
38
Motherboard
GA B150M D3H DDR4
CPU
i5 6500
Graphics
GTX 970
Mac
  1. iMac
if you go from last bios uptade you need to reeinstal the whole thing? I have a windows 10 and Sierra 10.12.3
 
Joined
Mar 17, 2017
Messages
5
Motherboard
Z170X-UD3
CPU
i5-6600K, 3.5GHZ
Graphics
EVGA Geforce GTX 1060
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hello all!

New to Hackintosh (and building computers in general!), but not new to mac; upon completing my first build I figured I'd chime in and help anyone who's in my position
Running:
i5-6600K
GA-Z170X-UD3
ASUS STRIX 970

Since this thread has been alive for the past year or so, I'm just sharing my findings after reading through all 26 pages. I narrowed down my options:

1) Update BIOS
2) EasyUEFI via Windows partition
3) Via Clover & Shell

Fresh out of Microcenter, my MOBO had F6 as the BIOS. I flashed it today and the extra partitions have stopped (it even deleted the older ones). I upgraded to the newest BIOS (F22). The only problem so far was the GPU driver defaulted from Web Driver back to OS X Default Graphics driver. Currently attempting to address the issue following the steps from "Problem 6" from this link: https://www.tonymacx86.com/threads/solving-nvidia-driver-install-loading-problems.161256/

Will update with my progress!
 
Top