Contribute
Register

[Guide] Razer Blade, Late 2016, FHD

Joined
Apr 21, 2016
Messages
1,011
Motherboard
ASUS X556UA-Clover
CPU
i5-6200U
Graphics
HD 520,1366x768
Mobile Phone
  1. iOS
OS patch applied. DSDT and IOReg attached again! :thumbup:

No, I think its an old one...back from El Capitan days.
You have 3 OS patches applied to your DSDT... :/
Undo Windows 2009 and 2013 patches, so you'll only have the 2015 patch applied.

BTW, HECI should be named IMEI. Rename is present by default in RehabMan's config.plist, copy the patch from those.

Please reply with new DSDT and IOReg if trackpad still not working after changes were made :)
 

uar

Joined
Jul 21, 2015
Messages
228
Motherboard
Razer Blade, Clover
CPU
i7-6700HQ
Graphics
HD 530 / GTX 1060, 1920x1080
Mobile Phone
  1. Android
You have 3 OS patches applied to your DSDT... :/
Undo Windows 2009 and 2013 patches, so you'll only have the 2015 patch applied.

BTW, HECI should be named IMEI. Rename is present by default in RehabMan's config.plist, copy the patch from those.

Please reply with new DSDT and IOReg if trackpad still not working after changes were made :)
It works again. The OS patch did the trick. The newer driver made the cursor fly, but the old one is still working. Thanks Ben! :thumbup:
 

uar

Joined
Jul 21, 2015
Messages
228
Motherboard
Razer Blade, Clover
CPU
i7-6700HQ
Graphics
HD 530 / GTX 1060, 1920x1080
Mobile Phone
  1. Android
By the way, Ben. Did you get the headphones to work?
 
Joined
Apr 21, 2016
Messages
1,011
Motherboard
ASUS X556UA-Clover
CPU
i5-6200U
Graphics
HD 520,1366x768
Mobile Phone
  1. iOS
By the way, Ben. Did you get the headphones to work?
Yes :)
Using AppleALC and layout-id 27 made for the X556UA I own. (Actually they worked with an old patched AppleHDA too, but it had some issues when unplugged-replugged).
Internal mic is also working with AppleALC, it didn't work before here.
 

uar

Joined
Jul 21, 2015
Messages
228
Motherboard
Razer Blade, Clover
CPU
i7-6700HQ
Graphics
HD 530 / GTX 1060, 1920x1080
Mobile Phone
  1. Android
Yes :)
Using AppleALC and layout-id 27 made for the X556UA I own. (Actually they worked with an old patched AppleHDA too, but it had some issues when unplugged-replugged).
Internal mic is also working with AppleALC, it didn't work before here.
That's great. I wanna try this out, but can't seem to find anything related to AppleALC with layout-id 27 for the X556UA...
 
Joined
Sep 14, 2017
Messages
20
Motherboard
Razer Blade 15 (2018)
CPU
Intel Core i7-8750H
Graphics
GTX 1070 Max-Q
Mobile Phone
  1. iOS
@uar did you ever get around to patching the new ACPI tables after updating the bios? I had to update mine because my fan was being real weird. Can't launch into Mac anymore because of it and I'm not 100% sure what how to patch them myself :(
 

uar

Joined
Jul 21, 2015
Messages
228
Motherboard
Razer Blade, Clover
CPU
i7-6700HQ
Graphics
HD 530 / GTX 1060, 1920x1080
Mobile Phone
  1. Android
@uar did you ever get around to patching the new ACPI tables after updating the bios? I had to update mine because my fan was being real weird. Can't launch into Mac anymore because of it and I'm not 100% sure what how to patch them myself :(
Same happened to me, so you need to use RehabMan’s config.plist to boot and start all over again. If you need something, just ask! :thumbup:
 
Joined
Sep 14, 2017
Messages
20
Motherboard
Razer Blade 15 (2018)
CPU
Intel Core i7-8750H
Graphics
GTX 1070 Max-Q
Mobile Phone
  1. iOS
Same happened to me, so you need to use RehabMan’s config.plist to boot and start all over again. If you need something, just ask! :thumbup:
THANK YOU!!! Got it to finally boot again. Am I all set now or is there something more I need to do to?
 

uar

Joined
Jul 21, 2015
Messages
228
Motherboard
Razer Blade, Clover
CPU
i7-6700HQ
Graphics
HD 530 / GTX 1060, 1920x1080
Mobile Phone
  1. Android
THANK YOU!!! Got it to finally boot again. Am I all set now or is there something more I need to do to?
If you made everything to work again, then there is nothing to do! :thumbup:
 
Top