Contribute
Register

[Guide] Razer Blade 15 (2018) Detailed Install Guide High Sierra 10.13.6 (17G2208-17G5019)

Joined
Dec 8, 2011
Messages
546
Motherboard
Razer Blade 15 - Clover
CPU
i7-8750H
Graphics
UHD 630/GTX 1060 - 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Do you have the audio issue on the 2018 model as well?

I did a little testing and the power drain is definitely caused by sleep. No idea how to troubleshoot that though. Seems like it's a common issue at least on the 2019 model. See https://github.com/stonevil/Razer_Blade_Advanced_early_2019_Hackintosh/issues/19
Every once in a while the audio bug pops up for me. Sometimes on a reboot the audio sources are missing entirely, but that only happens every once in a while. I've never had to boot into Windows to fix audio though. The issue seems to be more exaggerated on the 2019 model.

The power drain isn't caused by sleep. It's caused by the lack of Power Management for the NVME. Power for it is never shut off, it's always on and it can't throttle power consumption on it because there's no drivers for OSX to interface with it. That's why battery life is better on the Windows side than it is on the Mac side.
 
Joined
May 17, 2011
Messages
153
Motherboard
Razer Blade 15 (2019)
CPU
i7-8750H
Graphics
UHD 630 | RTX 2070
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Every once in a while the audio bug pops up for me. Sometimes on a reboot the audio sources are missing entirely, but that only happens every once in a while. I've never had to boot into Windows to fix audio though. The issue seems to be more exaggerated on the 2019 model.

The power drain isn't caused by sleep. It's caused by the lack of Power Management for the NVME. Power for it is never shut off, it's always on and it can't throttle power consumption on it because there's no drivers for OSX to interface with it. That's why battery life is better on the Windows side than it is on the Mac side.

Oh I wasn't talking about bad battery life in general or battery drain while sleeping.

Right now I'm at 100% battery. I unplugged the laptop from power and closed the lid. Now if I reopen the lid I'm getting keyboard illumination but a black screen. Close and open lid again, everything works. Now if I use the device for a couple of minutes it gets really hot and the fans start spinning. The Energy tab in Activity monitor tells me that I have 1:25h left. Now if I reboot it stays cool and I get about 4:30h of battery life.

I can reproduce this 100% of the time. It's definitely caused by the device going to sleep and I doubt it's the NVME drive. It kind of reminds me of how little battery life I got when the dGPU wasn't turned off via the ssdt, that's why I mentioned it. The CPU is not the problem I think, it's clocked super low and there is no real load or power draw. Temps do get hot on the CPU (I'm at 63 after letting it sit in this weird state for a couple of minutes) but that could be the heat of the GPU heating up the CPU as well.

That's just a theory though as I don't know how to check.
 
Joined
Dec 8, 2011
Messages
546
Motherboard
Razer Blade 15 - Clover
CPU
i7-8750H
Graphics
UHD 630/GTX 1060 - 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Oh I wasn't talking about bad battery life in general or battery drain while sleeping.

Right now I'm at 100% battery. I unplugged the laptop from power and closed the lid. Now if I reopen the lid I'm getting keyboard illumination but a black screen. Close and open lid again, everything works. Now if I use the device for a couple of minutes it gets really hot and the fans start spinning. The Energy tab in Activity monitor tells me that I have 1:25h left. Now if I reboot it stays cool and I get about 4:30h of battery life.

I can reproduce this 100% of the time. It's definitely caused by the device going to sleep and I doubt it's the NVME drive. It kind of reminds me of how little battery life I got when the dGPU wasn't turned off via the ssdt, that's why I mentioned it. The CPU is not the problem I think, it's clocked super low and there is no real load or power draw. Temps do get hot on the CPU (I'm at 63 after letting it sit in this weird state for a couple of minutes) but that could be the heat of the GPU heating up the CPU as well.

That's just a theory though as I don't know how to check.

That has to be a 2019 model specific issue or there's something in Power Management and the GPU disable parts that you missed. I have never once experienced what you just described. Though you are getting better battery life than myself after your reboot. That's a really odd thing to happen
 
Joined
May 17, 2011
Messages
153
Motherboard
Razer Blade 15 (2019)
CPU
i7-8750H
Graphics
UHD 630 | RTX 2070
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
That has to be a 2019 model specific issue or there's something in Power Management and the GPU disable parts that you missed. I have never once experienced what you just described. Though you are getting better battery life than myself after your reboot. That's a really odd thing to happen

It does seem like a 2019 issue because others experience it as well (hence the github issue) and it really is very odd. That makes it hard to google too. I might open a seperate thread with all the debug outputs and files when I find the time.

The 4:30h thing was just an estimate on what I've seen before, right now after rebooting it sits at 3:07 but it's climbing. What helps battery life is the CPU friend thing in stonevils guide, you should check it out. It allows the CPU to clock itself down more. Also undervolting helps but I haven't done that yet (I do it in Windows with Throttlestop, just not in the BIOS). You'll have to unlock some more options in the BIOS to do it. It's safe to do so though, the mid 2019 model is undervolted from the factory.
 
Joined
Dec 8, 2011
Messages
546
Motherboard
Razer Blade 15 - Clover
CPU
i7-8750H
Graphics
UHD 630/GTX 1060 - 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
It does seem like a 2019 issue because others experience it as well (hence the github issue) and it really is very odd. That makes it hard to google too. I might open a seperate thread with all the debug outputs and files when I find the time.

The 4:30h thing was just an estimate on what I've seen before, right now after rebooting it sits at 3:07 but it's climbing. What helps battery life is the CPU friend thing in stonevils guide, you should check it out. It allows the CPU to clock itself down more. Also undervolting helps but I haven't done that yet (I do it in Windows with Throttlestop, just not in the BIOS). You'll have to unlock some more options in the BIOS to do it. It's safe to do so though, the mid 2019 model is undervolted from the factory.
I would open up a separate thread and see if someone more advanced in the Hackintosh world can help you pin point the issue. I'm just a weekend warrior.

I did just go through stonevils guide and did CPU PM Implementation with CPU Friend, unfortunately the 2018 version doesn't have the same capabilities with BIOS undervolting, so I can't do any of that. But bringing my lowest clock setting down to 800MHz should make a pretty good difference battery life wise. We shall see here in the next day.

There's a bunch of new stuff I have to implement and update the guide for. CPU Friend is one of those, as well as the GPIO Pinning of the new Touchpad Drivers. Working on that right now, just waiting to get my hands on a new external mouse before I really dive into that, don't want to be stuck without a mouse to use incase I break something lol
 
Joined
Feb 22, 2013
Messages
25
Motherboard
Asus ROG maximus impact VIII
CPU
i5-6600k
Graphics
GTX 980 Ti MSI
Mac
Classic Mac
Mobile Phone
Joined
Oct 30, 2018
Messages
117
Motherboard
Razer Blade 15-Clover
CPU
i7-8750H
Graphics
UHD 630+GTX 1060, 1920x1080
Mobile Phone
  1. iOS
Joined
Feb 22, 2013
Messages
25
Motherboard
Asus ROG maximus impact VIII
CPU
i5-6600k
Graphics
GTX 980 Ti MSI
Mac
Classic Mac
Mobile Phone
Lost sleep is very bad for me, won't update then :(
What Blade you have?
Fair enough. It's a 2018 advanced (GTX1070). Trying to pin down the problem with pmset but so far not so good.
 
Joined
Oct 30, 2018
Messages
117
Motherboard
Razer Blade 15-Clover
CPU
i7-8750H
Graphics
UHD 630+GTX 1060, 1920x1080
Mobile Phone
  1. iOS
Joined
Dec 8, 2011
Messages
546
Motherboard
Razer Blade 15 - Clover
CPU
i7-8750H
Graphics
UHD 630/GTX 1060 - 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Hi lads,

Updated to Catalina from the App store, everything went well except for my bluetooth card (DW1830), I had to use modified kexts and it works now (see https://www.insanelymac.com/forum/t...na-broadcom-bluetooth-firmware-upload/?page=5) if you have that issue.

However, the machine lost the ability to sleep, let us know if you have similar issues.

Cheers
I might play with installing Catalina on a separate partition to do some troubleshooting, but it's honestly not a very big priority for me since so many audio based applications that I use are heavily advising against Catalina as they're not yet compatible. But if I get some free time, I might look into playing around with it.

But have you gone through and made sure things like your graphics set up is still good? Does sleep work without the bluetooth drivers?

I would strip the install to the bare minimum needed to function and see if sleep works and then start adding in functionality to see what breaks sleep.
 
Top