Contribute
Register

[Guide] Razer Blade 15 (2018) Detailed Install Guide High Sierra 10.13.6 (17G2208-17G5019)

Joined
Jul 24, 2013
Messages
124
Motherboard
Razer Blade 15 (2018)
CPU
I7-8750H
Graphics
GTX 1070HQ
Mac
  1. iMac
  2. MacBook
  3. Mac mini
Classic Mac
  1. iBook
  2. iMac
Mobile Phone
  1. iOS
My audio through headphones was messed up but only the first time before restarting. Every time after that has been fine. Are you sure you're using the latest AppleALC kext? That link is here in case you're using the one from this thread.
AppleALC by Acidanthera
Yeah I've grabbed the newest version from Github. Thanks though!

Test everything with the latest updates in the 1/11/19 guide update and report back. The framebuffer bug should be gone.

As far as the audio goes. It's a bug with AppleALC. It should only happen once in a while. Though the latest update it seems to happen a lot less. Since all of the latest updates I have done to the laptop, I have not had it happen, yet.
I'll give it a shot when I get a chance! Thanks again for all the work you have put into this.
 
Joined
Dec 8, 2011
Messages
546
Motherboard
Razer Blade 15 - Clover
CPU
i7-8750H
Graphics
UHD 630/GTX 1060 - 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
@mr-prez @lunaoso there might be boot ups where the laptop hangs. It's just the nature of a hackintosh laptop. In the future we might get to 100%, but it will take some time to totally fine tune it.
Right now it's fine tuned to the point where it's booting 99% of the time and is stable with 99% functionality. I'll take that for now.
 
Joined
Jul 24, 2013
Messages
124
Motherboard
Razer Blade 15 (2018)
CPU
I7-8750H
Graphics
GTX 1070HQ
Mac
  1. iMac
  2. MacBook
  3. Mac mini
Classic Mac
  1. iBook
  2. iMac
Mobile Phone
  1. iOS
@mr-prez @lunaoso there might be boot ups where the laptop hangs. It's just the nature of a hackintosh laptop. In the future we might get to 100%, but it will take some time to totally fine tune it.
Right now it's fine tuned to the point where it's booting 99% of the time and is stable with 99% functionality. I'll take that for now.
Just went through your latest update, 2/2 on boots so far! Looks good to me, thanks for the update.

And I'm definitely cool with 99% working, like you said, it's to be expected with a Hackintosh. Having 20% working was definitely getting annoying after a few days though, so I'm super excited to have that fixed. You definitely deserve a lot of beers this weekend :)
 
Joined
Dec 8, 2011
Messages
546
Motherboard
Razer Blade 15 - Clover
CPU
i7-8750H
Graphics
UHD 630/GTX 1060 - 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Just went through your latest update, 2/2 on boots so far! Looks good to me, thanks for the update.

And I'm definitely cool with 99% working, like you said, it's to be expected with a Hackintosh. Having 20% working was definitely getting annoying after a few days though, so I'm super excited to have that fixed. You definitely deserve a lot of beers this weekend :)
Unfortunately I work weekends, so no beer for me until Sunday night haha
 
Joined
May 15, 2018
Messages
26
Motherboard
Razer Blade 15
CPU
i7 8750H
Graphics
UHD 630, 1070 GTX, 4K Display
Can’t seem to find the windows bundle attached for AfuWin64?
Never mind I found it online. Will try this weekend.
 
Last edited:
Joined
Dec 8, 2011
Messages
546
Motherboard
Razer Blade 15 - Clover
CPU
i7-8750H
Graphics
UHD 630/GTX 1060 - 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Can’t seem to find the windows bundle attached for AfuWin64?
Never mind I found it online. Will try this weekend.
My mistake on this, I forgot to upload the Windows Bundle folder. Just fixed that, should be all good now.
 
Joined
Sep 14, 2017
Messages
20
Motherboard
Razer Blade 15 (2018)
CPU
Intel Core i7-8750H
Graphics
GTX 1070 Max-Q
Mobile Phone
  1. iOS
Updated to the newest kexts & patches last night and so far so good for me. No black screen when booting up and so far no KP/freezing. Thanks so much for the guide! Never was able to get trackpad functioning 100% on my old 2016 blade so it's nice to finally have a fully functioning hackintosh.
 
Joined
May 15, 2018
Messages
26
Motherboard
Razer Blade 15
CPU
i7 8750H
Graphics
UHD 630, 1070 GTX, 4K Display
Updated to the newest kexts & patches last night and so far so good for me. No black screen when booting up and so far no KP/freezing. Thanks so much for the guide! Never was able to get trackpad functioning 100% on my old 2016 blade so it's nice to finally have a fully functioning hackintosh.
Did you go the Mojave route? Im having some issues with the guide and the 1070. I just have a feeling its Mojave
 
Joined
Oct 27, 2015
Messages
94
Motherboard
EliteBook 850 G2
CPU
i7-5500U
Graphics
HD5500
Did you go the Mojave route? Im having some issues with the guide and the 1070. I just have a feeling its Mojave

Mojave will operate in the same way as the special build of High Sierra. What exactly are your issues?
 
Joined
Dec 8, 2011
Messages
546
Motherboard
Razer Blade 15 - Clover
CPU
i7-8750H
Graphics
UHD 630/GTX 1060 - 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Did you go the Mojave route? Im having some issues with the guide and the 1070. I just have a feeling its Mojave
Don't expect the Nvidia 1070 to be fully functional on Mojave. There are no drivers for Mojave yet, if you do get the Nvidia card to work, it most likely won't be full acceleration/will be glitchy.
 
Top