Contribute
Register

[GUIDE] OC 10.13.6 Z490 Gigabyte Aorus Xtreme + Core i5 10400 + Nvidia GTX 1060

Joined
Aug 29, 2021
Messages
18
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10850K
Graphics
GTX1080ti
@Middleman, thank you for assembling. I was guided by it when I bought the z490D.
I am using your version from the first post (EFI for High Sierra) and configurator for 0.6.5. The version number is not important to me. The main thing is that everything works. Only annoying messages at system startup.
 

Attachments

  • IMG_2645.JPG
    IMG_2645.JPG
    4.6 MB · Views: 9
Joined
May 11, 2011
Messages
1,720
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
@Middleman, thank you for assembling. I was guided by it when I bought the z490D.
I am using your version from the first post (EFI for High Sierra) and configurator for 0.6.5. The version number is not important to me. The main thing is that everything works. Only annoying messages at system startup.
Great!
As for the annoying messages, you can remove the -v boot-arg under the NVRAM section.

You’re welcome!
 
Joined
Sep 19, 2018
Messages
11
Motherboard
Z370-I Gaming
CPU
i7-8700K
Graphics
UHD630 / Radeon VII
Mac
  1. iMac
So, aside from all the very helpful off topic stuff, your build is working well?

I'm looking at the z490 aorus extreme as an alternative to the vision d + 10G card. I'd like to run big sur (transfer from my current z370 build)..
Nice to see that both ethernet ports and thunderbolt work.

Can you eleborate on how the thunderbolt is working - Have you tested it?
TB hotplug?
USB-2/3/C hotplug on the thunderbolt ports?

Have you looked into flashing the thunderbolt chip and enabling thunderbolt bus?
Could potentially use one of the firmwares already available for vision d...maybe.

And of course the AX201 wifi is a CNVi/CRF module, is it like other gigabyte z490 boards in that the m2 wifi slot cannot do pcie?
In that case I could fit a T919 in the bottom pcie slot, since it already has 10GB ethernet.
 
Joined
May 11, 2011
Messages
1,720
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
So, aside from all the very helpful off topic stuff, your build is working well?

I'm looking at the z490 aorus extreme as an alternative to the vision d + 10G card. I'd like to run big sur (transfer from my current z370 build)..
Nice to see that both ethernet ports and thunderbolt work.

Can you eleborate on how the thunderbolt is working - Have you tested it?
TB hotplug?
USB-2/3/C hotplug on the thunderbolt ports?

Have you looked into flashing the thunderbolt chip and enabling thunderbolt bus?
Could potentially use one of the firmwares already available for vision d...maybe.

And of course the AX201 wifi is a CNVi/CRF module, is it like other gigabyte z490 boards in that the m2 wifi slot cannot do pcie?
In that case I could fit a T919 in the bottom pcie slot, since it already has 10GB ethernet.
Yes the build is working fine, just that right now it’s not my most active setup - that is reserved for my Gigabyte B550 Vision D build which is in my office at work.

As for the Thunderbolt, it works on this setup but not via hotplug (tested only on boot up). And yes the TB USB-C port also works as does TB2/1 devices.

As for the Thunderbolt BIOS controller flashing, I had looked into it for this board but not decided yet. CaseySJ has it documented for his Z490 Vision D board but there are no guides yet for the Aorus Xtreme afaik. I would think it wouldn’t be too dissimilar to older Gigabyte flashing methods if there is one. It will likely involve a chip programmer and some jumper wires.
 
Joined
Sep 19, 2018
Messages
11
Motherboard
Z370-I Gaming
CPU
i7-8700K
Graphics
UHD630 / Radeon VII
Mac
  1. iMac
As for the Thunderbolt BIOS controller flashing, I had looked into it for this board but not decided yet. CaseySJ has it documented for his Z490 Vision D board but there are no guides yet for the Aorus Xtreme afaik. I would think it wouldn’t be too dissimilar to older Gigabyte flashing methods if there is one. It will likely involve a chip programmer and some jumper wires.
afaik, the issue is that the the firmware includes parts for diifferent things - the thunderbolt controller itself, and also a section for power stuff which can differ per board (as i said AFAIK, I'm keen to read more detail as I'm comfortable getting into this stuff). So the stock firmware and apple/alternate firmware need to be compared and blended so that the right parts are there for your hardware but with only the parts changed that are needed for Apples thunderbolt extended mode.

But yes it would make sense for the AO extreme and Vision D to share a lot of the same work. Maybe the vision D thunderbolt firmware is good to go. I'd like to know how to compare/check that.
 
Joined
May 11, 2011
Messages
1,720
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
afaik, the issue is that the the firmware includes parts for diifferent things - the thunderbolt controller itself, and also a section for power stuff which can differ per board (as i said AFAIK, I'm keen to read more detail as I'm comfortable getting into this stuff). So the stock firmware and apple/alternate firmware need to be compared and blended so that the right parts are there for your hardware but with only the parts changed that are needed for Apples thunderbolt extended mode.

But yes it would make sense for the AO extreme and Vision D to share a lot of the same work. Maybe the vision D thunderbolt firmware is good to go. I'd like to know how to compare/check that.
Yes indeed.

Well if it helps, you can find the guides here. CaseySJ has written quite a bit of it in detail.
>https://www.tonymacx86.com/threads/gigabyte-z490-vision-d-thunderbolt-3-i5-10400-amd-rx-580.298642/
(under Thunderbolt Bus Activation section)

here > https://www.tonymacx86.com/threads/...erbolt-3-i7-9700k-amd-rx-580.267551/page-1639

and > https://www.tonymacx86.com/threads/...700k-amd-rx-580.267551/page-2687#post-2186155 (full guide)

As it is also a Titan Ridge chipset, I would think the Z490 Aorus Xtreme should be functionally close to the Z490 Vision D. Remember however to backup your original firmware first with the programmer/Pi before going ahead with the update.
 
Joined
Oct 19, 2014
Messages
91
Motherboard
Asus B460M-A (r2)
CPU
i5 10400
Graphics
UHD 630
Mobile Phone
  1. Android
Mobo: Asus B460M-A (r2) (H470 Chipset)
CPU: i5 10400
GPU: Asus RX580 8GB

I successfully tested catalina 10.15.6 and big sur 11.5.2 on this configuration.
but now i wanna boot my old 10.13.6 High Sierra on this configuration. so i build EFI (attached) and it booted successfully HS 10.13.6 . Quick Sync is also working.
Only issues are
1. USB 2.0 ports not working.
2.My ALC897audio not working , only HDMI audio working
3.i wanna make EFI for OC 0.6.6

plz help.
 

Attachments

  • EFI.zip
    26 MB · Views: 5
  • Screen Shot 2021-09-28 at 3.43.52 AM.png
    Screen Shot 2021-09-28 at 3.43.52 AM.png
    43.6 KB · Views: 7
Joined
May 11, 2011
Messages
1,720
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Mobo: Asus B460M-A (r2) (H470 Chipset)
CPU: i5 10400
GPU: Asus RX580 8GB

I successfully tested catalina 10.15.6 and big sur 11.5.2 on this configuration.
but now i wanna boot my old 10.13.6 High Sierra on this configuration. so i build EFI (attached) and it booted successfully HS 10.13.6 . Quick Sync is also working.
Only issues are
1. USB 2.0 ports not working.
2.My ALC897audio not working , only HDMI audio working
3.i wanna make EFI for OC 0.6.6

plz help.

Hi there,

Okay I've had a quick look, and added in the necessary changes for your EFI. It is now on OC 0.6.6.
For the audio I've changed ALCID to layout-id 69.

For the USB, you'll need to use a USB script such as Corpnewt's USBMap tool in Terminal and add in the USB 2.0 ports by using USB 2.0 connected peripherals on the USB 2.0 ports and testing them before creating the new USBMap kext > https://github.com/corpnewt/USBMap

I've uploaded the new EFI. Give it a shot.
 

Attachments

  • EFI-2.zip
    26.4 MB · Views: 9
Joined
Oct 19, 2014
Messages
91
Motherboard
Asus B460M-A (r2)
CPU
i5 10400
Graphics
UHD 630
Mobile Phone
  1. Android
Hi there,

Okay I've had a quick look, and added in the necessary changes for your EFI. It is now on OC 0.6.6.
For the audio I've changed ALCID to layout-id 69.

For the USB, you'll need to use a USB script such as Corpnewt's USBMap tool in Terminal and add in the USB 2.0 ports by using USB 2.0 connected peripherals on the USB 2.0 ports and testing them before creating the new USBMap kext > https://github.com/corpnewt/USBMap

I've uploaded the new EFI. Give it a shot.
thanks for reply. i tried your EFI but no luck with Audio i tried layout-id 66 and 69 both.
i can fix USB issue that not big deal. but audio is very imp for me. Audio ALC897 works properly in catalina and big sur . whats problem here i m unable to find out.

My kind request to you can u build a same EFI for Clover. as clover is very friendly with High sierra according to my past experience.

i did some research and came to conclusion that AppleHDA of 10.13.6 doesn't support ALC 897 codec
so is there any way to patch it or how can i use catalina's AppleHDA in high sierra ?
 
Last edited:
Joined
May 11, 2011
Messages
1,720
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
thanks for reply. i tried your EFI but no luck with Audio i tried layout-id 66 and 69 both.
i can fix USB issue that not big deal. but audio is very imp for me. Audio ALC897 works properly in catalina and big sur . whats problem here i m unable to find out.

My kind request to you can u build a same EFI for Clover. as clover is very friendly with High sierra according to my past experience.

i did some research and came to conclusion that AppleHDA of 10.13.6 doesn't support ALC 897 codec
so is there any way to patch it or how can i use catalina's AppleHDA in high sierra ?
You're welcome.

With regards to a High Sierra build, I don't have one on this with Clover, but I do have another laptop build for Clover on High Sierra which you could adapt. You'd have to add in your own SMBIOS values and change the FakeCPUID, videocard and Mac system ID values to iMac18,3 to match your setup. > https://www.tonymacx86.com/threads/...10-13-6-intel-vram-trackpad-fix-guide.308477/

As for the ALC897 issue, if there are no drivers for it then there's really no other way to enable it. Hacking or tweaking the Catalina AppleHDA to High Sierra may be troublesome and likely yield system instabilities. So what would be the best option here? I suggest it would be best to get hold of a Mac-compatible external USB DAC and use that instead to output, such as a Gigabyte Aorus Essential USB DAC or SoundBlaster Omni
> https://www.gigabyte.com/Motherboard/ESSential-USB-DAC#kf
> https://www.creative.com/p/sound-blaster/sound-blaster-omni-surround-5-1
 
Top