Contribute
Register

Guide: Multibooting UEFI on Separate Drives

Going Bald

Moderator
Joined
Aug 14, 2010
Messages
23,062
Motherboard
GA-X58A-UD7-F7
CPU
W3670
Graphics
RX 580
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
iMac
Good afternoon.

The truth is that more than a problem, it is a minor inconvenience, which fortunately allowed me to work perfect, but I hate to see it. See if you can give me a little hand and we solve.

We will begin.

Installing clover and windows in UEFI mode. From clover botting perfectly windows and osx, but now comes the downside.

I have a hotswap with 4 discs (3 storage and one hd windows), and where SSD is installed osx.

From clover in the GUI I see only two units (both osx recovery units as non-booting disks, have hidden). Can anyone tell me the reason why the unit is the first windows displayed (left) and osx (right) although the boot is the osx by setting clover?

Thank you in advance.
Possibility exists Clover looks at UEFI/BIOS scan of SATA ports. On board, which ports are Windows / OS X connected?
Check Manual - gives order of ports SATA P0, SATA P1, SATA P2, etc. increment by 1 each additional SATA port from PCH up to 10 ports maximum. If Windows drive on P0 and OS X on drive P1, Windows shows in list of icons on Clover screen first (left most icon).
 
Joined
Aug 15, 2011
Messages
77
Motherboard
EVGA-Z370 FTW
CPU
i7-8700K
Graphics
R9 290X
Mac
iMac
Mobile Phone
Android
Thank you for the reply.

I don't think thay it will be the reason.

P0= dvd/BR player
P1= SSD Osx system
P2= Hdd 1 Tb storage
P3= Hdd 1 Tb Storage
p4= hdd 1 tb Storage
p5= Hdd Windows drive

Sincerly I don't remember when was the change, but I remember that the first Icon was osx and then windows icon.

It could be the reason that I had hidden the other drives?
 
Last edited:

Going Bald

Moderator
Joined
Aug 14, 2010
Messages
23,062
Motherboard
GA-X58A-UD7-F7
CPU
W3670
Graphics
RX 580
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
iMac
Thank you for the reply.

I don't think thay it will be the reason.

P0= dvd/BR player
P1= SSD Osx system
P2= Hdd 1 Tb storage
P3= Hdd 1 Tb Storage
p4= hdd 1 tb Storage
p5= Hdd Windows drive

Sincerly I don't remember when was the change, but I remember that the first Icon was osx and then windows icon.

It could be the reason that I had hidden the other drives?
Possibly - I do not know enough about Clover code to say for sure.
 
Joined
Aug 15, 2011
Messages
77
Motherboard
EVGA-Z370 FTW
CPU
i7-8700K
Graphics
R9 290X
Mac
iMac
Mobile Phone
Android
Thanks for all.

I hope that some gurus of the forum could say something about it.

My knowledge is enough like you about clover. I will be more happy if I will have more knowledge about it.
 
Joined
Mar 6, 2016
Messages
106
Motherboard
Asus Maximus VIII Gene Z170
CPU
i7-6700K
Graphics
5600XT
Mobile Phone
iOS
Hi, I have a basic (i.e. Noob) question about efi. I'm a couple of weeks out from building my first hack and am working through the installation details. I plan to have OS X on one ssd and Windows on another. From what I gather / guess OS X does an efi installation by default, so when you use disk utility to make a single guid / macos extended partition it's actually also making an efi partition.

Im assuming that I only need an efi partition on one drive not both. Does it matter which drive has it? OS X is never going away but Windows might someday in which case would I want the efi partition on the Mac drive so if I turn the Windows drive into a data drive everything will still boot correctly?

Thanks,


G
 
Joined
May 10, 2016
Messages
105
Motherboard
Gigabyte Z170MX
CPU
I7 6700k
Graphics
HD 530 IGFX; GIGABYTE RX 460
Mac
MacBook Pro
Mobile Phone
iOS
Hi

Deleted second partition on my drive leaving the EFI partition

Tried changing storage boot option control from Legacy to uefi and CSM off/on and all combinations but it just keeps saying "disk is of the gpt partitions style" and refuses to install!!

Anyone help please?
 

Going Bald

Moderator
Joined
Aug 14, 2010
Messages
23,062
Motherboard
GA-X58A-UD7-F7
CPU
W3670
Graphics
RX 580
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
iMac
Hi

Deleted second partition on my drive leaving the EFI partition

Tried changing storage boot option control from Legacy to uefi and CSM off/on and all combinations but it just keeps saying "disk is of the gpt partitions style" and refuses to install!!

Anyone help please?
This is telling you that your Windows installer was made for Legacy Mode installation only. Create a new USB Windows installer and make sure it contains both Legacy and UEFI by using the Windows media creator or make a UEFI only installer using Rufus.
Either way will work.
 
Joined
May 10, 2016
Messages
105
Motherboard
Gigabyte Z170MX
CPU
I7 6700k
Graphics
HD 530 IGFX; GIGABYTE RX 460
Mac
MacBook Pro
Mobile Phone
iOS
Many thanks Going Bald - I was just beginning to realise this when I received your reply - after reading another of your threads whereby you were trying to explain this to another user ( and it wasn't sinking in so you gracefully bowed out! )

Spent 2 months getting my hack working and this was final thing getting to dual boot, however I have the OS X side to do all over again on release day of Mac OS Sierra on the 20th. This is because I have purchased a gigabyte RX 460 and have been working on hd 530 up to now.

I figured a clean install on that day would be wise even though a lot of work, and would consider what I've done up to now as not wasted just "training" for the main event.

Only thing I didn't get was DSDT as my i7 6700k wasn't supported by the script I was using, but that's for another thread, sure I'll get there in the end. Thanks again
 

Going Bald

Moderator
Joined
Aug 14, 2010
Messages
23,062
Motherboard
GA-X58A-UD7-F7
CPU
W3670
Graphics
RX 580
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
iMac
Many thanks Going Bald - I was just beginning to realise this when I received your reply - after reading another of your threads whereby you were trying to explain this to another user ( and it wasn't sinking in so you gracefully bowed out! )

Spent 2 months getting my hack working and this was final thing getting to dual boot, however I have the OS X side to do all over again on release day of Mac OS Sierra on the 20th. This is because I have purchased a gigabyte RX 460 and have been working on hd 530 up to now.

I figured a clean install on that day would be wise even though a lot of work, and would consider what I've done up to now as not wasted just "training" for the main event.

Only thing I didn't get was DSDT as my i7 6700k wasn't supported by the script I was using, but that's for another thread, sure I'll get there in the end. Thanks again
To get your ACPI tables, DSDT, SSDTs etc at the Clover screen hit F4 (or maybe fn+F4) and Clover dumps them in the Clover/ACPI/orig folder.
 
Joined
May 10, 2016
Messages
105
Motherboard
Gigabyte Z170MX
CPU
I7 6700k
Graphics
HD 530 IGFX; GIGABYTE RX 460
Mac
MacBook Pro
Mobile Phone
iOS
To get your ACPI tables, DSDT, SSDTs etc at the Clover screen hit F4 (or maybe fn+F4) and Clover dumps them in the Clover/ACPI/orig folder.
That's a great help and something I was unaware of - really appreciate it thank you
 
Top