Contribute
Register

[GUIDE] : MSI Z97-Gaming 7 | i5-5675C Broadwell | HD6200 | 8GB 2400MHz OS X El Capitan

Joined
Nov 14, 2015
Messages
12
Mac
Classic Mac
Mobile Phone
I can't find the gaming 7, will the 5 work?

Gigabyte GA-Z97X-GAMING 5 LGA 1150 Z97 115dB SNR HD Audio with Built-In Rear Audio Amplifier ATX Motherboard https://www.amazon.com/dp/B00JKCHEQ2/?tag=tonymacx86com-20

My 4790k is on its way and need a mobo with the least issues and the most compatibility, and this seems to work well in both regards.

thanks!
 

wildwillow

Moderator
Joined
Jun 26, 2012
Messages
4,639
Motherboard
GA-Z87X-OC
CPU
i7-4770K
Graphics
HD4600+R9 380 4GB
Mac
MacBook Pro
Classic Mac
Mobile Phone
iOS, Other
I can't find the gaming 7, will the 5 work?

Gigabyte GA-Z97X-GAMING 5 LGA 1150 Z97 115dB SNR HD Audio with Built-In Rear Audio Amplifier ATX Motherboard https://www.amazon.com/dp/B00JKCHEQ2/?tag=tonymacx86com-20

My 4790k is on its way and need a mobo with the least issues and the most compatibility, and this seems to work well in both regards.

thanks!
You'll probably find this guide more appropriate [Guide] Z97MX-Gaming 5 | i7 4790K | GTX 970 G1 | OS X 10.11. It has the same audio codec and ethernet as you as the boards are almost identical other than size.
 

wildwillow

Moderator
Joined
Jun 26, 2012
Messages
4,639
Motherboard
GA-Z87X-OC
CPU
i7-4770K
Graphics
HD4600+R9 380 4GB
Mac
MacBook Pro
Classic Mac
Mobile Phone
iOS, Other
Having difficulty getting my i5-57675C to enable HD6200. If convenient, attach a current IOReg and config.plist. Thanks.
I was injecting framebuffer (0x16220002) through the config.plist to start. When enabling HDMI audio I used your ssdt_hdmi-hd6200. But I've changed framebuffers since then due to a conflict with the DP. I won't ramble on about here as I posted my findings in your guide Post#860. Haven't updated this guide yet..

Note: 10.11.1 About This Mac - Intel Iris Pro Graphics 6200 1536MB
10.11.2 (beta) About this Mac - Intel Graphics 1536MB. Same framebuffer loading seems cosmetic.

Attached is config.plist and IOReg.
 

Attachments

Joined
Nov 9, 2013
Messages
51
Motherboard
MSI Z170A Gaming Pro
CPU
i7-6700k 4.4GHz - Corsair H110i
Graphics
MSI GTX 1070 Gaming 8GB - EVGA 970 SSC ACX 2.0+
Mac
MacBook
Classic Mac
Performa
Mobile Phone
iOS
So the MSI Gaming Z97 and Z97A 5,6,7 more than likely use PCIe 2.0 x2/x4(not really a difference in the 2) Yeah theres been a lot of miss information with there Tech specs, good to know the NVME versions will still work in them though since they're pretty much the same pice as the AHCI variants at 3.0 and 2.0 speeds, so might as well buy the Samsung 950 Pro when I have the chance so when I upgrade in the future I won't have to buy another SSD. Finally someone whose checked! lol appreciate that, as far as the USB goes in the Z97A 6 its a bit weird and wonky, getting the speeds to work requires to install the USBInject all kext, and the XHCI patches but that didn't make them work for me but once I uninstalled them then 3.0 speed kicked in. Seems weird but Im not questioning it, theres a lot of weirdness with these boards but they do work great. One thing I've noticed with mine though, you can't check the devices connected to SATA though System Information haven't looked into it, but it refuses to load. Not too worried about it because Disk Sensei shows Trim is enabled through there enabler and I have TrimEnable Force turned on so between the 2 it should be working lol
 
Joined
Nov 9, 2013
Messages
51
Motherboard
MSI Z170A Gaming Pro
CPU
i7-6700k 4.4GHz - Corsair H110i
Graphics
MSI GTX 1070 Gaming 8GB - EVGA 970 SSC ACX 2.0+
Mac
MacBook
Classic Mac
Performa
Mobile Phone
iOS
All in all though other than the wonky USB its a really easy setup, and IMessage works and everything 0 complaints other than USB but thats an actual OS X Issue
 

wildwillow

Moderator
Joined
Jun 26, 2012
Messages
4,639
Motherboard
GA-Z87X-OC
CPU
i7-4770K
Graphics
HD4600+R9 380 4GB
Mac
MacBook Pro
Classic Mac
Mobile Phone
iOS, Other
HD6200 problem solved using the upper HDMI connector (Z97N-WiFi).
Been caught out on that one with the H77N-WiFi.
 

wildwillow

Moderator
Joined
Jun 26, 2012
Messages
4,639
Motherboard
GA-Z87X-OC
CPU
i7-4770K
Graphics
HD4600+R9 380 4GB
Mac
MacBook Pro
Classic Mac
Mobile Phone
iOS, Other
so might as well buy the Samsung 950 Pro when I have the chance so when I upgrade in the future I won't have to buy another SSD.
Glad you have your system figured out. As for the Samsung 950, I'd hold back on any NVMe drive for OS X at the moment. If it is for Windows then as I mentioned it works. Personally as the Z97 MSI boards are running these drives at PCI 2.0 x2 and not PCI 3.0 x4(half speed) any of these drives are merely wasted money versus speed, you'd be better off with twice the size Sata SSD.
 
Top