Contribute
Register

[Guide] MSI GF62VR 7RF, High Sierra 10.13.2

Joined
Oct 23, 2017
Messages
209
Motherboard
Hp pavilion dv6-6c65sx (Legacy)
CPU
I7-2670QM/HM65
Graphics
INTEL HD 3000/ Radeon HD 6700M 1366x768
Mobile Phone
Android
This is a guide for the MSI GF62VR 7RF laptop. I am noob tester not expert. I am not sure if I did the right or the wrong thing during the process I can accept your comments below. My aim is to provide easy steps for what I did to make my laptop works with high sierra 10.13.2.
In this guide I used 2 usb sandisk sticks. 16gb usb to make mac high sierra 10.13.2 usb installer and 32gb usb to install high sierra on because I didn't want to mess with my internal hard drive and ssd.
Also I used linksys ae6000 wifi usb because my internal wifi is not supported on high sierra.

Many thanks to Rehabman who helped me during this process.

I made a guide with sierra 10.12.6 on the same laptop and I followed the same steps here. You can notice I walked through that guide except there is slight differences on the making usb installer and setting up usb configuration (when I searched for change 15 port limit to 26 in XHCI kext that has MatchOS = 1012.x then copied it to my config.plist)
https://www.tonymacx86.com/threads/guide-msi-gf62vr-7rf-with-sierra-10-12-6.241631/


* Do you have the same laptop and you are noob and lazy to follow my guide?
You can walk through my guide from Making usb installer to Installing high sierra on the target then download clover folder and zip file I renamed it "MSI GF62VR 7RF essential kexts" both are in the attachement. The clover needs to be replaced to your clover folder and kexts needs to be installed by kexts utility. Don't forget to install AppleBacklightInjector.kext to /L/E by typing in terminal
Code:
sudo cp -R *The path where you put AppleBacklightInjector.kext* /Library/Extensions
Code:
sudo kextcache -i /
- restart the system

After that you got high sierra 10.13.2 fully working without needing to walk through the rest of my guide except fixing app store.

Making usb installer
- reset Bios to default then I set boot mode to UEFI with CSM
- I Downloaded mac high sierra 10.13.2 from mac app store.
- In terminal
Code:
diskutil list
Code:
# repartition /dev/disk1 GPT, one partition
# EFI will be created automatically
# second partition, "install_osx", HFS+J, remainder
diskutil partitionDisk /dev/disk1 1 GPT HFS+J "install_osx" R
[note] /dev/disk1 is for usb 16gb sandisk

- Downloaded LATEST REHABMAN CLOVER https://bitbucket.org/RehabMan/clover/downloads/
- selected the target of the install to "install_osx"
- checked "Install for UEFI booting only "and "Install Clover in the ESP"
- checked "BGM" from Themes
- checked "OsxAptioFixDrv-64" and "EmuVariableUefi-64.efi'' from Drivers64UEFI

- After I installed the clover I downloaded and copied (FakeSMC.kext,VoodooPS2Controller.kext,SATA-100-series-unsupported.kext) to /EFI/CLOVER/kexts/Other. And downloaded and copied HFSPlus.efi to /EFI/Clover/drivers64UEFI.

- I chose config_HD615_620_630_640_650.plist renamed it to config.plist replaced it in /EFI/Clover.

- in terminal:
Code:
# copy installer image
sudo "/Applications/Install macOS High Sierra.app/Contents/Resources/createinstallmedia" --volume  /Volumes/install_osx --nointeraction
- after it finished I renamed it again
Code:
# rename
sudo diskutil rename "Install macOS High Sierra" install_osx

Installing high Sierra on the target

- after I booted from usb drive I reached the installer and my 32usb needed to be formatted to Extended (Journaled) GUID using disk utility in order to install on it.
- after restart I booted from the 16gb usb again then chose in the clover the hard drive that I renamed before to complete the installation.
- I launched latest rehabman's clover again in order to install the clover in the 32gb usb and became bootable
In the clover:
- selected the target of the install to "my clover 32usb" depends on the name during format
- checked "Install for UEFI booting only "and "Install Clover in the ESP"
- checked "BGM" from Themes
- checked "OsxAptioFixDrv-64" and "EmuVariableUefi-64.efi'' from Drivers64UEFI
- selected "Install RC scripts on target volume"
After installation EFI drive showed up then I copied (FakeSMC.kext,VoodooPS2Controller.kext,SATA-100-series-unsupported.kext) to /EFI/CLOVER/kexts/Other
- installed (FakeSMC.kext,VoodooPS2Controller.kext,SATA-100-series-unsupported.kext) using kext utility.
- copied HFSPlus.efi to /EFI/Clover/drivers64UEFI. Then the 32gb usb became bootable.
- Restarted and booted my 32gb usb

Post installation

Show hidden files:
I used this to show hidden files.
In terminal
Code:
defaults write com.apple.finder AppleShowAllFiles YES
sign out
———
Linksys AE6000 wifi
- Installed RT2870USBWirelessDriver.kext using kext utility
- Installed DWA-140WirelessUtility
————
Ethernet:
- installed AtherosE2200Ethernet.kext
http://www.insanelymac.com/forum/topic/300056-solution-for-qualcomm-atheros-ar816x-ar817x-and-killer-e220x/
————
Downloading tools:
- extracted native acpi files by pressing F2 and F4 during startup at cover
- mounted refi using EFI MOUNTER
- copied files that begin with ssds/ddts from /EFI/CLOVER/ACPI/origin to new folder on desktop
- I downloaded recent build of iasl to disassemble ssdt/ddts https://bitbucket.org/RehabMan/acpica/downloads
In terminal
Code:
cd ~/Downloads
unzip iasl.zip
sudo cp iasl /usr/bin
To extract and copy iasl to /usr/bin

- I downloaded rehabman’s iasl using these commands in terminal

Code:
mkdir ~/Projects && cd ~/Projects
git clone https://github.com/RehabMan/Intel-iasl.git iasl.git
cd iasl.git
Code:
make
Code:
sudo make install
Code:
sudo cp /usr/bin/iasl /Applications/MaciASL.app/Contents/MacOS/iasl61
Disassembling acpi files
In terminal
Code:
cd "to directory where I placed all SSDT/DSDT"
ls -l SSDT*.aml
to make sure that there is no duplicate ssdts by checking their sizes

Code:
pbpaste>refs.txt
This created ref.txt in my current working directory after that I opened ref.txt manually then I copied the following:

Code:
External(MDBG, MethodObj, 1)
External(_GPE.MMTB, MethodObj, 0)
External(_SB.PCI0.LPCB.H_EC.ECWT, MethodObj, 2)
External(_SB.PCI0.LPCB.H_EC.ECRD, MethodObj, 1)
External(_SB.PCI0.LPCB.H_EC.ECMD, MethodObj, 1)
External(_SB.PCI0.PEG0.PEGP.SGPO, MethodObj, 2)
External(_SB.PCI0.GFX0.DD02._BCM, MethodObj, 1)
External(_SB.PCI0.SAT0.SDSM, MethodObj, 4)
External(_GPE.VHOV, MethodObj, 3)
External(_SB.PCI0.XHC.RHUB.TPLD, MethodObj, 2)
Then save

Code:
iasl -da -dl -fe refs.txt DSDT.aml SSDT*.aml
I noticed ****.dsl files created

I downloaded MaciASL : https://bitbucket.org/RehabMan/os-x-maciasl-patchmatic/downloads/


- ran MaciASL
- chose Preferences from the MaciASL menu bar
- selected Sources
- clicked the [+] button
- gave it a name ("Laptop Patches")
- typed the following URL: http://raw.github.com/RehabMan/Laptop-DSDT-Patch/master
- opened ssdt.dsl file that I created in desktop with MaciASL
- Patched the following :
1 -[usb] USB3 PRW 0X6D Skylake (instant wake)
2 -[sys] IRQ Fix
3 -[audio] Audio Layout 12 And in right I manually edited the layout-id from 12 to 3
4 - added patch for brightness control key by clicking patch then adding the following text

Code:
into method label _QB7 replace_content
begin
// Brightness Down\n
    Notify(\_SB.PCI0.LPCB.PS2K, 0x0405)\n
end;
into method label _QB8 replace_content
begin
// Brightness Up\n
    Notify(\_SB.PCI0.LPCB.PS2K, 0x0406)\n
end;
then apply


- clicked compile one error showed (Name already exists in the scope (BNUM)) and needed to be fixed. Other warnings, remarks, optimizations not important. I fixed the error by finding the other (BNUM) and deleting the line
Code:
         External (BNUM, UnknownObj)    // (from opcode)

- Saved AS DSDT.AML (ACPI Machine Language Binary) and replaced it
Copied all ****.aml files to /clover/acpi/patched


Note: using MaciASL requires internet connection for the patches to load from the internet. That is why I tried to install my Linksys AE6000 wifi usb and Ethernet first.


Sound:
- downloaded apple patcher 1.8
http://www.insanelymac.com/forum/files/file/496-applehda-patcher/
- ran apple patcher 1.8
- picked realtec alc898 from laptop menu
- another window appeared then I didn’t put any number in the find and hit skip
- MironeAudio folder created on desktop
- deleted applehda.kext in system/library/extensions
- installed the applehda.kext from full Patched AppleHDA folder using kext utility
- installed FakePCIID.kext + FakePCIID_Intel_HDMI_Audio.kext using kext utility from https://bitbucket.org/RehabMan/os-x-fake-pci-id/downloads/

Disabling Nvidia graphics:
- opened the ssdt-7.dsl with MaciASL
- added the _INI line method before _OFF line method
Code:
Method(_INI) { _OFF() } // easy patch: add _INI to call _OFF
Method (_OFF, 0, Serialized)  // _OFF: Power Off
        {
and then saved as ssdt-7aml in /EFI/CLOVER/ACPI/patched

Fix the sleep:
- opened the directory \OS-X-Clover-Laptop-Config-master\hotpatch that I had downloaded
- SSDT-PTSWAK.dsl was needed to be opened by MaciASL and saved as SSDT-PTSWAK.aml in /clover/acpi/patched
- SSDT-Config.dsl was needed to be opened by MaciASL and searched for XPEE and changed the value to 1
Name(XPEE, 1)
then saved as SSDT.Config.aml in /clover/acpi/patched
- opened DSDT.dsl in my clover then searched for Method (_PTS and Method (_WAK to check if they are serialized or notserialized

Code:
 Method (_PTS, 1, NotSerialized)  // _PTS: Prepare To Sleep
    {
        If (Arg0)
        {
            \_SB.TPM.TPTS (Arg0)
            \_SB.PCI0.LPCB.SPTS (Arg0)
            \_SB.PCI0.NPTS (Arg0)
            RPTS (Arg0)
        }
    }

    Method (_WAK, 1, NotSerialized)  // _WAK: Wake
    {
        RWAK (Arg0)
        \_SB.PCI0.NWAK (Arg0)
        \_SB.PCI0.LPCB.SWAK (Arg0)
        \_SB.PCI0.LPCB.EC.MSWK (Arg0)
        Return (WAKP)
    }
My native _PTS and _WAK are notSerialized.Then I opened config.plist with plisteditor that is found in the OS-X-Clover-Laptop-Config-master\hotpatch that I had downloaded then searched for _WAK and _PTS after that copied the following:
"change Method(_WAK,1,N) to ZWAK, pair with SSDT-PTSWAK.aml"
"change Method(_PTS,1,N) to ZPTS, pair with SSDT-PTSWAK.aml"
To my config.plist
[note] _WAK,1,N and _PTS,1,N for notSerialized and _WAK,1,S and _PTS,1,S for Serialized
Download link for the original files (https://github.com/RehabMan/OS-X-Clover-Laptop-Config then clone or download)

Battery status and trackpad:
- downloaded https://bitbucket.org/RehabMan/os-x-acpi-battery-driver/downloads/ and Installed ACPIBatteryManager.kext using kext utility and restarted the system. After installing ACPIBatteryManager.kext, this fixed the SysPrefs->Trackpad to show up. After that I went to SysPrefs->Trackpad->Point & Click->Tap to click.


Brightness:
- I followed the guide to get the files https://www.tonymacx86.com/threads/guide-laptop-backlight-control-using-applebacklightinjector-kext.218222/
- opened SSDT-PNLF.dsl from ~/Projects/guide.git/hotpatch with MaciASL then saved it as SSDT-PNLF.aml to ACPI/patched
- added the patch marked with comment "change F%uT%04x to F%uTxxxx in AppleBacklightInjector.kext (credit RehabMan)" from ~/Projects/guide.git/config_patches.plist to my own config.plist at EFI/Clover/config.plist
- installed AppleBacklightInjector.kext to /L/E by typing in terminal
Code:
sudo cp -R ~/Projects/probook.git/kexts/AppleBacklightInjector.kext /Library/Extensions
Code:
sudo kextcache -i /
- restarted the system

USB configurations:
- downloaded and installed USBInjectAll.kext from https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads/
- downloaded https://github.com/RehabMan/OS-X-USB-Inject-All/raw/master/config_patches.plist
In the config_patches.plist
- I searched for change EHC1 to EH01 and change EHC2 to EH02 and copied them to my config.plist
- I searched for change 15 port limit to 26 in XHCI kext that has MatchOS = 1013.x then copied it to my config.plist
- installed FakePCIID_XHCIMux.kext
- added -uia_ignore_rmcf to config.plist/boot/arguments

- I ran IORegistryExplorer
- tested each port with both USB2 and USB3 devices
- used SSDT-UIAC-ALL.dsl as a template (https://github.com/RehabMan/OS-X-USB-Inject-All/raw/master/SSDT-UIAC-ALL.dsl)
- opened SSDT_UIAC-ALL.DSL with MaciASL and edited the following :


Code:
DefinitionBlock ("", "SSDT", 2, "hack", "UIAC", 0)
{
    Device(UIAC)
    {
        Name(_HID, "UIA00000")
        Name(RMCF, Package()
        {
            "8086_a12f", Package()
            {
                "port-count", Buffer() { 26, 0, 0, 0 },
                "ports", Package()
                {
                    "HS03", Package()
                    {
                        "UsbConnector", 3,
                        "port", Buffer() { 3, 0, 0, 0 },
                    },
                    "HS04", Package()
                    {
                        "UsbConnector", 3,
                        "port", Buffer() { 4, 0, 0, 0 },
                    },
                    "HS07", Package()
                    {
                        "UsbConnector", 3,
                        "port", Buffer() { 7, 0, 0, 0 },
                    },
                    "HS08", Package()
                    {
                        "UsbConnector", 3,
                        "port", Buffer() { 8, 0, 0, 0 },
                    },
                    "HS10", Package()
                    {
                        "UsbConnector", 255,
                        "port", Buffer() { 10, 0, 0, 0 },
                    },
                    "HS11", Package()
                    {
                        "UsbConnector", 255,
                        "port", Buffer() { 11, 0, 0, 0 },
                    },
                    "HS12", Package()
                    {
                        "UsbConnector", 3,
                        "port", Buffer() { 12, 0, 0, 0 },
                    },
                    "SS03", Package()
                    {
                        "UsbConnector", 3,
                        "port", Buffer() { 19, 0, 0, 0 },
                    },
                    "SS04", Package()
                    {
                        "UsbConnector", 3,
                        "port", Buffer() { 20, 0, 0, 0 },
                    },
                    "SS08", Package()
                    {
                        "UsbConnector", 3,
                        "port", Buffer() { 24, 0, 0, 0 },
                    },
                },
            },
        })
    }
}
//EOF
- then saved it as SSDT-UIAC.aml in /acpi/patched
- removed -uia_ignore_rmcf in config.plist/boot/arguments
[more info for usb configurations https://www.tonymacx86.com/threads/guide-creating-a-custom-ssdt-for-usbinjectall-kext.211311/ ]

Fix App Store:
- SysPrefs->Network and removed all networks, Apply, then removed /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist.
- restarted the system then added all networks
-----------------------------------------------------------------
 

Attachments

Joined
Jul 24, 2017
Messages
5
Motherboard
MSI GE73VR 7RF / HM175
CPU
intel core i7 77000HQ
Graphics
intel hd630 & Nvidia GTX 1070 8Gb
I have a device of different model msi and almost the same specifications I tried to prove the system did not take off



My Hardware:
MSI GS63VR 7RF Stealth Pro
cpu: Intel Core i7 7700HQ Kabylake
gfx: Intel HD630
gfx-dedicated: gtx 1060 6gb
Motherboard: MS-16K2 (intel hm170 chipset)
memory: 16Gb ddr4 (2x8Gb samsung)
Network: Killer e2500
Drives: - 256 NVME SSD (samsung mzvpw256)
- 2Tb HDD (seagate)
 
Joined
Oct 23, 2017
Messages
209
Motherboard
Hp pavilion dv6-6c65sx (Legacy)
CPU
I7-2670QM/HM65
Graphics
INTEL HD 3000/ Radeon HD 6700M 1366x768
Mobile Phone
Android
I have a device of different model msi and almost the same specifications I tried to prove the system did not take off



My Hardware:
MSI GS63VR 7RF Stealth Pro
cpu: Intel Core i7 7700HQ Kabylake
gfx: Intel HD630
gfx-dedicated: gtx 1060 6gb
Motherboard: MS-16K2 (intel hm170 chipset)
memory: 16Gb ddr4 (2x8Gb samsung)
Network: Killer e2500
Drives: - 256 NVME SSD (samsung mzvpw256)
- 2Tb HDD (seagate)
Nice Laptop. What is your issue with it ?
 
Joined
Jul 24, 2017
Messages
5
Motherboard
MSI GE73VR 7RF / HM175
CPU
intel core i7 77000HQ
Graphics
intel hd630 & Nvidia GTX 1070 8Gb
I have tried many versions and my only problem is not knowing the internal graphics card and I want to communicate with you if you are from Saudi Arabia, please send me a way to communicate with you.
 
Joined
Oct 23, 2017
Messages
209
Motherboard
Hp pavilion dv6-6c65sx (Legacy)
CPU
I7-2670QM/HM65
Graphics
INTEL HD 3000/ Radeon HD 6700M 1366x768
Mobile Phone
Android
I have tried many versions and my only problem is not knowing the internal graphics card and I want to communicate with you if you are from Saudi Arabia, please send me a way to communicate with you.
If you are trying to enable your nvidia card, you can't enable it. As you can see from my guide I couldn't enable it.

Talking about assistance via private communication is against froum rules. See the 3rd rule. Sorry
 
Joined
Jul 24, 2017
Messages
5
Motherboard
MSI GE73VR 7RF / HM175
CPU
intel core i7 77000HQ
Graphics
intel hd630 & Nvidia GTX 1070 8Gb
Thank you I will try again more than once and I hope to do it and do an Intel card and I hope you explain the installation steps in the video or pictures
 
Joined
Oct 23, 2017
Messages
209
Motherboard
Hp pavilion dv6-6c65sx (Legacy)
CPU
I7-2670QM/HM65
Graphics
INTEL HD 3000/ Radeon HD 6700M 1366x768
Mobile Phone
Android
Thank you I will try again more than once and I hope to do it and do an Intel card and I hope you explain the installation steps in the video or pictures
No need steps for intel HD you just need the correct config.plist and you may need to install FakePCIID_Intel_HD_Graphics.kext using kext utility.

What macOS are you using?
 
Joined
Oct 23, 2017
Messages
209
Motherboard
Hp pavilion dv6-6c65sx (Legacy)
CPU
I7-2670QM/HM65
Graphics
INTEL HD 3000/ Radeon HD 6700M 1366x768
Mobile Phone
Android
Joined
Mar 2, 2014
Messages
2
Motherboard
MSI GS43VR 4RE
Mac
Mac mini
I want to mention that I have an MSI GS43VR 7RE laptop, and following most of this guide, has helped me install Hackintosh on my laptop. There are a few things still not working, such as MacOS recognizing that I have a touchpad, and the speakers are still not working.

Other than the things I've mentioned, my laptop is running great now. Thank you @goldenegg for this guide!
 
Top