Contribute
Register

[Guide] MSI GE72 7RD Apache - Mojave 10.14.5

Joined
Oct 21, 2014
Messages
20
Motherboard
MSI GP72M 7REX Leopart Pro
CPU
I7-7700HQ/HM175
Graphics
HD 630+GTX 1050 TI
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.

Also, please finish your hardware details as requested in the FAQ.
Hello RehabMan ,attached the requested file, thank you for your help
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Good evening, please find attached the Problem Report file. Thank you in advance.
You forgot to implement backlight control.
Refer to the guide:
 
Joined
Oct 21, 2014
Messages
20
Motherboard
MSI GP72M 7REX Leopart Pro
CPU
I7-7700HQ/HM175
Graphics
HD 630+GTX 1050 TI
You forgot to implement backlight control.
Refer to the guide:
After installing what you told me, I now get a 0 or 100% display on the internal screen. But no variation of brightness. I also have Fn key control with the kext "ApplePS2SmartTouchPad.kext" It’s a start and a big step
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
After installing what you told me, I now get a 0 or 100% display on the internal screen. But no variation of brightness. I also have Fn key control with the kext "ApplePS2SmartTouchPad.kext" It’s a start and a big step
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Joined
Oct 21, 2014
Messages
20
Motherboard
MSI GP72M 7REX Leopart Pro
CPU
I7-7700HQ/HM175
Graphics
HD 630+GTX 1050 TI
Hello RehabMan ,Sorry, you can find my files now, thank you very much
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hello RehabMan ,Sorry, you can find my files now, thank you very much
MacBookPro14,3 is a poor choice. Use MacBookPro14,1 or MacBookPro11,1.

Your kextcache output proves kexts are not installed correctly.
All kexts you need must be installed to the system volume.
Read post #2 of the Clover guide for details:
 
Joined
Oct 21, 2014
Messages
20
Motherboard
MSI GP72M 7REX Leopart Pro
CPU
I7-7700HQ/HM175
Graphics
HD 630+GTX 1050 TI
Good morning, thank you all for your answer.
I am surprised at your remark about the choice of the SM BIOS 14.3 which seemed to me to involve my CPU 7700 HQ and HD 630. On the other hand it is true that I’m having a lot of trouble (I have a lot of eventual eventual essay with the stunning Headkaze Hackintool application for HDMI display and mini DP) the configuration of the ports and connector is Bizard between ID 5916000 or 059B0000 for the assignment of Con 0-1-2 or 0-2-3 not to mention the many reboot with system error ...when HDMI hot plug... I could say that the best configuration of the correspont frambuffer has an HD620 or I find the connector(1) dedicated to DP port.

On the other hand for information I proceeded to create a SSDT-IUAC.aml according to the Hackintool method, I placed it in ACPI/patche and put on command line in config.plist. This seems to me now OK I have just been bothered with the port HS07 which received an MSI EPC USB (connection/ loop deconnection). After several reading I decided to delete this port.Es what I did right?

But the first object was to solve the problem of retro lighting the internal screen. I wanted to do this at a later stage in order to understand, but I still have everything to do with the previous day.
I realized that it is preferable to install the kexts in L/E, which I have to do as soon as the tests are conclusive; (For ca Clover seems simpler or easier).
I have modified the BIOS DM to 14.1. The brightness setting is still not operational. I am sending you a new debug. report so you can please correct me.

Thank you in advance
 

Attachments

Feartech

Moderator
Joined
Aug 3, 2013
Messages
12,852
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
iOS
Good morning, thank you all for your answer.
I am surprised at your remark about the choice of the SM BIOS 14.3 which seemed to me to involve my CPU 7700 HQ and HD 630. On the other hand it is true that I’m having a lot of trouble (I have a lot of eventual eventual essay with the stunning Headkaze Hackintool application for HDMI display and mini DP) the configuration of the ports and connector is Bizard between ID 5916000 or 059B0000 for the assignment of Con 0-1-2 or 0-2-3 not to mention the many reboot with system error ...when HDMI hot plug... I could say that the best configuration of the correspont frambuffer has an HD620 or I find the connector(1) dedicated to DP port.

On the other hand for information I proceeded to create a SSDT-IUAC.aml according to the Hackintool method, I placed it in ACPI/patche and put on command line in config.plist. This seems to me now OK I have just been bothered with the port HS07 which received an MSI EPC USB (connection/ loop deconnection). After several reading I decided to delete this port.Es what I did right?

But the first object was to solve the problem of retro lighting the internal screen. I wanted to do this at a later stage in order to understand, but I still have everything to do with the previous day.
I realized that it is preferable to install the kexts in L/E, which I have to do as soon as the tests are conclusive; (For ca Clover seems simpler or easier).
I have modified the BIOS DM to 14.1. The brightness setting is still not operational. I am sending you a new debug. report so you can please correct me.

Thank you in advance
you haven't installed your kexts to /Library/Extensions
 
Joined
Oct 21, 2014
Messages
20
Motherboard
MSI GP72M 7REX Leopart Pro
CPU
I7-7700HQ/HM175
Graphics
HD 630+GTX 1050 TI
Yes I am aware of this and as I said I wanted to do the tests abors, now if that is the reason for the not working I will study how to properly install the Kexts in L/E and do it. I have not yet tried this method. Thank you
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
12,852
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
iOS
Yes I am aware of this and as I said I wanted to do the tests abors, now if that is the reason for the not working I will study how to properly install the Kexts in L/E and do it. I have not yet tried this method. Thank you
by not installing your kexts to /L/E some things won't work
 
Top