Contribute
Register

[Guide] MSI GE62 6QD Apache Pro - Mojave 10.14

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,929
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
OK I noticed something ..The back light works after the laptop wakes from sleep. It's my first time putting the laptop to sleep after fresh installing Mojave. So i don't what exactly fixed it.
How should I report this? debug files before and after the sleep ? can we do something about it now that we know it works after it turns on from sleep?
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Joined
Oct 8, 2018
Messages
21
Motherboard
MSI GE72 Apache Pro 6QD
CPU
i7-6700HQ
Graphics
GTX 960M + Iris 530, 1920x1080
Mobile Phone
Android
Files attached..
"NormalBoot" is from a restart.. with backlight problem.
"sleep" is after wake from sleep and working back light control.

Brightness from 80% to 100% is the same it doesn't change..but it's fine with me.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,929
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Files attached..
"NormalBoot" is from a restart.. with backlight problem.
"sleep" is after wake from sleep and working back light control.

Brightness from 80% to 100% is the same it doesn't change..but it's fine with me.
Check into options for BLKT in SSDT-RMCF (for controlling _INI actions in SSDT-PNLF).
It is mentioned in the guide:
https://www.tonymacx86.com/threads/...ontrol-using-applebacklightfixup-kext.218222/

Also, make sure you have legacy boot/CSM enabled in BIOS (then re-extract/re-patch DSDT.aml after that).
 
Joined
Mar 28, 2015
Messages
132
Motherboard
MSI GS65 8SE
CPU
i7-8750H
Graphics
UHD 630 + RTX 2060
Mac
MacBook Pro
Mobile Phone
Android
Also, make sure you have legacy boot/CSM enabled in BIOS (then re-extract/re-patch DSDT.aml after that).
Is it required to have legacy boot/CSM? I have UEFI rather than legacy boot but with ACHI but I have not encountered problems, only clover taking a bit longer to load despite having clover on an ssd. Not really a big deal since it takes 10 seconds but It used to load in around 2 seconds.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,929
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Is it required to have legacy boot/CSM? I have UEFI rather than legacy boot but with ACHI but I have not encountered problems, only clover taking a bit longer to load despite having clover on an ssd. Not really a big deal since it takes 10 seconds but It used to load in around 2 seconds.
AHCI has nothing to do with legacy/CSM/UEFI.

And yes, legacy/CSM is generally required as it initializes the graphics hardware in a way that is more complete, more comparable with Apple's firmware.
 
Joined
Mar 28, 2015
Messages
132
Motherboard
MSI GS65 8SE
CPU
i7-8750H
Graphics
UHD 630 + RTX 2060
Mac
MacBook Pro
Mobile Phone
Android
And yes, legacy/CSM is generally required as it initializes the graphics hardware in a way that is more complete, more comparable with Apple's firmware.
Okay got it. I will have to reinstall macOS and Windows in order to boot with legacy.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,929
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I will have to reinstall macOS and Windows in order to boot with legacy.
Why?
Continue to boot UEFI, but enable legacy as well (just to get CSM).
 
Joined
Mar 28, 2015
Messages
132
Motherboard
MSI GS65 8SE
CPU
i7-8750H
Graphics
UHD 630 + RTX 2060
Mac
MacBook Pro
Mobile Phone
Android
Continue to boot UEFI, but enable legacy as well (just to get CSM).
I cant boot with legacy option in UEFI. My clover does not show with this option but I have another option calles "UEFI with CSM". I booted from there and everything is fine.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,929
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I cant boot with legacy option in UEFI. My clover does not show with this option but I have another option calles "UEFI with CSM". I booted from there and everything is fine.
Each BIOS has a different way of showing the options. What you want is UEFI with CSM, or UEFI with legacy, but boot UEFI first. Either way is the same thing (booting UEFI, with UEFI+CSM).
 
Joined
Dec 3, 2017
Messages
12
Motherboard
MSI GE62 6QD Apache Pro - Clover
CPU
i7-6700HQ
Graphics
GTX 960M + HD 530 (1980x1080)
Thanks for this awesome guide!!

I've been working with Mojave in my GE62 6QD for more than one week but with no wifi card changed and thats why I didn't posted before.

Today the wifi card arrived and now I can say everything works, and pretty fine.

The only thing I note is that my USB3.0 ports doesn't work with pendrives or external HDD, but they work with soundcards or mouses, so they work. USB3.1 is working fine with a hub, so there I put pen drives etc. I'd say before patching DSDTs and installing USBinjectall.kext they worked fine, not very sure.

I would like to upload my debug files so you can check them if this USB3.0 issue is not common.

Another thing is that the quality for web cam is not so good, maybe not correctly set up by me.

Again, thank you very much for your work, you made me very happy, never thought about moving to OS or MAC system, but windows 10 is making me crazy in the last times, I have to say now I prefer OSX.

i'm learning to create debug files to upload, I'll post them soon.
 
Top