Contribute
Register

[GUIDE] macOS Big Sur 11 on Z390 Aorus Elite board

Joined
Dec 10, 2010
Messages
738
Motherboard
Gigabyte Z390 Aorus Elite
CPU
i9-9900K
Graphics
RX 580
Mobile Phone
  1. iOS
Everything works perfectly!
Sleep, star / stop works perfect too!
osx speed is also acceptable.

one problem, maybe you can explain to me why:
I'm using a virtualization software for using VM-Win10, but as soon as it starts it tells me that: "network identification failed"
I tried to set all the possible options in the settings:
-shared network
-host-only
-etc..
I think this is a new subject for a new thread, open it as new to be more likely to receive help.
I don't use virtualization.
That USB LAN ... do you have or have you ever had a USB LAN device connected? If the answer is no, remove it from the list.
 
Joined
Oct 5, 2012
Messages
34
Motherboard
Gigabyte Z390 Aorus Elite
CPU
i7-9700
Graphics
630 / RX 550
Mac
  1. MacBook Pro
That USB LAN ... do you have or have you ever had a USB LAN device connected? If the answer is no, remove it from the list.
how should i proceed to delete the row?
from config.plist?
I do not know which

tnks
 
Joined
Nov 7, 2017
Messages
17
Motherboard
Asus TUF Z390-PRO GAMING
CPU
i9-9900K
Graphics
Intel UHD 630
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Hi @miliuco , im tryng to use your EFI, in my setup (Asus TUF Z390-PRO GAMING, i9-9900k, Intel graphics card, NVME Samsung 980 PRO 1Tb).
I remove references to CPUFriend + CPUFriendDataProvider and delete the kexts, and also remain with config.plist to intel.
The problem appear, after few seconds on apple logo, a white screeen appear, i can move the mouse there, but nothing more appears. After several minutes, it appears a reboot occurs. Can you understand whats the problem ?
 
Last edited:
Joined
Dec 10, 2010
Messages
738
Motherboard
Gigabyte Z390 Aorus Elite
CPU
i9-9900K
Graphics
RX 580
Mobile Phone
  1. iOS
Hi @miliuco , im tryng to use your EFI, in my setup (Asus TUF Z390-PRO GAMING, i9-9900k, Intel graphics card, NVME Samsung 980 PRO 1Tb).
I remove references to CPUFriend + CPUFriendDataProvider and delete the kexts, and also remain with config.plist to intel.
The problem appear, after few seconds on apple logo, a white screeen appear, i can move the mouse there, but nothing more appears. After several minutes, it appears a reboot occurs. Can you understand whats the problem ?
With the previous EFI you was using, it was working well?
What SMBIOS, iMac19,1? Do you have removed RestrictEvents.kext?
Have you done ResteNVRAM al least once with the new EFI?
 
Joined
Nov 7, 2017
Messages
17
Motherboard
Asus TUF Z390-PRO GAMING
CPU
i9-9900K
Graphics
Intel UHD 630
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
With the previous EFI you was using, it was working well?
What SMBIOS, iMac19,1? Do you have removed RestrictEvents.kext?
Have you done ResteNVRAM al least once with the new EFI?

Hi, is a new machine, i have a old hackintosh at another machine.

Yes SMBIOS iMac19,1.
RestrictEvents.kext is not at your EFI folder.
I use everything like yours.
Yes i have done the ResetNVRam, i think the problem was about intel graphics, but right now, i don have another graphic card to test.
My plan was to put it working, and after do some customizations.
 
Joined
Dec 10, 2010
Messages
738
Motherboard
Gigabyte Z390 Aorus Elite
CPU
i9-9900K
Graphics
RX 580
Mobile Phone
  1. iOS
Hi, is a new machine, i have a old hackintosh at another machine.

Yes SMBIOS iMac19,1.
RestrictEvents.kext is not at your EFI folder.
I use everything like yours.
Yes i have done the ResetNVRam, i think the problem was about intel graphics, but right now, i don have another graphic card to test.
My plan was to put it working, and after do some customizations.
macOS version? Big Sur?
 
Joined
Dec 10, 2010
Messages
738
Motherboard
Gigabyte Z390 Aorus Elite
CPU
i9-9900K
Graphics
RX 580
Mobile Phone
  1. iOS
@Argozelo
BIOS setup

AI Tweaker:
- ASUS MultiCore Enhancement: Auto

Advanced:

Platform Misc Configuration (lower temperature of Radeon):
- PCI Express Native Power Management: Enabled
- Native ASPM: Enabled
- PCH DMI ASPM: Auto
- ASPM: Auto
- L1 Substates: L1.1 & L1.2
- PEG - ASPM: Auto

CPU Configuration:
- Intel (VMX) Virtualization Technology: Enabled
- Hyper-Threading: Enabled
- CPU-Power Management Control:
Intel SpeedStep: Enabled
Intel Speed Shift: Enabled
CFG Lock: Disabled

System Agent (SA) Configuration
- VT-d: Disabled
- Above 4G Decoding: Disabled
- Graphics Configuration:
Primary Display: iGFX
iGPU Multi-Monitor: Enabled
DVMT Pre-Allocated: 32M
RC6(Render Standby): Disabled

PCH Configuration
- IOAPIC 24-119 Entries: Enabled

PCH Storage Configuration
- SATA Controller(s): Disabled (if you have SDD NVMe)

Onboard Devices Configuration
- HD Audio: Enabled
- USB power delivery in Soft Off state (S5): Disabled
- Serial Port Configuration
Serial Port: Off

USB Configuration
- Legacy USB Support: Enabled
- XHCI Hand-off: Enabled

Network Stack Configuration
- Network Stack: Disabled

Boot:

- Boot Configuration
Fast Boot: Disabled
- CSM (Compatibility Support Module)
Launch CSM: Disabled
- Secure Boot
OS Type: Other OS
 
Top