Contribute
Register

[GUIDE] macOS Big Sur 11 on Z390 Aorus Elite board

Joined
Oct 5, 2012
Messages
34
Motherboard
Gigabyte Z390 Aorus Elite
CPU
i7-9700
Graphics
630 / RX 550
Mac
  1. MacBook Pro
Ok, this is lack of graphics acceleration. dGPU is not well detected. Even with DSDT and DeviceProperties.
Now is too late. Tomorrow we’ll try changes in config.plist to see if we can fix the problem.
:beachball::beachball::beachball:
if you happen to come to Italy you have a paid dinner ...
thank's man!
 
Joined
May 11, 2011
Messages
1,720
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
:beachball::beachball::beachball:
if you happen to come to Italy you have a paid dinner ...
thank's man!
Congrats on the loading! If you want me to continue the test, try using shikigva=80 as boot-args.
 
Joined
Dec 10, 2010
Messages
736
Motherboard
Gigabyte Z390 Aorus Elite
CPU
i9-9900K
Graphics
RX 580
Mobile Phone
  1. iOS
Congrats on the loading! If you want me to continue the test, try using shikigva=80 as boot-args.
This boot arg can be useful but I doubt that thanks to it the RX is well recognized, its purpose is another.
As long as it is not well detected, VRAM 7mb is displayed and it has no graphics acceleration.

What surprises me is that you @Middleman have RX550 (it is in the Hack called Arcee, right?) well installed and from what you say this is achieved with SSDT-GPU-SPOOF.aml + DeviceProperties in config.plist. But @ifreddy already has this setting and yet it is not well detected. What is wrong?

@ifreddy
Read this post:
The full thread can be helpful for the problem you have.

I can only came up with the idea of trying 3 different settings:
  • SSDT-GPU-SPOOF.aml + DeviceProperties in config.plist -> dGPU not well detected
  • SSDT-GPU-SPOOF.aml without DeviceProperties in config.plist
  • DeviceProperties in config.plist without SSDT-GPU-SPOOF.aml.
I guess settings 2 and 3 aren't going to work either, but I'm saying this to try something different.
 
Joined
May 11, 2011
Messages
1,720
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
This boot arg can be useful but I doubt that thanks to it the RX is well recognized, its purpose is another.
As long as it is not well detected, VRAM 7mb is displayed and it has no graphics acceleration.

What surprises me is that you @Middleman have RX550 (it is in the Hack called Arcee, right?) well installed and from what you say this is achieved with SSDT-GPU-SPOOF.aml + DeviceProperties in config.plist. But @ifreddy already has this setting and yet it is not well detected. What is wrong?

@ifreddy
Read this post:
The full thread can be helpful for the problem you have.

I can only came up with the idea of trying 3 different settings:
  • SSDT-GPU-SPOOF.aml + DeviceProperties in config.plist -> dGPU not well detected
  • SSDT-GPU-SPOOF.aml without DeviceProperties in config.plist
  • DeviceProperties in config.plist without SSDT-GPU-SPOOF.aml.
I guess settings 2 and 3 aren't going to work either, but I'm saying this to try something different.
Actually shikigva=80 is what I use to enable hardware acceleration on the AMD card in addition to the GPU spoof.
 
Joined
Dec 10, 2010
Messages
736
Motherboard
Gigabyte Z390 Aorus Elite
CPU
i9-9900K
Graphics
RX 580
Mobile Phone
  1. iOS
Actually shikigva=80 is what I use to enable hardware acceleration on the AMD card in addition to the GPU spoof.
Ok, then you have to try it. @ifreddy put it in boot-args as @Middleman says and tell us.
I had the idea that shikigva is to enable DRM or iGPU performance. It is worth to try.
 
Joined
Oct 5, 2012
Messages
34
Motherboard
Gigabyte Z390 Aorus Elite
CPU
i7-9700
Graphics
630 / RX 550
Mac
  1. MacBook Pro
Good morning .

I added "shikigva = 80" but the card still detects as (RX550, 7MB)

Processor is also misdetected: (4.3 GHz unknown). it's a i7-9700

1624183582236.png
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,555
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Good morning .

I added "shikigva = 80" but the card still detects as (RX550, 7MB)

Processor is also misdetected: (4.3 GHz unknown). it's a i7-9700

View attachment 522254
shikigva=80 has nothing to do with your 7MB graphics issue
 
Top