Contribute
Register

[Guide] Lenovo Z50-70/Z40-70/G50-70/G40-70 using Clover UEFI

Joined
Nov 16, 2015
Messages
212
Motherboard
Lenovo G50-70-Clover
CPU
i5-4210U
Graphics
HD 4400 1920x1080
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
dear sir, thanks for your contribution
this Efi recovery will not show the recovery dmg image (for the first installation)
I will get 3 choices only:
1. windows
2. clear NVRAM
3. UEFI Shell

if I use the EFI from thedeadfish59 / lenovo_z50-70_hackintosh page it will show the recovery but the screen will not clear (due to bad reselution)

any hind please
regards

Edit: thanks to @Feartech I updated my profile and signiture

please find attachment of the recover secreen that I get from the efi in the ubove link
regards

View attachment 537792
Press space to show hidden entries
 
Joined
Dec 2, 2021
Messages
7
Motherboard
Lenovo Z50-70
CPU
i7-4510U
Graphics
intell 4400 + GT 840M ( 1920 x 1080)
Mobile Phone
  1. Android
Press space to show hidden entries
Edit:- I solve the issue by enable legacy boot (it was EFI only)


thanks a lot for reply
but I get same display issue..
the apple logo in startup is ok but then it will be mess..
I try Big Sur and Monterey .
I have to note that my original creen was broken and I change it with one (same specification 1920*1080 60hz)

regards
1640458362413.jpg

1640458362364.jpg
1640458362390.jpg
 
Last edited:
Joined
Nov 16, 2015
Messages
212
Motherboard
Lenovo G50-70-Clover
CPU
i5-4210U
Graphics
HD 4400 1920x1080
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
Joined
Dec 2, 2021
Messages
7
Motherboard
Lenovo Z50-70
CPU
i7-4510U
Graphics
intell 4400 + GT 840M ( 1920 x 1080)
Mobile Phone
  1. Android
Dear all I successfully installed Monterey on my Lenovo Z50-70 using OpenCore 0.7.4 form post 647.
I have to mention thinks that is not easy to find in the tutorials...
1- after the boot you should press space to see all the options including the install/recovery usb.
2- you should set your bios to allow legacy boot .
3- I get "A required firmware update could not be installed" during installation solved by changing AdviseFeatures=True in config.plist
edit:
4- after the set up (it you are coming from windows ) you need to add the Efi folder content to the EFI partition.
first I mount the refi partion in windows and copy the efi folder and rename it to Mac but the oc folder should be on the first directory not inside other folder , then I use Easyeufi to add macOS entry and select the boot64.efi inside the boot folder
5- copy best the image and follow the post install section in OC guide to add the GUI and sound.
6- to add linux support you have to add OpenLinuxBoot.efi and ext4_x64.efi to the driver folder then add them to config.plist then add flags=0x678f set in Arguments for OpenLinuxBoot.efi driver

thanks to @daigosx for help and support...

regards

1.png
 
Last edited:
Joined
Nov 7, 2018
Messages
17
Motherboard
Lenovo Z50-70-OpenCore
CPU
i5
Graphics
HD 4400,1920x1080
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi all. I also just wanted to chime in. I did a fresh install using @daigosx EFI and it worked fine. I have yet to test all functionality thoroughly but two things that don't work are:
1) mouse pad tracking and gesture works but buttons don't
2) brightness keys don't work
I can live with that at the moment as I can always use a mouse or tap the pad to click

Thanks for all your hard work!
 
Joined
Nov 16, 2015
Messages
212
Motherboard
Lenovo G50-70-Clover
CPU
i5-4210U
Graphics
HD 4400 1920x1080
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
Hi all. I also just wanted to chime in. I did a fresh install using @daigosx EFI and it worked fine. I have yet to test all functionality thoroughly but two things that don't work are:
1) mouse pad tracking and gesture works but buttons don't
2) brightness keys don't work
I can live with that at the moment as I can always use a mouse or tap the pad to click

Thanks for all your hard work!
VoodooPS2 allows advanced gestures but disables buttons, ApplePS2 gives buttons but disables gestures.

You can enable both XOSI ssdt and patch to enable brightness buttons but I have issues booting Windows with those enabled. Give it a try cause it's working for someone else.
You can also map brightness keys using Karabiner
 
Joined
Mar 3, 2015
Messages
49
Motherboard
Lenovo Z50-70
CPU
i5-4510U
Graphics
820M
Mobile Phone
  1. Android
  2. iOS
Update time!
OC 0.7.4
Works with BigSur and is Monterey ready.
SystemProductName changed to MacBookPro11,5 you'll have to regenerate your NVRAM->PlatformInfo

Download the latest OCBinaryData if you want a working OpenCanopy GUI

Disconnect your apple id before you upgrade the EFI

Have fun
I've updated OC to 0.8.3 but It is failing to boot.
I'm attaching log file and compressed EFI directory. (I've removed SMBIOS from this compressed file on actual EFI partition it is present)
 

Attachments

  • EFI.zip
    13.5 MB · Views: 24
  • opencore-2022-08-02-083746.txt
    256 KB · Views: 19
Joined
Mar 3, 2015
Messages
49
Motherboard
Lenovo Z50-70
CPU
i5-4510U
Graphics
820M
Mobile Phone
  1. Android
  2. iOS
Update time!
OC 0.7.4
Works with BigSur and is Monterey ready.
SystemProductName changed to MacBookPro11,5 you'll have to regenerate your NVRAM->PlatformInfo

Download the latest OCBinaryData if you want a working OpenCanopy GUI

Disconnect your apple id before you upgrade the EFI

Have fun
I've updated OC to 0.8.3, and made some changes now Open core is booting but selecting installed MacOS, always display progress around 50% and keeps adding logs. No matter How long did I wait.
Here is my updated EFI directory and log file.
 

Attachments

  • EFI.zip
    13.5 MB · Views: 22
  • opencore-2022-08-16-075728.txt
    256 KB · Views: 12
Joined
Jul 4, 2019
Messages
6
Motherboard
Lenovo Z50-70
CPU
i7-4510U
Graphics
HD 4400 + GF 840M
Hello everybody,
I installed MacOs Monterei on my Lenovo Z50-70 using the daigosx file at post: 653

At the moment for what I have been able to verify works:
The audio from the speakers
The audio keys
The mouse
Movement with the touchpad
The battery level

It does not work:
The keys of brightness.
The two buttons on the touchpad (Synaptic)
Wifi (I guess because I have the original Realtek card)

When the PC goes into hibernation, it resumes only using the keyboard and not the mouse is this normal?

I still have to try bluetooh and hdmi

The mac sees the processor as a dual core even if mine is a quad core is this normal?

Restarting windows the pc is a mac and I had to restore default values from bios to fix, but can it be avoided?

After completing everything can i re-enable virtualization, fast and secure boot in the bios?

I haven't done any post installation steps yet either because I don't have everything working yet and then because I don't know if I have to run them anyway since I used opencore instead of clover.

If I need to change any driver or kexts just replace it in the efi folder and reboot?

I know I ask several things, but after reading the 74 pages of posts and with your help I hope to also be able to upgrade to opencore 0.8.4 by contributing to this community.
 

Attachments

  • macbook.jpg
    macbook.jpg
    202.6 KB · Views: 18

Feartech

Moderator
Joined
Aug 3, 2013
Messages
29,013
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Hello everybody,
I installed MacOs Monterei on my Lenovo Z50-70 using the daigosx file at post: 653

At the moment for what I have been able to verify works:
The audio from the speakers
The audio keys
The mouse
Movement with the touchpad
The battery level

It does not work:
The keys of brightness.
The two buttons on the touchpad (Synaptic)
Wifi (I guess because I have the original Realtek card)

When the PC goes into hibernation, it resumes only using the keyboard and not the mouse is this normal?

I still have to try bluetooh and hdmi

The mac sees the processor as a dual core even if mine is a quad core is this normal?

Restarting windows the pc is a mac and I had to restore default values from bios to fix, but can it be avoided?

After completing everything can i re-enable virtualization, fast and secure boot in the bios?

I haven't done any post installation steps yet either because I don't have everything working yet and then because I don't know if I have to run them anyway since I used opencore instead of clover.

If I need to change any driver or kexts just replace it in the efi folder and reboot?

I know I ask several things, but after reading the 74 pages of posts and with your help I hope to also be able to upgrade to opencore 0.8.4 by contributing to this community.
you need to leave the bios settings as they are

for your realtek wifi, then maybe this may help:
 
Top