Contribute
Register

[Guide] Lenovo Z50-70/Z40-70/G50-70/G40-70 using Clover UEFI

Joined
Mar 3, 2015
Messages
41
Motherboard
Lenovo Z50-70
CPU
i5-4510U
Graphics
GeForce 820M
Mobile Phone
  1. Android
  2. iOS
I'm having problem after update from 10.15.7 to 11.0

In same SSD I'm using 11.0 which was clean installation. It is working fine. But when I tried to update my existing Catelina partition, I'm getting error.

Both partitions are being loaded from same SSD's EFI.

Here is my EFI without resource directory
 

Attachments

  • WhatsApp Image 2021-01-07 at 8.35.47 PM.jpeg
    WhatsApp Image 2021-01-07 at 8.35.47 PM.jpeg
    181.3 KB · Views: 17
  • EFI.zip
    12.8 MB · Views: 33
Joined
Jan 1, 2021
Messages
1
Motherboard
dq77mk
CPU
corei7 3rd gen
Graphics
nvidia gt220
hi
I followed guide exactly but whenever i install clover i got stuck on +++++++ random seed even though i tried memory fix solution i.e copying osxaptxxx or aptixxxx drivers just to be clear it happens after installing clover and installing/generating kexts and config.plist accorinding to your method after reboot it get stuck on ++++++.\
One important thing is that mac os installs without any problems i changes flash drive even hard drives. If i remove generated clover folder it do boot again without any problem but whenever i try whole g50 project it get stuck on +++++

I tried both rehabman clover and latest clover too both after generating kexts, patch and plist copying get stuck on same error.

also during compilation project i get unsigned kexts error which i assume is normal as someone said in this thread its normal.


BTW i realling did tried more than 100 times before its first time posting here. Really believe me. I was about to give up but thought to get help.
i am attaching my clover folder too.


my specs are..

Lenovo g50-70
Intel core i7 4510u
8GB Ram
Integrated graphics
128GB apple ssd or 500Gb sata (tried on both)
 

Attachments

  • CLOVERxx.zip
    2.1 MB · Views: 13
Joined
Mar 3, 2015
Messages
41
Motherboard
Lenovo Z50-70
CPU
i5-4510U
Graphics
GeForce 820M
Mobile Phone
  1. Android
  2. iOS
Here you go!
OC-0.6.3 working EFI for Big Sur. This is a slight modified version of @Mikorist 's one.
  • You have to fill PlatformInfo section by yourself
  • UpdateSMBIOSMode is set to "Custom" and Kernel->Quirks->CustomSMBIOSGuid is set to true: this won't pass SSDTs to other OSes and you'll be able to boot Windows/Linux "natively" from OC. Breaks BootCamp
  • OpenCanopy is enabled but you need to fill OC/Resources subfolders
  • Should work with Catalina too
I am working on a new EFI with some custom SSDT, proper USB mapping, VoodooPS2 (Enables touchpad gestures for me) and AppleALC (microphone issues atm). I am facing sleep issues, so I won't share it yet.
@Mikorist if you want to help me improve the EFI, send me a PM.
I'm not getting Ethernet.
Any suggestions?

I'm having RealtekRTL8111.kext in EFI/OC/Kexts
 
Joined
Apr 7, 2012
Messages
12
Motherboard
Gigabyte Z68X-UD3H-B3
CPU
i7 3770k
Graphics
RX 580
Mobile Phone
  1. iOS
I'm not getting Ethernet.
Any suggestions?

I'm having RealtekRTL8111.kext in EFI/OC/Kexts
Coincidentally the latest version of RealtekRTL8111.kext doesn't work on my desktop so you may be having the same problem. Try an older version.
 
Joined
Feb 3, 2018
Messages
40
Motherboard
Lenovo Z50-70
CPU
i7-4510U
Graphics
HD 4400 & GT 840m (1920x1080)
Mobile Phone
  1. Android
  2. iOS
Hello, does this guide can be used to install macOS big sur?
 
Joined
Nov 16, 2015
Messages
173
Motherboard
Lenovo G50-70-Clover
CPU
i5-4210U
Graphics
HD 4400 1920x1080
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
Hello, does this guide can be used to install macOS big sur?
No, but you can try using a working Big Sur efi. There are some attached in previous posts.
Or you can use the guide to install Catalina, switch from Clover to OpenCore and upgrade to Big Sur
 
Joined
Nov 16, 2020
Messages
3
Motherboard
Lenovo Lancer
CPU
I5 4210U
Graphics
R5 M230
Mobile Phone
  1. Android
No, but you can try using a working Big Sur efi. There are some attached in previous posts. Or you can use the guide to install Catalina, switch from Clover to OpenCore and upgrade to Big Sur

I have low microphone sound issue on discord etc. Siri works just perfectly but on other applications i cant use device's microphone properly. I tried every efi but i cant fix can anybody help me ?
 
Joined
Nov 8, 2018
Messages
17
Motherboard
Lenovo Z50-70-OpenCore
CPU
i5
Graphics
HD 4400,1920x1080
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Here you go!
OC-0.6.3 working EFI for Big Sur. This is a slight modified version of @Mikorist 's one.
  • You have to fill PlatformInfo section by yourself
  • UpdateSMBIOSMode is set to "Custom" and Kernel->Quirks->CustomSMBIOSGuid is set to true: this won't pass SSDTs to other OSes and you'll be able to boot Windows/Linux "natively" from OC. Breaks BootCamp
  • OpenCanopy is enabled but you need to fill OC/Resources subfolders
  • Should work with Catalina too
I am working on a new EFI with some custom SSDT, proper USB mapping, VoodooPS2 (Enables touchpad gestures for me) and AppleALC (microphone issues atm). I am facing sleep issues, so I won't share it yet.
@Mikorist if you want to help me improve the EFI, send me a PM.
Thanks! Could you elaborate on how to 'fill in PlatformInfo'? I used OpenCore Configurator to fill it in but it doesn't seem to save it to the config.plist.

EDIT: Got it to save to the config but it doesn't seem to be applied. With Custom mode it says OPENCORE_SN1 and with mode create it says unavailable.
EDIT2: I now looked into bhedge's config and used his PlatformInfo (with my serial and uuid) and it now seems to work!
Hi folks

Like daigosx I've got my Z50-70 working with Big Sur OpenCore 0.6.3 using Mikorist's EFI as the base (big thanks to Mikorist). Everything appears to work including sleep/wake, battery/power management and FaceTime/iMessage.

My machine still has the original AR9565 wifi card which only has limited OS X support, I used to have it working in High Sierra but am still working on it in Big Sur. If someone has a solution to this please post it!

Cheers
Benny Hedge
 
Last edited:
Joined
Nov 8, 2018
Messages
17
Motherboard
Lenovo Z50-70-OpenCore
CPU
i5
Graphics
HD 4400,1920x1080
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Like I said in my previous post, I have now switched to OpenCore using daigosx and bhedge's EFIs as baseline. I updated OC to 0.6.5 and am mostly pretty happy. Thanks!

However, there are some minor inconveniences with this 10.15.7-OC setup:
1) The trackpad scrolling seems to be on or off (scrolling until I change directions or lift my fingers) unlike how it was using VoodooPS2Controller (I tried that one but clicking doesn't work on it).
2) Volume and brightness keys now default to incremental steps instead of whole segments at a time unless CMD is being held at the same time (the reverse of previous behaviour). Also, holding Shift does not make a sound anymore.
3) The DVD drive doesn't seem to work anymore. Nevermind, actually, restarting with the DVD inside fixed it.
4) The right Option key doesn't seem to be working
5) HDMI sound is not working / doesn't show up
6) Closing the lid doesn't put laptop to sleep

Is there anything I can do about these issues? Or is that just how it is going to be?
 
Last edited:
Top