Contribute
Register

[Guide] Lenovo Yoga C930-13IKB (4K/i7-8550u) 99% working, updated 7 Feb

Joined
Oct 31, 2014
Messages
135
Motherboard
Lenovo LNVNB161216
CPU
i7-8550U
Graphics
UHD 620 (3840x2160)
Mobile Phone
  1. Android
Final update for today:

I saw elsewhere that the new WhateverGreen should enable 60Hz. Updated OC, VirtualSMC, WhateverGreen and Lilu, which caused the boot to last extra four minutes (4x 60s stall on "BAT1"), broke power management, and did not give me 60Hz. I am now back to Lilu 1.4.9 and everything is fine again.

You can delete AppleBacklightFix and IOGraphicsFamily, WhateverGreen handles those functionalities.

Now I just have to rename the partition from "Install macOS Big Sur" to something else and I'm golden.
 
Joined
Oct 31, 2014
Messages
135
Motherboard
Lenovo LNVNB161216
CPU
i7-8550U
Graphics
UHD 620 (3840x2160)
Mobile Phone
  1. Android
Delete BT4LEContinuityFixup.kext, enable ExtendBTFeatureFlags in OpenCore, and Lilu 1.5.1 + WhateverGreen 1.4.8 are fine. Still no 60Hz, but I can't say I notice the difference, unless I am watching a movie. The difference I do notice is that the laptop is running *much* cooler. As to whether it's because of Big Sur or the changes made to the EFI folder, I can't tell.

I'll spend some more time with BS to make sure I don't find anything that stopped working (so far everything's going well, except the 120398092 requests to grant permissions and, of course, unlocking with Apple Watch – Messages and FaceTime work as well). But it's looking great so far.

Edit: Found one problem – videos on Apple Music display a black screen, the sound plays correctly. Seems like all other DRM content displays correctly, just not those. This seems related? https://www.tonymacx86.com/threads/...e-with-apple-music-videos-sound-works.309464/

Edit 2: bit the bullet and cloned BS to the internal drive. It works *beautifully*. Amazon really needs to update the Kindle app, but that's their problem, unrelated to our, ah, special testing machines. Everything else works beautifully and I can't believe how quiet and cool my laptop suddenly is.

Thanks so much for all the help, @Silent99!
 
Last edited:
Joined
Jun 21, 2012
Messages
30
Motherboard
LNVNB161216
CPU
i7-8550u
Graphics
UHD 620 (3840x2160)
That's great to hear! I couldn't find the info on 60Hz on WhateverGreen you mentioned other than for use on external monitors. Do you have a link? At the resolution I mentioned in an earlier comment I don't get screen glitching (which I do at 1920 x 1080), except on some video streaming services in fullscreen mode as you mentioned.
 
Joined
Jun 21, 2012
Messages
30
Motherboard
LNVNB161216
CPU
i7-8550u
Graphics
UHD 620 (3840x2160)
If I add the new WhateverGreen and alter the config.plist entry i still get 48 but it takes 2.5 minutes to boot instead of 40 seconds and the system barely runs.
 
Joined
Oct 31, 2014
Messages
135
Motherboard
Lenovo LNVNB161216
CPU
i7-8550U
Graphics
UHD 620 (3840x2160)
Mobile Phone
  1. Android
Mine starts up just as fast, but heats up like Mojave used to. I can't say I notice the 48Hz, to be honest. Maybe if it was 120Hz before, I would. As things are, I'm not even sure whether the display properties are correct, It Just Works (TM).

With Mojave my trackpad used to stop working sometimes after long uptime, curious if it will be better now.
 
Joined
Dec 20, 2018
Messages
705
Motherboard
Gigabyte Z370 AORUS Gaming 7
CPU
i7-8700K OC 5GHz
Graphics
GTX 1080 Ti & UHD 630
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
That's great to hear! I couldn't find the info on 60Hz on WhateverGreen you mentioned other than for use on external monitors. Do you have a link? At the resolution I mentioned in an earlier comment I don't get screen glitching (which I do at 1920 x 1080), except on some video streaming services in fullscreen mode as you mentioned.

@navaira you guys need to add these properties from this post to your config.plist to make the 4k screen run @60Hz. hope this helps. try and report back

note: add -igfxmpc. to boot args as well. Also remove the edid patch you have that enables the 48hz. in your config.plist
 
Joined
Jun 21, 2012
Messages
30
Motherboard
LNVNB161216
CPU
i7-8550u
Graphics
UHD 620 (3840x2160)

@navaira you guys need to add these properties from this post to your config.plist to make the 4k screen run @60Hz. hope this helps. try and report back

note: add -igfxmpc. to boot args as well. Also remove the edid patch you have that enables the 48hz. in your config.plist
Thanks for the info! I didn't remove the edid patch when I tested it out and will try that now.

Edit: I tried to figure out which lines under DeviceProperties specifically related to the edid patch but I may have left in some lines that should have been removed (or deleted too many). After adding the lines from your link as well as the boot arg you mentioned and the new version of WEG, my laptop hangs on boot but again I don't think I properly returned the config.plist to the state it was in before the edid patch was added. This will probably take some time or perhaps help.
 

Attachments

  • config.plist
    37.3 KB · Views: 33
Last edited:
Joined
Dec 20, 2018
Messages
705
Motherboard
Gigabyte Z370 AORUS Gaming 7
CPU
i7-8700K OC 5GHz
Graphics
GTX 1080 Ti & UHD 630
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
Thanks for the info! I didn't remove the edid patch when I tested it out and will try that now.

Edit: I tried to figure out which lines under DeviceProperties specifically related to the edid patch but I may have left in some lines that should have been removed (or deleted too many). After adding the lines from your link as well as the boot arg you mentioned and the new version of WEG, my laptop hangs on boot but again I don't think I properly returned the config.plist to the state it was in before the edid patch was added. This will probably take some time or perhaps help.
try changing you kext loading order put WEG at the top near lilu. also can you take a pic of where it hangs?
 
Joined
Apr 5, 2019
Messages
21
Motherboard
Lenovo LNVB161216
CPU
i7-8550U
Graphics
UHD 620 (3840x2160)
Mobile Phone
  1. Android
Short and sad update. I flashed the bios twice and somehow killed it completely. The bios chip is fine but the laptop refuses to power on at all and had that awful burning smell of a capacitor that has just popped.
I'm so sad. I really loved this laptop. Thanks navaira for inspiring me to get it and to everyone else who supported me along the way.
 
Top