Contribute
Register

[Guide] Lenovo Yoga 920 i7-8550U 4K Big Sur 11.1 OpenCore

Joined
Mar 20, 2019
Messages
35
Motherboard
Yoga 920-13IKB
CPU
i7 8550u
Graphics
UHD620
For those who care about keyboard brightness control, I got it working by adding these in config.plist > ACPI > Patch

<dict>
<key>Comment</key>
<string>change OSID to XSID</string>
<key>Count</key>
<integer>0</integer>
<key>Enabled</key>
<true/>

<key>Find</key>
<data>
T1NJRA==
</data>

<key>Limit</key>
<integer>0</integer>
<key>Mask</key>
<data>
</data>
<key>OemTableId</key>
<data>

</data>
<key>Replace</key>
<data>

WFNJRA==
</data>

<key>ReplaceMask</key>
<data>

</data>
<key>Skip</key>
<integer>0</integer>
<key>TableLength</key>
<integer>0</integer>

<key>TableSignature</key>
<data>

</data>
</dict>
<dict>
<key>Comment</key>
<string>Prevent Apple I2C kexts from attaching to I2C controllers</string>
<key>Count</key>
<integer>0</integer>
<key>Enabled</key>
<true/>

<key>Find</key>
<data>
U1U5TGFYUT0=
</data>

<key>Limit</key>
<integer>0</integer>
<key>Mask</key>
<data>
</data>
<key>OemTableId</key>
<data>

</data>
<key>Replace</key>
<data>

U1U5TGFYTT0=
</data>

<key>ReplaceMask</key>
<data>

</data>
<key>Skip</key>
<integer>0</integer>
<key>TableLength</key>
<integer>0</integer>

<key>TableSignature</key>
<data>

</data>
</dict>
<dict>
<key>Comment</key>
<string>Prevent Apple I2C kexts from attaching to I2C controllers</string>
<key>Count</key>
<integer>0</integer>
<key>Enabled</key>
<true/>

<key>Find</key>
<data>
U1U5TGFYUT0=
</data>

<key>Limit</key>
<integer>0</integer>
<key>Mask</key>
<data>
</data>
<key>OemTableId</key>
<data>

</data>
<key>Replace</key>
<data>

U1U5TGFYTT0=
</data>

<key>ReplaceMask</key>
<data>

</data>
<key>Skip</key>
<integer>0</integer>
<key>TableLength</key>
<integer>0</integer>

<key>TableSignature</key>
<data>

</data>
</dict>
<dict>
<key>Comment</key>
<string>_Q38 to XQ38</string>

<key>Count</key>
<integer>0</integer>
<key>Enabled</key>
<true/>

<key>Find</key>
<data>
X1EzOA==
</data>

<key>Limit</key>
<integer>0</integer>
<key>Mask</key>
<data>
</data>
<key>OemTableId</key>
<data>

</data>
<key>Replace</key>
<data>

WFEzOA==
</data>

<key>ReplaceMask</key>
<data>

</data>
<key>Skip</key>
<integer>0</integer>
<key>TableLength</key>
<integer>0</integer>

<key>TableSignature</key>
<data>

</data>
</dict>
<dict>
<key>Comment</key>
<string>_Q39 to XQ39</string>

<key>Count</key>
<integer>0</integer>
<key>Enabled</key>
<true/>

<key>Find</key>
<data>
X1EzOQ==
</data>

<key>Limit</key>
<integer>0</integer>
<key>Mask</key>
<data>
</data>
<key>OemTableId</key>
<data>

</data>
<key>Replace</key>
<data>

WFEzOQ==
</data>

<key>ReplaceMask</key>
<data>

</data>
<key>Skip</key>
<integer>0</integer>
<key>TableLength</key>
<integer>0</integer>

<key>TableSignature</key>
<data>

</data>
</dict>

Then adding the attached SSDT and it's entry in the config file.

I'm not dual booting, but hopefully doing it this way won't break things for those of you who are.
Hi, Could you send me your EFI? My brightness control still doesn't work when I add your SSDT.
Anybody try win10+BigSur double boot? I got blue/green screen when I boot to win10. I am using cephasara's EFI3.
 
Joined
Jan 6, 2021
Messages
5
Motherboard
Yoga 920 13'
CPU
I7-8550U
Graphics
Intel UHD 620
Hi, Could you send me your EFI? My brightness control still doesn't work when I add your SSDT.
Anybody try win10+BigSur double boot? I got blue/green screen when I boot to win10. I am using cephasara's EFI3.
I am quadruple-booting with Windows,Linux,ChromeOS and Big Sur so that shouldn't be a problem. The SSDT works also on my 1080p screen so that shouldn't be a problem. I can upload my EFI for you, but I've changed a whole lot there and it's for 1080p not 4k. Did you add the correct stuff to config.plist?
 
Joined
Mar 20, 2019
Messages
35
Motherboard
Yoga 920-13IKB
CPU
i7 8550u
Graphics
UHD620
I am quadruple-booting with Windows,Linux,ChromeOS and Big Sur so that shouldn't be a problem. The SSDT works also on my 1080p screen so that shouldn't be a problem. I can upload my EFI for you, but I've changed a whole lot there and it's for 1080p not 4k. Did you add the correct stuff to config.plist?
Could you attach your EFI? Thanks!
 
Joined
Jan 6, 2021
Messages
5
Motherboard
Yoga 920 13'
CPU
I7-8550U
Graphics
Intel UHD 620
Removed all broadcom kexts, added intel kexts for AC7260, removed debug info, removed picker so it can auto-boot to macos, removed some things from pci-e for graphics card.
Did you do other things except include SSDT in for brightness control?
 
Joined
Mar 20, 2019
Messages
35
Motherboard
Yoga 920-13IKB
CPU
i7 8550u
Graphics
UHD620
Removed all broadcom kexts, added intel kexts for AC7260, removed debug info, removed picker so it can auto-boot to macos, removed some things from pci-e for graphics card.
My brightness control still doesn't work! Any other people can share your EFI to me?
 
Joined
Jul 4, 2018
Messages
52
Motherboard
Yoga 920-13IKB
CPU
i7-8550u
Graphics
UHD620
My brightness control still doesn't work! Any other people can share your EFI to me?
The EFI posted by @Majkel19 seems fine, although I know that you have the Broadcom card so I would recommend using this one and then adding the SMBIOS using genSMBIOS before you use it.

From what I can see he has the keys put in exactly how I did so I don't think this will fix the brightness control. Can you post your EFI exactly as you're using it.
 

Attachments

  • EFI.zip
    6.6 MB · Views: 21
Joined
Mar 20, 2019
Messages
35
Motherboard
Yoga 920-13IKB
CPU
i7 8550u
Graphics
UHD620
The EFI posted by @Majkel19 seems fine, although I know that you have the Broadcom card so I would recommend using this one and then adding the SMBIOS using genSMBIOS before you use it.

From what I can see he has the keys put in exactly how I did so I don't think this will fix the brightness control. Can you post your EFI exactly as you're using it.
Thank you! The brightness control finally works in my computer with your EFI. However, my windows10 still doesn't work. It is very werid! When I remove BigSur boot from EFI, it is able to boot to windows10.
 
Joined
Jul 4, 2018
Messages
52
Motherboard
Yoga 920-13IKB
CPU
i7-8550u
Graphics
UHD620
Thank you! The brightness control finally works in my computer with your EFI. However, my windows10 still doesn't work. It is very werid! When I remove BigSur boot from EFI, it is able to boot to windows10.
I don't know for sure but that seems to suggest to me that one or more of thee SSDTs are interfering with Windows. Try removing the SSDTs and see if you can boot Windows. If you figure out which SSDTs are causing an issue in Windows then try wrapping its methods with a check for the Darwin kernel like in the brightness keys SSDT.

If you get it working then try posting it here.
 
Top