Contribute
Register

[Guide] Lenovo Y50/Y70 (UHD or 1080p) using Clover UEFI

Status
Not open for further replies.

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,951
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
[Guide] Lenovo Y50 (UHD or 1080p) using Clover UEFI

I'm attaching everything that might be important.
Thanks a lot!

View attachment 148328

One thing I don't understand is why your layout-id injected on HDAU is 12.

It should be 86, as that's what the patches do.

HDAU layout-id must be the same as HDEF layout-id.

--

Investigating...

I see the problem. Fix pushed to the repo. Please update and repatch... test.
 
Joined
Jun 28, 2011
Messages
707
Motherboard
Lenovo Y50-70 ID8C49
CPU
i7-4710
Graphics
HD 4600 + GT 860M, 1920*1080
[Guide] Lenovo Y50 (UHD or 1080p) using Clover UEFI

If someone has 10.10.4 (I save all), they can install it and test.

But the catch is even if 10.10.4 works, how would we transplant it and make it work on 10.10.5?
 
Joined
Mar 7, 2011
Messages
35
Motherboard
Razer Blade 2017 UHD (Laptop)
CPU
Intel i7-7700HQ
Graphics
NVIDIA GeForce GTX 1060
[Guide] Lenovo Y50 (UHD or 1080p) using Clover UEFI

Never valid to use more than one patch for a given port simultaneously. Of course using patches for both 0105 and 0204 is a good idea, as you don't really know which port the device is connecting to.

You should also verify that the patches are having the desired effect. By looking at ioreg you can see whether the connector-type for the ports is changed from DP <00 04 00 00> to HDMI <00 08 00 00>.

I've tried the values from 9 to 15 for both 0204 and 0105. Seems like only 12 and 13 leads to a reboot. For other values, the screen hangs and no signal is transmitted through HDMI.

I've only tried with CSM on, will have to find some time to see how it fares with CSM off.

Verified on ioreg that both AppleIntelFramebuffer@1 and AppleIntelFramebuffer@2 are giving connector type 00 08 00 00. I assume it means the 0105 and 0204 patches are being injected respectively
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,951
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
[Guide] Lenovo Y50 (UHD or 1080p) using Clover UEFI

@divinitus
@masterscarhead1

Please read post #732.
 
Joined
Mar 7, 2011
Messages
35
Motherboard
Razer Blade 2017 UHD (Laptop)
CPU
Intel i7-7700HQ
Graphics
NVIDIA GeForce GTX 1060
[Guide] Lenovo Y50 (UHD or 1080p) using Clover UEFI

@divinitus
@masterscarhead1

Please read post #732.

Thank you! Will try now.
 
Joined
Mar 7, 2011
Messages
35
Motherboard
Razer Blade 2017 UHD (Laptop)
CPU
Intel i7-7700HQ
Graphics
NVIDIA GeForce GTX 1060
[Guide] Lenovo Y50 (UHD or 1080p) using Clover UEFI

One thing I don't understand is why your layout-id injected on HDAU is 12.

It should be 86, as that's what the patches do.

HDAU layout-id must be the same as HDEF layout-id.

--

Investigating...

I see the problem. Fix pushed to the repo. Please update and repatch... test.

Hey RehabMan,

I am typing this message deliberately on my TV screen as to prove that HDMI is working perfectly now. After your update, the only patch needed is 0105 (12) patch.

I am willing to pledge my firstborn daughter to you because you're awesome!

But seriously, thank you, everything is working now. Really appreciate you taking out time to assist :)

For the rest, what I did was

cd <y50.git> folder
git reset --hard HEAD
git pull --rebase

REBOOT FROM USB

cd <y50.git>

make cleanallex
./disassemble.sh
make patch
make
make install

and reboot!
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,951
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
[Guide] Lenovo Y50 (UHD or 1080p) using Clover UEFI

Hey RehabMan,

I am typing this message deliberately on my TV screen as to prove that HDMI is working perfectly now. After your update, the only patch needed is 0105 (12) patch.

I am willing to pledge my firstborn daughter to you because you're awesome!

But seriously, thank you, everything is working now. Really appreciate you taking out time to assist :)

For the rest, what I did was

cd <y50.git> folder
git reset --hard HEAD
git pull --rebase

REBOOT FROM USB

cd <y50.git>

make cleanallex
./disassemble.sh
make patch
make
make install

and reboot!

Note for those wanting a shortcut:

This is enough to update:
Code:
cd ~/y50.git
git pull
make clean install

If you do the full re-extract/disassemble ('make cleanallex'), then you need to boot from USB.

For the simple case of a repo script update, not necessary to re-extract because you already have valid extracted/disassembled files... just update and repatch.
 
Joined
Jun 28, 2011
Messages
707
Motherboard
Lenovo Y50-70 ID8C49
CPU
i7-4710
Graphics
HD 4600 + GT 860M, 1920*1080
[Guide] Lenovo Y50 (UHD or 1080p) using Clover UEFI

Note for those wanting a shortcut:

This is enough to update:
Code:
cd ~/y50.git
git pull
make clean install

If you do the full re-extract/disassemble ('make cleanallex'), then you need to boot from USB.

For the simple case of a repo script update, not necessary to re-extract because you already have valid extracted/disassembled files... just update and repatch.

Works like a charm thanks!
I was doing some researching, and apparently intel3160 used to work bluetooth only, but recently stopped working for other users as well. Seems to be interesting, but I'm getting a compatible card once I'm in Asia in a few months. Can't seem to get one here
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,951
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
[Guide] Lenovo Y50 (UHD or 1080p) using Clover UEFI

Works like a charm thanks!
I was doing some researching, and apparently intel3160 used to work bluetooth only, but recently stopped working for other users as well. Seems to be interesting, but I'm getting a compatible card once I'm in Asia in a few months. Can't seem to get one here

Intel WiFi is not supported. There is class-driver support for all BT devices in OS X (provided firmware is on the device), but results are not reliable and it will get replaced when you install a compatible WiFi card anyway.

Not worth investigating. Waste of time...
 
Joined
Jun 28, 2011
Messages
707
Motherboard
Lenovo Y50-70 ID8C49
CPU
i7-4710
Graphics
HD 4600 + GT 860M, 1920*1080
[Guide] Lenovo Y50 (UHD or 1080p) using Clover UEFI

Any thoughts on getting iMessages and Facetime working?
I have tried the creating all the serials and such and sure it works, but you get the customer service error code during login
I have next to no reason to use it, but thought since I'm trying to get the OS fully functional, it's worth a shot just for curiosity sake
 
Status
Not open for further replies.
Top