Contribute
Register

[Guide] Lenovo Y50/Y70 (UHD or 1080p) using Clover UEFI

Joined
May 2, 2015
Messages
233
Motherboard
Lenovo Y50-70 UEFI @ Apple OS X 10.11.4 El Capitan w/ Clover & Microsoft Windows 10 1511
CPU
Intel® Core™ i7-4710HQ 2.4Ghz
Graphics
Intel HD Graphics 4600 w/ 1536MB & NVIDIA GeForce GTX 860M w/ 4GB on UHD (3840x2160) Non touch
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
[Guide] Lenovo Y50 (UHD or 1080p) using Clover UEFI

hi

just updated to 10.10.5
everything seem to work fine include my 4k display (worked from the start, i didnt needed to run the iokit patch again this time)

here my system after the update
 

Attachments

  • Yan’s MacBook Pro.ioreg
    5.6 MB · Views: 46

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,169
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
[Guide] Lenovo Y50 (UHD or 1080p) using Clover UEFI

hi

just updated to 10.10.5
everything seem to work fine include my 4k display (worked from the start, i didnt needed to run the iokit patch again this time)

here my system after the update

The IOKit framework must not be in the update... It would seem unlikely that Apple removed the limitation. You can check your md5 to see if it is still the same as it was after you last patched.
 
Joined
May 2, 2015
Messages
233
Motherboard
Lenovo Y50-70 UEFI @ Apple OS X 10.11.4 El Capitan w/ Clover & Microsoft Windows 10 1511
CPU
Intel® Core™ i7-4710HQ 2.4Ghz
Graphics
Intel HD Graphics 4600 w/ 1536MB & NVIDIA GeForce GTX 860M w/ 4GB on UHD (3840x2160) Non touch
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
[Guide] Lenovo Y50 (UHD or 1080p) using Clover UEFI

The IOKit framework must not be in the update... It would seem unlikely that Apple removed the limitation. You can check your md5 to see if it is still the same as it was after you last patched.


this what i got
4c99100b36f37df4bdcc5dc4cd2b8237

dosent match any patched md5 or i missed somthing

patched 10.10.3 should be
a045c1ac523fece1f1b083b2c5ee842c
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,169
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
[Guide] Lenovo Y50 (UHD or 1080p) using Clover UEFI

this what i got
4c99100b36f37df4bdcc5dc4cd2b8237

dosent match any patched md5 or i missed somthing

patched 10.10.3 should be
a045c1ac523fece1f1b083b2c5ee842c

From the-darkvoid's script:
Code:
		"a045c1ac523fece1f1b083b2c5ee842c"|"4c99100b36f37df4bdcc5dc4cd2b8237")
		echo "         --> Yosemite 10.10.3 / 10.10.4 IOKit (${RED}patched${OFF})"
		echo "         IOKit is already patched, no action taken."
		;;

Your IOKit is patched 10.10.4.

Your assertion that it has to be a045c1ac523fece1f1b083b2c5ee842c is incorrect.
 
Joined
May 2, 2015
Messages
233
Motherboard
Lenovo Y50-70 UEFI @ Apple OS X 10.11.4 El Capitan w/ Clover & Microsoft Windows 10 1511
CPU
Intel® Core™ i7-4710HQ 2.4Ghz
Graphics
Intel HD Graphics 4600 w/ 1536MB & NVIDIA GeForce GTX 860M w/ 4GB on UHD (3840x2160) Non touch
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
[Guide] Lenovo Y50 (UHD or 1080p) using Clover UEFI

From the-darkvoid's script:
Code:
        "a045c1ac523fece1f1b083b2c5ee842c"|"4c99100b36f37df4bdcc5dc4cd2b8237")
        echo "         --> Yosemite 10.10.3 / 10.10.4 IOKit (${RED}patched${OFF})"
        echo "         IOKit is already patched, no action taken."
        ;;

Your IOKit is patched 10.10.4.

Your assertion that it has to be a045c1ac523fece1f1b083b2c5ee842c is incorrect.

well in my 10.10.4 i had the one showen in the script
now it changed and i didnt changed it
i cant find my new md5 in the script meaning its a new one

so what am i missing ?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,169
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
[Guide] Lenovo Y50 (UHD or 1080p) using Clover UEFI

well in my 10.10.4 i had the one showen in the script

Read the script carefully. Both are there in the same case.

now it changed and i didnt changed it
i cant find my new md5 in the script meaning its a new one

so what am i missing ?

You're not reading the code very carefully.

Conclusion: You had 10.10.4 patched IOKit. You updated to 10.10.5. The IOKit is not updated in 10.10.5. Result: you still have patched 10.10.4 IOKit with no need to take any post-install steps.
 
Joined
Aug 17, 2010
Messages
201
Motherboard
Razer Blade 15 Mercury White
CPU
i7-8750H
Graphics
UHD 630 + GTX 1060
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
[Guide] Lenovo Y50 (UHD or 1080p) using Clover UEFI

[Previous text deleted]

Sorry false alarm. Must have been a one off startup issue. Seems to be ok now after updating. Odd...
 
Joined
Jan 10, 2014
Messages
96
Motherboard
Lenovo Y50-70
CPU
i7-4710HQ
Graphics
GTX 860M 4GB Maxwell
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
[Guide] Lenovo Y50 (UHD or 1080p) using Clover UEFI

hii i just upgraded from 10.11 beta 3 to 10.11 beta 4 and i am getting stuck at the apple logo
i tried veribose
without cache
without kext
without cache and kext

While in veribose i noticed the screen freezes at [IOBluetoothHCIController][start] -- completed

and as you know the bluetooth does not work

is there any way to get around this or would i have to reinstall as even recovery gets stuck at the same point
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,169
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
[Guide] Lenovo Y50 (UHD or 1080p) using Clover UEFI

hii i just upgraded from 10.11 beta 3 to 10.11 beta 4 and i am getting stuck at the apple logo
i tried veribose
without cache
without kext
without cache and kext

While in veribose i noticed the screen freezes at [IOBluetoothHCIController][start] -- completed

and as you know the bluetooth does not work

is there any way to get around this or would i have to reinstall as even recovery gets stuck at the same point

You probably neglected to set CsrActiveConfig=0x67 during the update/cache rebuild.

See config.plist from guide: http://www.tonymacx86.com/yosemite-...de-booting-os-x-installer-laptops-clover.html
 
Joined
Jan 10, 2014
Messages
96
Motherboard
Lenovo Y50-70
CPU
i7-4710HQ
Graphics
GTX 860M 4GB Maxwell
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
[Guide] Lenovo Y50 (UHD or 1080p) using Clover UEFI

thank you for the advice i got frustrated and reinstalled
 
Top