Contribute
Register

[Guide] Lenovo Y50/Y70 (UHD or 1080p) using Clover UEFI

Joined
Apr 20, 2013
Messages
39
Motherboard
Lenovo Y5070 (Clover)
CPU
Core i7 4710HQ/Intel 8 Series
Graphics
Intel HD4600, Nvidia Geforce GTX 860M Screen Resolution: 1920x1080
Mac
Classic Mac
Mobile Phone
[Guide] Lenovo Y50 (UHD or 1080p) using Clover UEFI

The Y50 uses NGFF form factor for WiFi card. Half mini PCIe cards don't fit (physically).

and the only NGFF card supported by OSX is bcm94352z?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,161
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
[Guide] Lenovo Y50 (UHD or 1080p) using Clover UEFI

and the only NGFF card supported by OSX is bcm94352z?

Only confirmed:
- BCM94352Z
- BCM94352ZAE

Might work, but not confirmed:
- BCM94356Z
- BCM94356ZAE

Not sure it exists, but if it did, would probably work:
- BCM94360Z
- BCM94360ZAE
 
Joined
Oct 18, 2014
Messages
69
CPU
i7 8750H
Graphics
GTX 1050 Ti / UHD 630
Mobile Phone
  1. iOS
[Guide] Lenovo Y50 (UHD or 1080p) using Clover UEFI

No need to copy CLOVERX64.efi. Just rename bootmgfw.efi to bootmgfw-orig.efi.Windows updates will create bootmgfw.efi, so after that, remove bootmgfw-orig.efi and rename bootmgfw.efi to bootmgfw-orig.efi.
Hello,I've just installed Windows 10 and followed this instruction here. But seems like there is something new with Windows 10 that renaming and deleting as instructed doesn't work. I still cannot boot to Clover after using Windows. Please help.Thank you.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,161
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
[Guide] Lenovo Y50 (UHD or 1080p) using Clover UEFI

Hello,I've just installed Windows 10 and followed this instruction here. But seems like there is something new with Windows 10 that renaming and deleting as instructed doesn't work. I still cannot boot to Clover after using Windows. Please help.Thank you.

You must delete, then rename. Not rename then delete.

Make sure bootmgfw-orig.efi is the latest from Win10.
 
Joined
Oct 18, 2014
Messages
69
CPU
i7 8750H
Graphics
GTX 1050 Ti / UHD 630
Mobile Phone
  1. iOS
[Guide] Lenovo Y50 (UHD or 1080p) using Clover UEFI

You must delete, then rename. Not rename then delete.Make sure bootmgfw-orig.efi is the latest from Win10.
Yes that's exactly what I did, delete and then rename. I did that a bunch of times, so I think the file is created by Windows 10.
 
Joined
Oct 18, 2014
Messages
69
CPU
i7 8750H
Graphics
GTX 1050 Ti / UHD 630
Mobile Phone
  1. iOS
[Guide] Lenovo Y50 (UHD or 1080p) using Clover UEFI

Yes that's exactly what I did, delete and then rename. I did that a bunch of times, so I think the file is created by Windows 10.
Okay so I found out that the orig file is reseted everytime I boot to Windows. Before rename the file is 1.2Mb. After rebooting it is 1.6Mb. It is the same size as the file while I was using Windows 8. So I guess that's the issue. Would updating clover solve the problem?
 
Joined
Oct 18, 2014
Messages
69
CPU
i7 8750H
Graphics
GTX 1050 Ti / UHD 630
Mobile Phone
  1. iOS
[Guide] Lenovo Y50 (UHD or 1080p) using Clover UEFI

Okay so I found out that the orig file is reseted everytime I boot to Windows. Before rename the file is 1.2Mb. After rebooting it is 1.6Mb. It is the same size as the file while I was using Windows 8. So I guess that's the issue. Would updating clover solve the problem?
I updated clover but it's still not working. Any suggestions?
 
Joined
Oct 18, 2014
Messages
69
CPU
i7 8750H
Graphics
GTX 1050 Ti / UHD 630
Mobile Phone
  1. iOS
[Guide] Lenovo Y50 (UHD or 1080p) using Clover UEFI

What is not working?

Rebooting from Windows 10 would create a bootmgfw.efi and a new bootmgfw-orig.efi so I cannot use Clover after restarting from Windows.

Hello,I've just installed Windows 10 and followed this instruction here. But seems like there is something new with Windows 10 that renaming and deleting as instructed doesn't work. I still cannot boot to Clover after using Windows. Please help.Thank you.

Okay so I found out that the orig file is reseted everytime I boot to Windows. Before rename the file is 1.2Mb. After rebooting it is 1.6Mb. It is the same size as the file while I was using Windows 8. So I guess that's the issue. Would updating clover solve the problem?
 
Joined
May 2, 2015
Messages
233
Motherboard
Lenovo Y50-70 UEFI @ Apple OS X 10.11.4 El Capitan w/ Clover & Microsoft Windows 10 1511
CPU
Intel® Core™ i7-4710HQ 2.4Ghz
Graphics
Intel HD Graphics 4600 w/ 1536MB & NVIDIA GeForce GTX 860M w/ 4GB on UHD (3840x2160) Non touch
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
[Guide] Lenovo Y50 (UHD or 1080p) using Clover UEFI

why dont you use easyuefi ?

i created a my boot order with it and everything works fine even after update to win10
 
Top