Contribute
Register

[Guide] Lenovo Y50 (UHD or 1080p) using Clover UEFI (10.11)

Joined
Mar 11, 2015
Messages
28
Motherboard
Windows 10
CPU
Intel Core i7 4710HQ
Graphics
NVIDIA GeForce GTX 860M & Intel HD 4600
Mac
Classic Mac
Mobile Phone
Android
#2
[Guide] Lenovo Y50 (UHD or 1080p) using Clover UEFI (10.11 beta)

What will happen when the stable release is out. Will that require a whole reinstall (making a new USB with the stable release)?
 
Joined
May 3, 2012
Messages
191,252
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
#3
[Guide] Lenovo Y50 (UHD or 1080p) using Clover UEFI (10.11 beta)

What will happen when the stable release is out. Will that require a whole reinstall (making a new USB with the stable release)?
No one can predict the future. I never do an install of final over a beta. Always fresh install or update from previous version.
 
Joined
May 3, 2012
Messages
191,252
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
#4
Note: Moved guide post #1 from Yosemite guides section.

Post 10.10 questions to the Yosemite guides thread.
Post 10.11 questions here.
 
Joined
Jul 18, 2015
Messages
44
Motherboard
Lenovo Y50-70
CPU
i7-4720HQ Haswell HM87
Graphics
Intel HD 4600 1920x1080, Nvidia GTX-960M 4 giga
Mac
Classic Mac
Mobile Phone
Android, iOS
#5
@rehabman
changed it again to macbookpro 11.1 and still the same

here is new ioreg backup and followed the instructions again and i think that usbxhci_y50 still not loading
 

Attachments

Joined
May 3, 2012
Messages
191,252
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
#6
@rehabman
changed it again to macbookpro 11.1 and still the same

here is new ioreg backup and followed the instructions again and i think that usbxhci_y50 still not loading
USBHX_y50.kext is now loading.
 
Joined
Jun 28, 2011
Messages
713
Motherboard
Lenovo Y50-70 Haswell ID8C49
CPU
i7-4710
Graphics
Intel 4600 + 4gb Geforce 860M 1920*1080
Mac
Classic Mac
Mobile Phone
#7
USBHX_y50.kext is now loading.
His ioreg is still not right though
He has USB2InternalHub not USB2Hub
Which suggests to me that the kext is not the right kext
The changes we made last night should have it showing up as USB2Hub, which would allow the correct mounting of network drives
Would explain why he can't access his network usb stuff
 
Joined
May 3, 2012
Messages
191,252
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
#8
His ioreg is still not right though
He has USB2InternalHub not USB2Hub
Which suggests to me that the kext is not the right kext
The changes we made last night should have it showing up as USB2Hub, which would allow the correct mounting of network drives
Would explain why he can't access his network usb stuff
I'm not sure what triggers AppleUSB20InternalHub vs. AppleUSB20Hub.

Maybe you should post a recent ioreg.
 
Joined
Jun 28, 2011
Messages
713
Motherboard
Lenovo Y50-70 Haswell ID8C49
CPU
i7-4710
Graphics
Intel 4600 + 4gb Geforce 860M 1920*1080
Mac
Classic Mac
Mobile Phone
#9
I'm not sure what triggers AppleUSB20InternalHub vs. AppleUSB20Hub.

Maybe you should post a recent ioreg.
The hub injector we added yesterday made it so it would be AppleUSB20Hub. Previously, without the hub injector, it would automatically be set as AppleUSB20InternalHub

I suspect if he uploaded his USBXHCI_y50.kext from both Clover and Extensions folder, you'll either find only one of them is updated, or neither of them are

I attached my ioreg. Only difference is I don't have USBXHCI_y50.kext in my extensions folder. I only have it in my Clover kext folder for simplicity and testing purposes since I'm too lazy to rebuild cache each time I test
 

Attachments

Joined
May 3, 2012
Messages
191,252
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
#10
The hub injector we added yesterday made it so it would be AppleUSB20Hub. Previously, without the hub injector, it would automatically be set as AppleUSB20InternalHub
Not according to the ioreg in post #5. The injector looks up-to-date, except for the mistake I just checked in a change for...

I suspect if he uploaded his USBXHCI_y50.kext from both Clover and Extensions folder, you'll either find only one of them is updated, or neither of them are
The one from EFI/Clover/kexts/Other has no effect, since FakeSMC is installed to /S/L/E.

As always though... this is always smart:
Code:
git pull
./download.sh
./install_downloads.sh
Or in this case, a bit less time involved:
Code:
git pull
make install_usb
I attached my ioreg
Your ioreg shows the injector kext NOT installed.
 
Top