Contribute
Register

[Guide] Lenovo V510-15ikb

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,109
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
This is my current EFI partition. I try to modify the config.plist with the one present in this post for the section device to sei intel . But also not work , I have the same result , 4mb of ram and no ktext load ( like the image )

n.b: I know now that there is the # for comment the key in the config.plist
"Problem Reporting" files are incomplete/wrong/too large.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Joined
Oct 17, 2013
Messages
141
Motherboard
Dell Vostro 15
CPU
i5-7200U
Graphics
HD620, 1920*1080
Mobile Phone
iOS
This is the file generating

=====================================

+ macOS DEBUG REPORT GENERATOR +

-------------------------------------

+ SCRIPT VERSION 4.3.1 +

=====================================


=====================================

+ AUTHOR: black.dragon74 +

=====================================


Hold on for a moment....

Found script data directory at /Users/daniele/Library/debugNk

EFI Mount Script (RehabMan) found. No need to download.

IORegistryExplorer found at /Applications/IORegistryExplorer.app

Verifying if correct version of IORegistryExplorer is installed.

Your version of IORegistryExplorer.app passed the check. Good to go!

Patchmatic not installed. Checking in DATA directory.

Binary found in DATA directory.

Data will be dumped at /Users/daniele/Desktop/12865

Dumping loaded ACPI tables.

Dumped loaded ACPI tables.

Dumping clover files.

Mounted EFI at /Volumes/EFI (credits RehabMan)

Verifying your EFI files...

ACPI files were dumped recently. Great!

Preboot log was dumped recently. Great!

All checks passed. Copying CLOVER files...

Removing theme dir from the dump.

Removing tools dir from the dump.

Masking your System IDs

Dump of CLOVER files completed successfully.

Unmounted /Volumes/EFI

Dumping System log.

Dumping kernel panic logs...

Dumping kernel log.

Dumping kextstat.

Dumping kextcache

Dumping IOREG.

IOREG Verified as /Users/daniele/Desktop/12865/MBP-di-daniele.ioreg

System dump not requested.

You may use gen_debug -sysprofile to generate system dump.

For output in TXT format use: "gen_debug -sysprofile txt". Default format is SPX

Dumping Boot log

Dumping NVRAM values...

Zipping all the files

Zipped files at: /Users/daniele/Desktop/12865/debug_12865.zip

Dump complete. Open /Users/daniele/Desktop/12865?(Yy/Nn) n

Okay. You can open it manually.

Thank You! Hope your problem gets sorted out soon.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,109
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
This is the file generating

=====================================

+ macOS DEBUG REPORT GENERATOR +

-------------------------------------

+ SCRIPT VERSION 4.3.1 +

=====================================


=====================================

+ AUTHOR: black.dragon74 +

=====================================


Hold on for a moment....

Found script data directory at /Users/daniele/Library/debugNk

EFI Mount Script (RehabMan) found. No need to download.

IORegistryExplorer found at /Applications/IORegistryExplorer.app

Verifying if correct version of IORegistryExplorer is installed.

Your version of IORegistryExplorer.app passed the check. Good to go!

Patchmatic not installed. Checking in DATA directory.

Binary found in DATA directory.

Data will be dumped at /Users/daniele/Desktop/12865

Dumping loaded ACPI tables.

Dumped loaded ACPI tables.

Dumping clover files.

Mounted EFI at /Volumes/EFI (credits RehabMan)

Verifying your EFI files...

ACPI files were dumped recently. Great!

Preboot log was dumped recently. Great!

All checks passed. Copying CLOVER files...

Removing theme dir from the dump.

Removing tools dir from the dump.

Masking your System IDs

Dump of CLOVER files completed successfully.

Unmounted /Volumes/EFI

Dumping System log.

Dumping kernel panic logs...

Dumping kernel log.

Dumping kextstat.

Dumping kextcache

Dumping IOREG.

IOREG Verified as /Users/daniele/Desktop/12865/MBP-di-daniele.ioreg

System dump not requested.

You may use gen_debug -sysprofile to generate system dump.

For output in TXT format use: "gen_debug -sysprofile txt". Default format is SPX

Dumping Boot log

Dumping NVRAM values...

Zipping all the files

Zipped files at: /Users/daniele/Desktop/12865/debug_12865.zip

Dump complete. Open /Users/daniele/Desktop/12865?(Yy/Nn) n

Okay. You can open it manually.

Thank You! Hope your problem gets sorted out soon.
You're using an invalid ig-platform-id. No expectation of working graphics with wrong ig-platform-id.
 
Joined
Oct 17, 2013
Messages
141
Motherboard
Dell Vostro 15
CPU
i5-7200U
Graphics
HD620, 1920*1080
Mobile Phone
iOS
But I use the same ig-platform-id from the config.plist find on the topic. I don’t have to use the same?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,109
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
But I use the same ig-platform-id from the config.plist find on the topic. I don’t have to use the same?
In your config.plist, you have 0x19168086 (invalid).
In post #1 config.plist, it is 0x19160000 (valid Skylake id, suitable if doing SKL spoof on KBL).
 
Joined
Oct 17, 2013
Messages
141
Motherboard
Dell Vostro 15
CPU
i5-7200U
Graphics
HD620, 1920*1080
Mobile Phone
iOS
I try both value 19168086 and 19160000.

But now i change the value in config.plist ( to re-try the 19160000 ) also in Device-IntelGFX and Graphics-og-platform-id , clear NVRAM with F11 on boot cloverEFI but the value in properties from apple remainng 19168086 ( the oldest )
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,109
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I try both value 19168086 and 19160000.

But now i change the value in config.plist ( to re-try the 19160000 ) also in Device-IntelGFX and Graphics-og-platform-id , clear NVRAM with F11 on boot cloverEFI but the value in properties from apple remainng 19168086 ( the oldest )
0x19168086 is invalid.

No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Joined
Oct 17, 2013
Messages
141
Motherboard
Dell Vostro 15
CPU
i5-7200U
Graphics
HD620, 1920*1080
Mobile Phone
iOS
Yes I understand is invalid, now i set on my config.plist 19160000 , but when the system boot up i found always 19168086
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,109
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Yes I understand is invalid, now i set on my config.plist 19160000 , but when the system boot up i found always 19168086
Still no PR files attached.
 
Joined
Oct 17, 2013
Messages
141
Motherboard
Dell Vostro 15
CPU
i5-7200U
Graphics
HD620, 1920*1080
Mobile Phone
iOS
here we are :)

p.s: thank you for the patience
 

Attachments

Top