Contribute
Register

[Guide] Lenovo ThinkPad X240

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,691
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hi @RehabMan
All required files in clover.zip.
i tried to get update from app store. then external keyboard, mouse are not working and battery icon and battery % not shown.
when i disconnect my charger .it show notification your mac sleeps in 5 min or else. with red battery icon.
also i removedSSDT-x240.aml from the patched folder. but my hackintosh still able to boot. i think ssdt is not working on hackintosh.
thanks.
Your kextcache output proves kexts are not installed correctly.
All kexts you need must be installed to the system volume.
Read post #2 of the Clover guide for details:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/

Did not check anything else.
 
Joined
Jan 27, 2018
Messages
1
Hi has anyone tried the x240 high sierra on the Lenovo ThinkPad Ultra Dock 40A2 ? I have built using this guide all works fine until I dock the unit. the Machine restarts looks to be a gpu error, was under the impression the dock requires no drivers .. works fine under windows 10 and Linux mint. any advice would be greatly appreciated.
 
Joined
Jan 22, 2019
Messages
99
Motherboard
Thinkpad T470p-Clover
CPU
i7-7700HQ
Graphics
HD 630, 2560 x 1440
Hello everyone... followed to the letter guide posted at n. 26 post, but for the sake of me I can't get audio working. Tried also apple alc method. I had a run also with Voodoohda but it only works with speakers and stops working as soon as it goes in sleep mode. Is there anyone with working audio under Mojave?
Attached files for trouble shooting as per OP. Thanks
 

Attachments

Joined
Oct 17, 2018
Messages
18
Motherboard
thinkpad x240
CPU
i5-4300U
Graphics
HD 4400
Classic Mac
iMac
Mobile Phone
Android
One question, I know, that it is a forum for hackintosh, but I have a big problem with Windows 10. I need it. But I cannot find the drivers for the BCM94352Z Wireless. And it does not work.

Does somebody have the drivers for Windows 10?

Thanks!!!
 
Joined
Jan 3, 2018
Messages
39
Motherboard
q77
CPU
Core i5 3570 3.40Ghz
Graphics
Nvidia GTX 1050
Mac
iMac, MacBook Pro
Mobile Phone
Android
There are two guides with the same title. Now I'm confused on which one to follow on Mojave, the first post on this thread or the post 26 on the other thread?
 
Joined
May 21, 2019
Messages
5
Motherboard
Thinkpad x240
CPU
I7 4600u
Hello,
I tried to install mojave with the instruction on page 3 and also with other clover version.
Every Time clover is stucking on loading mac os After install on „End RandomSeed“.

Is there and trick to get further or is it not possible to Boot from an external Drive?

Attached the clover output
 

Attachments

Joined
May 21, 2019
Messages
7
Motherboard
ThinkPad X240 Mainboard NM-A091
CPU
Intel Core i7-4600U SR1EA
Graphics
Intel HD 4400
Hey there!

I am experiencing a flickering of pixels across the whole screen, especially on darker background it can be seen as little coloured dots appearing across the screen. I followed this guide for x240, I also tried the guide specially for Intel HD 4400 and it doesn't seem to fix the problem.

I need your help! I've done a fresh install of High Sierra where was the problem and now I updated to Mojave but the problem persist. I've installed everything what I found needed in the post-installation and everything seems to work fine except this.

I created the problem reporting dump via script here on forum, I hope its complete.

Thanks a lot for all your help I am so grateful for all the guides and great support, I am learning so much about hackintosh on this forum :thumbup:
 

Attachments

Top