Contribute
Register

[Guide] Lenovo ThinkPad X240

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,927
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I installed the tluck voodoops2controller kext and the trackpad now works fine, I configured it in the shortcuts,
With the properties from .dsl, my version should behave the same. Maybe you're not applying the properties into your SSDT correctly.

but isn't there any way to emulate real gestures ? It just act as key combinations
Real gestures are not implemented.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,927
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Joined
Jun 19, 2018
Messages
17
Motherboard
Lenovo X240
CPU
I5 4300U
Graphics
HD4400
Audio won't work with my current setup.
On macOS Mojave, Apple removed a lot of Layouts (LayoutID) from AppleHDA.kext.
What we currently use on my guides is LayoutID 28 (which has been removed).

So you will have to change layout ID to a existing one on both SSDT-HDEF & SSDT-HDAU (for example use layout id 2).
Also you must edit my audio kext to use layout id 2.

I will update my guides for macOS Mojave after Public Beta comes out.
Hi Sniki
macOS Mojave exited, you can be manual on X240 complete
Thanks
 
Joined
Oct 17, 2018
Messages
18
Motherboard
thinkpad x240
CPU
i5-4300U
Graphics
HD 4400
Classic Mac
iMac
Mobile Phone
Android
Hi, sorry for question but I have the screen change for other with FHD, and I have problems with the screen. I get the Clover Screen on the start screen. The Apple screen continues but there is a point (where the verbose mode disapears) which I got this screen:

 
Joined
Apr 5, 2016
Messages
3
Motherboard
Lenovo x240
CPU
I5-4300U
Graphics
HD 4400 1366*786
Mobile Phone
Android, Other
Hi, @RehabMan I have a problem with my graphics hd 4400 it shows 4MB only and screen glitches everytime i boot into hackintosh. i attached. bootlogs.
it detects my graphics but only showing 4MB. in system preference it show in graphics/Display tab : no kext loaded. clover folder attached. please help me to resolve this issue. Thanks
 

Attachments

Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,927
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hi, @RehabMan I have a problem with my graphics hd 4400 it shows 4MB only and screen glitches everytime i boot into hackintosh. i attached. bootlogs.
it detects my graphics but only showing 4MB. in system preference it show in graphics/Display tab : no kext loaded. clover folder attached. please help me to resolve this issue. Thanks
"Problem Reporting" files are incomplete.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Joined
Apr 5, 2016
Messages
3
Motherboard
Lenovo x240
CPU
I5-4300U
Graphics
HD 4400 1366*786
Mobile Phone
Android, Other
"Problem Reporting" files are incomplete.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.

Hi @RehabMan
All required files in clover.zip.
i tried to get update from app store. then external keyboard, mouse are not working and battery icon and battery % not shown.
when i disconnect my charger .it show notification your mac sleeps in 5 min or else. with red battery icon.
also i removedSSDT-x240.aml from the patched folder. but my hackintosh still able to boot. i think ssdt is not working on hackintosh.
thanks.
 

Attachments

Last edited:
Top