Contribute
Register

[Guide] Lenovo ThinkPad X240 [OpenCore 0.6.7] [WIP]

Sniki

Moderator
Joined
Jan 5, 2016
Messages
2,316
Motherboard
HP Elite 8300 SFF
CPU
i7-3770
Graphics
HD 3000 | GTX 1650 LP
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
1616418468023.png


Lenovo ThinkPad X240 using OpenCore (0.6.7)

The Readme, Instructions and the EFI is provided here: https://github.com/Sniki/Lenovo-Thinkpad-X240


Problem Reporting and Troubleshooting

Please provide proper Problem Reporting (archive) which includes the EFI and a copy of IOREG.
IOREG should be saved with the correct working version of IOregistryExplorer that can be found here:
 
Last edited:

Sniki

Moderator
Joined
Jan 5, 2016
Messages
2,316
Motherboard
HP Elite 8300 SFF
CPU
i7-3770
Graphics
HD 3000 | GTX 1650 LP
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Reserved for future post #1
 

Sniki

Moderator
Joined
Jan 5, 2016
Messages
2,316
Motherboard
HP Elite 8300 SFF
CPU
i7-3770
Graphics
HD 3000 | GTX 1650 LP
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Reserved for future post #2
 

Sniki

Moderator
Joined
Jan 5, 2016
Messages
2,316
Motherboard
HP Elite 8300 SFF
CPU
i7-3770
Graphics
HD 3000 | GTX 1650 LP
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Reserved for future post #3
 
Joined
Mar 15, 2021
Messages
7
Motherboard
Thinkpad x240
CPU
I5 4300U
Graphics
Intel HD graphics
I take off my hat. Impressive work. Everything seems to be working perfectly, even Wifi and Bluetooth (haven't tried transfer speeds tho).
No idea about battery, my old thinkpad is always plugged in and used as a desktop replacement for office work and some audio recording.
I had some trouble with the wake after the laptop was idle during 15 mn (I was doing something else in other room). I couldn't wake it after that, had to manually reboot it.
No idea if it will happen again, as I disabled sleep because I need to do some work this afternoon. I will enable it and test it again asap and report here my results.

FAN STOP works with YogaSMCPanel, that's just a blessing to my ears. Only thing that remains would be to create a custom profile for my fans, with different functioning level according to some temps. No idea how to do that tho, but I will research.

Thanks again Sniki, you're giving my Thinkpad a new life.

Edit1: I tested wireless connection for speed. I get about a 30% of the speed I get with ethernet. Still, impressive that it works out of the box! No need for a wifi dongle is a HUGE win.
 
Last edited:

Sniki

Moderator
Joined
Jan 5, 2016
Messages
2,316
Motherboard
HP Elite 8300 SFF
CPU
i7-3770
Graphics
HD 3000 | GTX 1650 LP
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
FAN STOP works with YogaSMCPanel, that's just a blessing to my ears. Only thing that remains would be to create a custom profile for my fans, with different functioning level according to some temps. No idea how to do that tho, but I will research
It will be something that i plan to work for myself as well, it ramps up for not much logical reasons, i checked the temps and it's scaling up for no need/earlier than needed.
Edit1: I tested wireless connection for speed. I get about a 30% of the speed I get with ethernet. Still, impressive that it works out of the box! No need for a wifi dongle is a HUGE win.
It's normal, they only support N speed right now, they have planned to implement AC support for next release and then full speeds will be available for everyone using Intel Cards.
 
Joined
Jun 2, 2020
Messages
16
Motherboard
X240
CPU
i5 4300U
Graphics
HD 4400
Mac
  1. MacBook
Classic Mac
  1. 128K
Mobile Phone
  1. iOS
Thank you Sniki. I have just tested new EFI, and all can I say, that it Is flawless. Much thanks.

Also, did someone found fix for DW1820a and interferences (especially BT audio) due to 3G? Changing firmware doesn't help (@acidentehera BrcmPatchRAM3 use the lastes anyway) . In Windows, and Linux works fine.
Does Intel card had this same issue (also duble antena)?
 

Sniki

Moderator
Joined
Jan 5, 2016
Messages
2,316
Motherboard
HP Elite 8300 SFF
CPU
i7-3770
Graphics
HD 3000 | GTX 1650 LP
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Thank you Sniki. I have just tested new EFI, and all can I say, that it Is flawless. Much thanks.

Also, did someone found fix for DW1820a and interferences (especially BT audio) due to 3G? Changing firmware doesn't help (@acidentehera BrcmPatchRAM3 use the lastes anyway) . In Windows, and Linux works fine.
Does Intel card had this same issue (also duble antena)?
Honestly i believe that i had that resolved if i am not wrong.

I will install Big Sur on my x240 tonight as it does have the DW1820A installed and test it.
Can you provide a clear scenario on how can you reproduce that interference ?

Intel Bluetooth is not very stable right now but at least it’s fantastic that no one needs to use a replacement card if on tight budget or to use any usb wifi/bluetooth.
For now it only support up to N speeds.
Dual Band AC is planned for next update v1.3 but no ETA on when they will do that.
 
Joined
Mar 22, 2021
Messages
1
Motherboard
x240
CPU
i5
Graphics
haswell
Thank you so much Sniki for you new release. I made an upgrade starting from your previous release based on OC 6.3 plus Big Sur. All it's working but I have trouble with ALCPlugFIx procedure. In 6.3 I had no problem installing the procedure and the sound coming from headset was good. After the execution of the procedure now the sound is off and I can ear only analog disturb.
Any hints ?
Thanks in advance
Giorgio
 
Joined
May 21, 2019
Messages
7
Motherboard
Thinkpad x240
CPU
I7 4600u
Graphics
INTEL
same here, everything is working like a charm, instead of the ALCPlugFix.
tested on Catalina then updated to Big Sur with the same issue.
 
Top