Contribute
Register

[Guide] Lenovo ThinkPad T440S

Joined
Nov 24, 2010
Messages
26
Motherboard
ThinkPad T440s-Clover
CPU
i5-4300U
Graphics
HD 4400, 1920x1080
Mac
Mac mini
Mobile Phone
iOS
Is there any other way to get a better touchpad experience on this laptop? I mean, is the T560/T450 (I don't remember which one exactly) touchpad better supported or something?
I started with the original buttonless trackpad and it worked fine, but the experience was clunky...literally. I changed it out for the T450 trackpad by Synaptics and the tracking is improved I think and the physical buttons make for a much better experience. Swapping it out isn't too bad, but I would suggest watching this video
for a good walkthrough of the process.
 
Joined
Apr 26, 2016
Messages
3
Mac
Classic Mac
Mobile Phone
I started with the original buttonless trackpad and it worked fine, but the experience was clunky...literally. I changed it out for the T450 trackpad by Synaptics and the tracking is improved I think and the physical buttons make for a much better experience. Swapping it out isn't too bad, but I would suggest watching this video
for a good walkthrough of the process.
I modified the tracking speed with MaciASL and the scrolling feels a lot better now, nearly as smooth as under Windows. I would only replace the touchpad if I could get gestures to work, for example three finger swipes but as far as I know there is no way to get that working on any touchpad. Thank you for the video though.

And a small update as for the broken digitizer, instead of modifying anything in the SSDT-USB, I simply disconnected the touch ribbon, everything is working fine now.
 
Joined
Mar 18, 2019
Messages
6
Motherboard
ThinkPad T440s-Clover
CPU
i5-4200U
Graphics
HD4400, 1600x900
Mac
MacBook Air
Mobile Phone
iOS
UPDATE: Skip this one, replaced by: https://www.tonymacx86.com/threads/guide-lenovo-thinkpad-t440s.244798/post-1929069


First of all, thank you for all your work on this.

I installed Mojave on my Lenovo T440s (first time doing this). The only problem I had was that it would not boot from HDD/SSD, but only from USB. I found a post with the solution (https://www.tonymacx86.com/threads/guide-lenovo-thinkpad-t440s.244798/post-1915430 - Basically copy my EFI folder from the USB into the EFI folder of the HDD/SSD). Other than that it worked like a charm and I had access to a Mojave desktop with most things working.

So far:
WORKING: Audio, Internal Display, VGA port, Ethernet, USB ports, Display Brightness and Audio Function keys, Trackpad, Mic, iMessage and Facetime (no camera - had to follow https://www.tonymacx86.com/threads/an-idiots-guide-to-imessage.196827/)
NOT CHECKED (Not really needed): MiniDP
STILL TO WORK ON (pending): WiFi/BT (I ordered a DW1560 and should be updating in the next few days)
NOT WORKING: Camera (checked with Image Capture and PhotoBooth, although the camera LED lights up)

I am attaching here all my diagnostic files (removed) in case you can provide any recommendations to get my camera working.

Thanks again,


F4


UPDATE #1: On System Information the camera shows up as "UVC Camera VendorID_22918 ProductID_618" (debug files attached are in this state). Later, I tried using RehabMan's FakePCIID_XHCIMux.kext (with all FakePCIID*.kext's) without any luck, and on System Information it goes to "No camera device". Again, the debug files sent are before trying FakePCCID*.kext's.

UPDATE #2: Audio had stopped working because I updated to the latest Mojave version, and started working again when I re-ran "kextcache -i /".
 
Last edited:
Joined
Mar 18, 2019
Messages
6
Motherboard
ThinkPad T440s-Clover
CPU
i5-4200U
Graphics
HD4400, 1600x900
Mac
MacBook Air
Mobile Phone
iOS
Separate question: My T440s has BIOS 2.27 (GJET77WW). Is there any benefit on upgrading it to 2.36 (and no higher because of the whitelisting issue)? or should I just leave it at 2.27?
@Sniki @Fobos531
 
Last edited:
Joined
Nov 24, 2010
Messages
26
Motherboard
ThinkPad T440s-Clover
CPU
i5-4300U
Graphics
HD 4400, 1920x1080
Mac
Mac mini
Mobile Phone
iOS
Separate question: My T440s has BIOS 2.27 (GJET77WW). Is there any benefit on upgrading it to 2.36 (and no higher because of the whitelisting issue)? or should I just leave it at 2.27?
@Sniki @Fobos531
I'm not certain, but I believe that 2.36 is the only T440s BIOS that is whitelist-free. From what I understand, it was not intentional on the part of Lenovo but was released without a whitelist in place.
 
Joined
Mar 18, 2019
Messages
6
Motherboard
ThinkPad T440s-Clover
CPU
i5-4200U
Graphics
HD4400, 1600x900
Mac
MacBook Air
Mobile Phone
iOS
I'm not certain, but I believe that 2.36 is the only T440s BIOS that is whitelist-free. From what I understand, it was not intentional on the part of Lenovo but was released without a whitelist in place.
Thanks a lot for replying. I will update the BIOS to version 2.36 just to be safe.
 
Joined
Mar 18, 2019
Messages
6
Motherboard
ThinkPad T440s-Clover
CPU
i5-4200U
Graphics
HD4400, 1600x900
Mac
MacBook Air
Mobile Phone
iOS
I'm not certain, but I believe that 2.36 is the only T440s BIOS that is whitelist-free. From what I understand, it was not intentional on the part of Lenovo but was released without a whitelist in place.
You were totally right. When I replaced the WiFi+BT card and turned it on, the T440s complained right away about an "unauthorized card" (on BIOS 2.27). After upgrading it to BIOS 2.36 it did not complain anymore and worked perfectly.

Another tip. I got the "wrong" BCM94352Z Wireless / Bluetooth Card (The one on the right with one slot instead of two):
394846

It happens that the one with two slots is very difficult to find in the US and would have to be ordered from China (EBay, Alibaba, etc.), and the one with one slot can be found in the US (cheaper and quicker - i.e. EBay, Amazon).

Well, the only difference is the slot, no electronics go through there, and if you are careful enough (and have the proper tools - don't lose a finger doing this), you can just "create" that second slit: the card is detected and works perfectly. Here is how mine looks now when plugged in:
394850


Thanks again
 
Joined
Mar 18, 2019
Messages
6
Motherboard
ThinkPad T440s-Clover
CPU
i5-4200U
Graphics
HD4400, 1600x900
Mac
MacBook Air
Mobile Phone
iOS
This is a follow up from this previous post.

I had ordered a BCM94352Z WiFi+BT card (as shown on previous posts) and a new SDD (500GB), so I decided to re-install my T440s Hackintosh from scratch, and see if the camera was not working because of something I messed up.

Unfortunately, I arrived at the same results. Everything works perfectly (including new WiFi and BT), but not the camera. Here is a summary as of now (same as before):

WORKING: Audio, internal display, external VGA port, Ethernet, WiFi, BT (including AirDrop), USB ports, Display Brightness/Audio Function keys, Trackpad, Mic, and USB ports on ThinkPad USB 3.0 Pro Dock (will check secondary ethernet, DVI video, and Full DP video - in the next week)
NOT CHECKED (Not really needed): MiniDP
NOT WORKING: Camera

I have not configured iMessage or Facetime yet, but I plan to do it once the camera works. Should not be a problem.

FYI: In System Information, the camera shows up as "UVC Camera VendorID_22918 ProductID_618", and I found out here that UVC webcams are supposed to be detected and to work by default in Mac OS 10.4/9 and above because the QuickCam 9000 is a UVC webcam. It should have been detected by the default Clover config but it wasn't, so maybe that kext is missing from the default Clover selection shown by @Sniki in the Mojave post on page 13? or I definitely missed something ... :'(

I am attaching here all my diagnostic files. I appreciate if any of the experts here can shed some light on this, and I can get that camera working.

Regards, and thanks again,


F4
 

Attachments

Last edited:
Joined
Mar 18, 2019
Messages
1
Motherboard
Haswell
CPU
i7
Graphics
HD4400
could anyone drop me a hint which part of the dsl and hotpatches i have to disable for smartTouchpad to function properly?

many thanks
 
Top