Contribute
Register

[Guide] Lenovo ThinkPad T440S [OpenCore 0.6.7]

Joined
Dec 15, 2020
Messages
4
Motherboard
T440s
CPU
i7-4600U
Graphics
HD 4400
I just attempted to boot latest Big Sur installer on VGA with Secure Boot on and I can confirm that everything works. Mouse did not work properly initially (macOS mirrors contents of both screens, but does not mirror mouse pointer), but closing the lid resolved the issue for me.
 
Joined
Feb 23, 2020
Messages
147
Motherboard
Dell Precision M4700
CPU
i7-3740QM
Graphics
M4000
I checked, it's enabled and not working.
Is it an Elans touchpad rather than Synaptics? Could try using the latest version of VoodooSMBus from that repo specifically. That includes an Elans driver. Don't use the modified VoodooSMBus.kext from VoodooRMI
 
Joined
Sep 24, 2020
Messages
11
Motherboard
T440s
CPU
4200U
Graphics
HD 4400
Is it an Elans touchpad rather than Synaptics? Could try using the latest version of VoodooSMBus from that repo specifically. That includes an Elans driver. Don't use the modified VoodooSMBus.kext from VoodooRMI
I don't think T440s even had elans, the driver page only gives a driver for synaptics. I'll give it a try anyway.
 
Joined
Jan 24, 2020
Messages
9
Motherboard
Thinkpad T440s
CPU
Intel core i7 4600U
Graphics
HD 4400
New update (OC 0.6.7) failed to boot
 

Sniki

Moderator
Joined
Jan 5, 2016
Messages
2,316
Motherboard
HP Elite 8300 SFF
CPU
i7-3770
Graphics
HD 3000 | GTX 1650 LP
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
New update (OC 0.6.7) failed to boot
You have to provide more information on how it is failing to boot for you, what screen, where it gets stuck, is it reporting any error message, etc.

So far i don’t have a single report of a failure since the update, everyone reported that it is working fine.

taking this into consideration i would double check if you missed or touched something or haven’t properly updated.
 
Joined
Dec 21, 2018
Messages
36
Motherboard
Lenovo t440S
CPU
4600u
Graphics
HD
Hi Sniki, everything work fine except the Secureboot thing: When I enabled the Secure boot, the screen displayed this:

IMG_0823.jpeg
When I disabled SecureBoot, disable CSM, the screen still got garbled. I have to go back to CSM enabled to come back to normal. I did followed your Secureboot guide carefully.

p/s: the audio fix worked magically, my collection of headphones now work with my hackintosh :D. Cheers!
 
Last edited:
Joined
Jan 24, 2020
Messages
9
Motherboard
Thinkpad T440s
CPU
Intel core i7 4600U
Graphics
HD 4400
ALCPlugFix not working on Mojave
 

Sniki

Moderator
Joined
Jan 5, 2016
Messages
2,316
Motherboard
HP Elite 8300 SFF
CPU
i7-3770
Graphics
HD 3000 | GTX 1650 LP
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
@KhoGao the SecureBoot guide is not 100% complete yet, i will update it tomorrow if no other priorities show up
unexpectedly.

@phantom0501 I will also update the ALCPlugFix as i am aware of the issues that it is causing
 
Joined
Jan 24, 2020
Messages
9
Motherboard
Thinkpad T440s
CPU
Intel core i7 4600U
Graphics
HD 4400
@Sniki: How to fix wifi error on Big Sur. I am using DW1560, bluetooth still works
 

Sniki

Moderator
Joined
Jan 5, 2016
Messages
2,316
Motherboard
HP Elite 8300 SFF
CPU
i7-3770
Graphics
HD 3000 | GTX 1650 LP
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Top