Contribute
Register

[Guide] Lenovo ThinkPad T440S [OpenCore 0.6.7] [WIP]

Sniki

Moderator
Joined
Jan 5, 2016
Messages
2,316
Motherboard
HP Elite 8300 SFF
CPU
i7-3770
Graphics
HD 3000 | GTX 1650 LP
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
1616418008144.jpeg

Lenovo ThinkPad T440S using OpenCore (0.6.7)

The Readme, Instructions and the EFI is provided here: https://github.com/Sniki/Lenovo-Thinkpad-T440S


Problem Reporting and Troubleshooting

Please provide proper Problem Reporting (archive) which includes the EFI and a copy of IOREG.
IOREG should be saved with the correct working version of IOregistryExplorer that can be found here:
 
Last edited:

Sniki

Moderator
Joined
Jan 5, 2016
Messages
2,316
Motherboard
HP Elite 8300 SFF
CPU
i7-3770
Graphics
HD 3000 | GTX 1650 LP
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Reserved for future post #1
 

Sniki

Moderator
Joined
Jan 5, 2016
Messages
2,316
Motherboard
HP Elite 8300 SFF
CPU
i7-3770
Graphics
HD 3000 | GTX 1650 LP
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Reserved for future post #2
 

Sniki

Moderator
Joined
Jan 5, 2016
Messages
2,316
Motherboard
HP Elite 8300 SFF
CPU
i7-3770
Graphics
HD 3000 | GTX 1650 LP
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Reserved for future post #3
 
Joined
Dec 4, 2015
Messages
177
Motherboard
z390 phantom itx
CPU
i7-9700k
Graphics
radeon 5700 XT
Hello Sniki. Sinetek.kext doesn't work in your EFI. I try the kext from cholonam's GitHub and it works. When I put it to sleep for a long time, it didn't work. I think it's still not stable at this time. One issue is with alcfixplug. YogaSMCPane will crash in system preference when back and reverse then
 

Sniki

Moderator
Joined
Jan 5, 2016
Messages
2,316
Motherboard
HP Elite 8300 SFF
CPU
i7-3770
Graphics
HD 3000 | GTX 1650 LP
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hello Sniki. Sinetek.kext doesn't work in your EFI. I try the kext from cholonam's GitHub and it works. When I put it to sleep for a long time, it didn't work. I think it's still not stable at this time. One issue is with alcfixplug. YogaSMCPane will crash in system preference when back and reverse then
Will double check although it's that same one, unless it got corrupted somehow during upload.
One thing you can try is raise the delay in boot args:
config.plist > NVRAM > 7C436110-AB2A-4BBB-A880-FE41995C9F82 > boot-args > rtsx_sleep_wake_delay_ms=100 to 500 or 1000 and see if it improves that for you, for me it was working fine.

As for YogaSMCPane, didn't notice that one either, maybe a problem on latest release, will check this one as well.

ALCPlugFix is something that i am looking on what to do with it or maybe try alc-verb from AppleALC and see if it works better. (until i completely solve the problem natively).
 
Joined
Dec 21, 2018
Messages
36
Motherboard
Lenovo t440S
CPU
4600u
Graphics
HD
I'm running latest beta Bigsur and beside the CSM/SecureBoot screen grabling thing, everything else is working fine.
My config: I7, 7260 Intel, 2 Ssds for windows and Mac, native 1080 screen, 12GB RAM, 450s Touchpad.
 

Sniki

Moderator
Joined
Jan 5, 2016
Messages
2,316
Motherboard
HP Elite 8300 SFF
CPU
i7-3770
Graphics
HD 3000 | GTX 1650 LP
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I'm running latest beta Bigsur and beside the CSM/SecureBoot screen grabling thing, everything else is working fine.
My config: I7, 7260 Intel, 2 Ssds for windows and Mac, native 1080 screen, 12GB RAM, 450s Touchpad.
@KhoGao Please upload your EDID here (as written on the rules), simply drag and drop into the post or click into the Attach files button.
That way i can patch it for you and provide the patched one to fix garbled screen for your display so you can use SecureBoot.
 
Last edited:
Joined
Dec 21, 2018
Messages
36
Motherboard
Lenovo t440S
CPU
4600u
Graphics
HD
Here you are my friend.
 

Attachments

  • EDID-6af-133d-orig.bin.zip
    685 bytes · Views: 33

Sniki

Moderator
Joined
Jan 5, 2016
Messages
2,316
Motherboard
HP Elite 8300 SFF
CPU
i7-3770
Graphics
HD 3000 | GTX 1650 LP
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Guys guide has received a small update:
- Updated ALCPlugFix with correct ALC3232.plist configuration file
- Updated Config.plist: added alc-verbs DeviceProperty to support CustomVerbs from 3rd party apps (ALCPlugFix)
- Updated AppleALC.kext: added missing verbs from ConfigData and WakeConfigData

Now audio should work fine (without dock support yet).
I will update codecs on AppleALC by sending a pull request so we can have our one with Full Dock Support.
 
Top