Contribute
Register

[Guide] Lenovo ThinkPad T440P

Joined
Jan 21, 2013
Messages
4
Motherboard
T440p
CPU
i5
Graphics
HD 4600
Mac
MacBook Pro
Mobile Phone
iOS
Try to re-apply alc_fix. That's what it is for.
i have try delete all injected binary and re-apply alc_fix the result is same not working and still have buzzing sound
 
Joined
Jan 4, 2019
Messages
2
Motherboard
Thinkpad T440p
CPU
i7 4712MQ
Graphics
HD4600
For those interested, there is a repository with an up-to-date configuration using latest Clover, Whatevergreen and lilu kext available here:
https://github.com/jloisel/t440p

Most of the explanations in the first topic are sadly a bit out of date. The configuration provided in this repository works very well on MacOS Mojave 10.14.2. Only Audio Jack is not working (but audio through speakers is fine).
 
Joined
Jan 4, 2019
Messages
2
Motherboard
Thinkpad T440p
CPU
i7 4712MQ
Graphics
HD4600
Do you use any configuration in the config.plist to make it work properly with jack? Which os version are you running? Audio Jack doesn't work in my case, and I use AppleALC kext.
 
Joined
Oct 20, 2011
Messages
7
Motherboard
Lenovo T440p
CPU
i5-4300M
Graphics
HD 4600 / 1920x1080
Do you use any configuration in the config.plist to make it work properly with jack? Which os version are you running? Audio Jack doesn't work in my case, and I use AppleALC kext.
I don't remember that I made any special settings. You can check for yourself - config.plist in the attachment.

EDIT:
After some unfortunate events with UltraDock I have reinstalled whole thing with Clover 4813 and Mojave - works good. I had similar issue with the sound - I have used AppleALC kext mentioned earlier in my previous post and applied alc_fix.
 

Attachments

Last edited:
Joined
Oct 24, 2016
Messages
5
Motherboard
Lenovo Thinkpad T440p
CPU
i7-4600MQ
Graphics
HD 4600, GT 730M 1920x1080
In regards to updating to Mojave and creating a new guide. I have not been able to successfully get audio to work when I updated to Mojave. The touchpad is working, but there is an issue with it. Its very laggy. It feels off and takes multiple strokes to get across the screen from one end to the other.
 
Last edited:
Joined
Jan 13, 2018
Messages
6
Motherboard
Asus F510UAR
CPU
i5 8250U
Graphics
UHD 620
Mobile Phone
Android, iOS
Hello everyone. I'v been using hackintosh on t440p last 1 year and discovered strange thing: wi-fi\bluetooth card replaced with bcm94352z and i have "unlocked" bios; Since i use this notebook with High Sierra (then i made a clean install of the Mojave version of OS) there was no problem with Bluetooth (i have Logitech MX1000 mouse (2 same mouses) + Apple wireless keyboard A1314). Sometimes mouse pointer stucks (i checked 3 different wireless BT mouses), freezes or working with extreme lags. Secondary system on this device is Win 10 Pro x64 and all checked mouses works pretty great, w/o any lags. So i removed all kext files for bluetooth on MacOS and installed external USB Bluetooth drive. This solved my problems with mouse but i wanna use internal bt w/o external solution. Any ideas how to fix this lags with wireless mouse?
 
Joined
Jan 20, 2019
Messages
19
Motherboard
Lenovo T440p iGPU
CPU
i5-4300M
Graphics
HD 4600 - 1080p
Mobile Phone
Android
Hello everyone, I have some questions before I will order a wireless card and move from Arch Linux to Mac OS Mojave.

First off; which wireless card is recommended for the T440p with whitelist removed? I would like to get the DW1830 for the 3-antenna capabilities and BT 4.1. I do not use a WWAN card so I have two antennas to spare. I might also go with the DW1560 depending on the availability of the DW1830.

My other question is; I have the opportunity to use my fathers Macbook Pro to create a clean High Sierra installation - can I use that to first install High Sierra and then upgrade my computer to Mojave via the built-in installer (app store)?
I did read somewhere on here that it is possible, but it's better to be sure.

And; do the DP-output work as expected? I use my computer frequently to watch movies with bitstream audio via my receiver. I also use a USB DAC/AMP from time to time, is bitperfect audio supported with Hackintosh?

I currently use the 2.5" SSD as my boot disk, but in the future I might adopt a M.2 SSD in the WWAN slot, will it be possible to move(clone) the Mac OS installation to that disk from my 2.5"? I know that is possible with Linux with the dd command, but I am not certain with Mac OS.

And oh, have anyone tried to install a i7-4xxxHQ processor with Iris Pro Graphics and used with Mac OS? It is possible to purchase adapted HQ CPUs from TaoBao. Would be interesting to know because of the native Iris Pro support on Mac OS.

I most certainly will have more questions pre- and post-installation but I will try to use the search function, but I am having some internet issues so I mostly end up with a gray screen now.


Cheers,
Emil
 
Last edited:
Top