Contribute
Register
Status
Not open for further replies.
Joined
Jan 13, 2018
Messages
6
Motherboard
Asus F510UAR
CPU
i5 8250U
Graphics
UHD 620
Mobile Phone
  1. Android
  2. iOS
check if everything is working correctly.
man thank you for great work and all your time spent to this guide. I was stupid and not read it carefully. Now after fresh install and following your steps all working perfect!
 

Sniki

Moderator
Joined
Jan 5, 2016
Messages
2,316
Motherboard
HP Elite 8300 SFF
CPU
i7-3770
Graphics
HD 3000 | GTX 1650 LP
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
man thank you for great work and all your time spent to this guide. I was stupid and not read it carefully. Now after fresh install and following your steps all working perfect!
You are welcome & Congratulations,
Enjoy your T440P Hackintosh.
 
Joined
Oct 19, 2010
Messages
27
Motherboard
GA-P55-US3L
CPU
i5 750
Graphics
Geforce GT240
Mac
  1. Mac Pro
Classic Mac
  1. Apple
Mobile Phone
  1. iOS
Hi @Sniki, thanks for your detailed guide.
I followed to all steps carefully but encountered a couple of issues.
Sorry for the bad English in advance, because its not my native language.
Let me explain step-by-step. (I newly in mackintosh theme, and want to know all that needed to accomplish patching this laptop)
Mine laptop has:
Intel core i5 4210m (2.6 GHz up to 3.2GHz)
Intel HD Graphics 4600
Screen 1367*768
NO discrete graphics
Since built in Wi-fi is unsupported, I use TP-Link TL-WN725N which working perfect with High Sierra

What works after your guide:
boot is ok, but after attempt of update
-graphics
-ethernet
-keyboard (I will replace it with a keyboard that has backlight)
-touchpad (standart, not replaced)
-all USB ports
-sleep/wake semi-working (sometimes does not going to sleep. I hear fan and HDD are working)
-led blink semi-working (even after woke up it blinks)

View attachment 307503

What not work and I want to fix this thing up
-accomplish work with sleep feature
-buttery does does not showing % (even after dsdt patching and attempt to use dsdt file from attachment in this thread)
-RGB/D-Sub cable non working (however I will not use, and fix it when mini display port will be checked)
-microphone
-camera
-sound
-3.5mm jack

everything was done according to guide, however I wasn't succeeded in patching ACPI and dsdt.
So according to guide i'v created an installation flash drive using Unibeast and image from the AppStore.
Its was a blank install without patched files or injected kexts.
Right after the first boot all 4 usb works and ethernet works too.
I'v installed kexts from this thread and from Rehabman's repository, and applied Rehabman's fork of clover.
So after using sdst files from this thread i wasn't succeeded to fix battery status.
Sound as well...

Hi friend!!! Please can you tell me how make work the tl wn725n?
Thanks!!!
 
Joined
Jan 12, 2016
Messages
13
Motherboard
ASUS ROG STRIX Z370-E
CPU
i7-8700K
Graphics
RX Vega 64
Mobile Phone
  1. iOS
Hey, first thanks for this incredible guide. I have been through every step including bios mod with CH341A and have an awesome hackintosh laptop. Actually, still waiting on my 1920x1080 IPS panel, but everything else anyway, and I learned a lot and it all works amazingly well. I’m a noob, and never would have tried a laptop without your guide, so thank you very much.

I just wanted to note that after I updated to 10.13.3 today, I thought it broke my audio. I tried reinstalling with the script you’ve attached and got an error message. So, I just rebuilt kext cache in terminal (which seems to be different than doing it with kext beast for some reason), and it all works again. No other problems with 10.13.3 update either.
 
Joined
Jan 12, 2016
Messages
13
Motherboard
ASUS ROG STRIX Z370-E
CPU
i7-8700K
Graphics
RX Vega 64
Mobile Phone
  1. iOS
Oh, and for people asking, “Which one is the bios chip on the Lenovo T440P?” You want the Winmod W25Q32BV.
 
Joined
Jan 3, 2017
Messages
1
Please can you tell me how make work the tl wn725n?
Just used original driver from official web site. Current version is for Sierra, but in my case it works perfectly with High Sierra.
Here is link
Right after installation you will see wi-fi badge in your status bar.
 
Joined
Oct 19, 2010
Messages
27
Motherboard
GA-P55-US3L
CPU
i5 750
Graphics
Geforce GT240
Mac
  1. Mac Pro
Classic Mac
  1. Apple
Mobile Phone
  1. iOS
Just used original driver from official web site. Current version is for Sierra, but in my case it works perfectly with High Sierra.
Here is link
Right after installation you will see wi-fi badge in your status bar.
Thanks man, yesterday buy this dongle and first install the driver, and after put the dongle the usb. All works perfect, maybe a bit slow than a common wifi.
 
Joined
Oct 8, 2012
Messages
12
Motherboard
T440p (Clover UEFI)
CPU
i7-4700MQ/QM87
Graphics
HD4600 + GT 730M(Optimus)
Thank you so much Sniki for this guide as your update V. 2.4 solved all the problems I had previously

No need anymore for discretespoof, no more glitches, for the wifi I use TL-WN725N as there is a driver for mac

Thank you also to RehabMan and the-braveknight
 
Joined
Feb 16, 2013
Messages
29
Motherboard
Lenovo U310/T440s
CPU
i3-3217U/i5-4300U
Graphics
HD 4000/4400
Mobile Phone
  1. iOS
@Jos1984 here are the files for you to test:
add these SSDTs into EFI/Clover/ACPI/Patched (remove everything else before copying them).
remove the old config.plist and use this one that i attached.
About kexts and procedures read the post #1 (my guide) carefully and you have everything explained.

The only difference is you use this config.plist that i attached and the SSDTs that i attached, everything else is same as on guide.

Then i need you to capture Active USB Ports on IOregistryExplorer,

After you installed the files and rebooted:
Open IOregistryexplorer and:

- Grab a USB2.0 Device (Mouse/USB2.0 Flash Drive or whatever u want) and plug it on each usb port:
(plug it on first port, hold it 3 sec, then unplug and plug it on other usb port, until you done this on all ports on the laptop.)

after you are done with that grab a USB3.0 device (USB3.0 Flash Drive/External Drive or whatever 3.0 device).
do the same procedure like with usb2 device but with the 3.0 device this time.

After you are done with the procedures, Save a copy of ioreg and attach it so i can build USB Ports Injector.

Test what is working and what isn't working.

Report back with results.

Hi there,

I have follow your instructions, and here you have the IORegistry file.

And sorry for the delay...
 

Attachments

  • T440s-Jos1984.zip
    629.2 KB · Views: 62

Sniki

Moderator
Joined
Jan 5, 2016
Messages
2,316
Motherboard
HP Elite 8300 SFF
CPU
i7-3770
Graphics
HD 3000 | GTX 1650 LP
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi there,

I have follow your instructions, and here you have the IORegistry file.

And sorry for the delay...
Thank you, looking at the files it looks like everything is fine.
I created the USB Injector and everything seems to be fine now, done with the files.
I will write the guide this weekend.
 
Status
Not open for further replies.
Top