Contribute
Register

[Guide] Lenovo ThinkPad T440P [OpenCore 0.5.9]

Joined
Oct 16, 2020
Messages
75
Motherboard
Thinkpad T440P
CPU
i7-4710MQ
Graphics
HD 4600
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
You need to disable the turnoff of the pc when the lid is closed, there is a setting for that in the power area.
Otherwise use amphetamine command to keep it always up
there is no setting that you speak of, if i am mistaken please show.

and amphetamine doesnt work on catalina, atleast on a 2017MBP it doesnt, none of them do, ive tried over 20 solutions but catalina just overides it alld

because i dont currently have the issue i cant check if amphetamine works, but i suspect none of these programs work as apple has completely blocked making changes to this behaviour in catalina.
 
Joined
Jun 23, 2020
Messages
2
Motherboard
Thinkpad T440P 4GB ram
CPU
i5 4300M
Graphics
Intel HD 4600
Mobile Phone
  1. Android
  2. iOS
guys, i have a problem when i boot my mac. it stuck on EXITBS:START and then restart.
last night, i tried to upgrade the opencore, and it says "FAILED TO LOAD CONFIGURATION" because i put it to microsoft folder to bypass the windows boot manager, after couple of minutes, it boots to opencore but not on mac and gives me EXITBS:START error. i've been read all the solutions in dortania documents, and it doesn't work. so here's my efi folder.

as always, thank you
 

Attachments

  • EFI.rar
    14 MB · Views: 82
Joined
Aug 13, 2020
Messages
7
Motherboard
Lenovo (Intel QM87)
CPU
i7 4710mq
Graphics
HD4600 / GT730M
Back again with a newly updated EFI.

Changes:
- updated to OC 0.6.3 (Support for 11.0 B10/11.0.1+)
- added AirportItlwm 1.2.0-debug (separated Catalina and BS versions through Min-/MaxKernel)
- removed Ultrabay hotplug patch as Big Sur would instantly kernel panic on boot
- Updated Kexts incl. AppleALC (ALCPlugFix actually works now for some reason)
- disabled Broadcom Kexts (re-enable them and delete/disable itlwm if using Broadcom WiFi)
- Updated OpenCanopy with Big Sur style Icons

What doesn't work:
- Bluetooth (injecting IntelBluetoothFirmware/Injector didn't help, not sure if it's a Big Sur issue)

Haven't tested:
- DP video output
- docking station (USB, Audio, Video)

As always, don't forget to transfer your serial

WARNING: Installer may take up to 15 minutes (no joke) to boot, should be back to normal once fully installed

Here's Big Sur running on my machine!

View attachment 494017

I found a solution for the Bluetooth problem for people with intel cards:
It is important to have the USBPorts.kext before the IntelBluetoothFirmware because the latter one need the correct USB port to function.

So now bluetooth is working in OC6.3 and 6.4 for me.
 
Joined
Jul 28, 2011
Messages
351
Motherboard
GA-H67MA-UD2H-B3
CPU
i5-2400
Graphics
HD 5750
Mac
  1. MacBook
Mobile Phone
  1. Android
Do you know how to make itlwm.kext work with OpenCore ?
I currently have a working T440p with 10.5.7 and Clover.
I added itlwm.kext in EFI/OC/Kexts in your OpenCore EFI USB, it boots fine but the itlwm.kext is not loading.
 
Last edited:
Joined
Aug 13, 2020
Messages
7
Motherboard
Lenovo (Intel QM87)
CPU
i7 4710mq
Graphics
HD4600 / GT730M
Do you know how to make itlwm.kext work with OpenCore ?
I currently have a working T440p with 10.5.7 and Clover.
I added itlwm.kext in EFI/OC/Kexts in your OpenCore EFI USB, it boots fine but the itlwm.kext is not loading.
You also have to edit the config.plist and add an entry for the kext under Kernel/Add
You can best do this with ProperTree or open the plist with a text editor and add next to the other kext items in the kernel section following code:
<dict> <key>BundlePath</key> <string>itlwm.kext</string> <key>Comment</key> <string>Intel Wifi Driver</string> <key>Enabled</key> <true/> <key>ExecutablePath</key> <string>Contents/MacOS/itlwm</string> <key>MaxKernel</key> <string></string> <key>MinKernel</key> <string></string> <key>PlistPath</key> <string>Contents/Info.plist</string> </dict>
 
Joined
Jul 28, 2011
Messages
351
Motherboard
GA-H67MA-UD2H-B3
CPU
i5-2400
Graphics
HD 5750
Mac
  1. MacBook
Mobile Phone
  1. Android
You also have to edit the config.plist and add an entry for the kext under Kernel/Add
You can best do this with ProperTree or open the plist with a text editor and add next to the other kext items in the kernel section following code:
<dict> <key>BundlePath</key> <string>itlwm.kext</string> <key>Comment</key> <string>Intel Wifi Driver</string> <key>Enabled</key> <true/> <key>ExecutablePath</key> <string>Contents/MacOS/itlwm</string> <key>MaxKernel</key> <string></string> <key>MinKernel</key> <string></string> <key>PlistPath</key> <string>Contents/Info.plist</string> </dict>
Thanks a lot, it worked.
It was a good try but I have to find how to dual boot before switching to OpenCore from Clover.
 
Joined
Oct 16, 2020
Messages
75
Motherboard
Thinkpad T440P
CPU
i7-4710MQ
Graphics
HD 4600
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
ok, so having tried @sha1062 's 0.6.3 EFI there was one issue i noticed immediately which is a big problem with opencore for me, and clover does not suffer from this

when the laptop is closed (aka clamshell mode) and connected to an external monitor with clover, it will work unplugged or plugged in. this is actually NOT how normal macbooks work, but its exactly what i want.

in OpenCore if the laptop is in clamshell mode and i unplug power, it immediately sleeps, the same as on a normal macbook pro.

do other uses experience this on OC aswell? and if so is there any easy way for me to change this and make it behave like on clover, perhaps it was because after going to opencore i didnt clear my nvram, i may need to try it again.
ok so i solved the issue

on Catalina it seems that VirtualSMC does not work aswell as FakeSMC for me

VirtualSMC causes computer to sleep when power is unplugged in clamshell mode, fake SMC does not.

i switched an OC build for T440P to FakeSMC and also VoodooHDA because it works better for audio and the headphone port doesnt buzz

now im finaly happy to use OpenCore because previously this issue with clamshell mode was holding me back.

moving forward someone has said that with there T440P on Big Sur using VirtualSMC they do not exhibit this issue, CAN ANYONE CONFIRM PLEASE??? if so i guess i would possibly want to switch back from FakeSMC to virtual SMC before upgrading to Big Sur as maybe FakeSMC is not working or reliable?
 
Last edited by a moderator:
Joined
Oct 16, 2020
Messages
75
Motherboard
Thinkpad T440P
CPU
i7-4710MQ
Graphics
HD 4600
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS

Hey guys, here is my OpenCore build for T440P, its quite different than some other builds with the main difference being FakeSMC instead of VirtualSMC, i tested both thoroughly and FakeSMC works much better for me, when plugging in external displays connection is much more snappy.

this works for Catalina and Big Sur, please use reset nvram and reboot upon first use, id suggest testing on a usb before using on your main build as i cant confirm this will work with all T440P hardware or motherboards.

Issues.

1. like many i cant get SDXC reader (RTS5227) to work, ive only played with 10.15.7+

2. personally i use my laptop in clamshell mode closed connected to external monitor with bluetooth keyboard and mouse, my bluetooth mouse is a G603 and also has the option of 2.4GHz over USB, neither bluetooth or USB will wake my T440P, even if im not in clamshell mode, and i sleep it manually, the T440P keyboard and mouse will not wake it, but closing and opening the display will. I included a video below to show the issue, its very minor but it bothers me alot...

if anyone has any solutions to this or has the SD reader working on 10.15.7 or higher please let me know

 
Last edited:
Joined
Oct 16, 2020
Messages
75
Motherboard
Thinkpad T440P
CPU
i7-4710MQ
Graphics
HD 4600
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
been working on my T440P OpenCore build relentlessly over the last few days, everything is working flawlessly except wake with bluetooth, opening the screen (or closing and opening if already open) still works to wake, and i can wake using wireless usb mouse, but i prefer to use this mouth in bluetooth mode to free up a port and wake from the same mouse on bluetooth or on my bluetooth keyboard isnt working, wifi is BCM94360CS2 authentic apple card, airdrop and handoff working fully, dont have apple watch to test apple watch unock but confident it would work.

does ANYONE have wake working from a bluetooth mouse or keyboard, can you PLEASE share you EFI
 
Joined
Jan 23, 2021
Messages
5
Motherboard
Aorus z270x Gaming 7
CPU
Intel i7-9700KF
Graphics
Nvidia Geforce GTX 1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
been working on my T440P OpenCore build relentlessly over the last few days, everything is working flawlessly except wake with bluetooth, opening the screen (or closing and opening if already open) still works to wake, and i can wake using wireless usb mouse, but i prefer to use this mouth in bluetooth mode to free up a port and wake from the same mouse on bluetooth or on my bluetooth keyboard isnt working, wifi is BCM94360CS2 authentic apple card, airdrop and handoff working fully, dont have apple watch to test apple watch unock but confident it would work.

does ANYONE have wake working from a bluetooth mouse or keyboard, can you PLEASE share you EFI
T440P can't wake from a bluetooth mouse or keyboard except fn and power
 
Top