Contribute
Register

[Guide] Lenovo ThinkPad T440P [OpenCore 0.5.9]

Joined
Oct 16, 2020
Messages
75
Motherboard
Thinkpad T440P
CPU
i7-4710MQ
Graphics
HD 4600
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hey everyone, so i tried using @sha1062 's 6.3 EFI with 10.15.7 and found that i prefered clover5022

since switching back to clover it seems that my clover boot has now changed slightly and it shows a bunch of command line text for a few seconds before showing the mac logo, wheras previously it only showed the mac logo and didnt show text like this, what could be causing this?
 
Joined
Nov 5, 2020
Messages
4
Motherboard
Lenovo Thinkpad T440p
CPU
i5-4210M
Graphics
Intel HD Graphics 4600
Hey everyone, so i tried using @sha1062 's 6.3 EFI with 10.15.7 and found that i prefered clover5022

since switching back to clover it seems that my clover boot has now changed slightly and it shows a bunch of command line text for a few seconds before showing the mac logo, wheras previously it only showed the mac logo and didnt show text like this, what could be causing this?
That is because you are enabling Verbose Mode, you can disable it by removing the boot flag -v
 
Joined
Oct 16, 2020
Messages
75
Motherboard
Thinkpad T440P
CPU
i7-4710MQ
Graphics
HD 4600
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
That is because you are enabling Verbose Mode, you can disable it by removing the boot flag -v
thats what i thought but i dont have it as a boot arguement to start with, could it be any of these?

Screenshot 2020-12-08 at 8.49.26 PM.png
 
Joined
Oct 16, 2020
Messages
75
Motherboard
Thinkpad T440P
CPU
i7-4710MQ
Graphics
HD 4600
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
don't forget to clean nvram if you are changing boot loaders
oh, i have not done this once, that sounds like it may be it! is there a safe way to do it, or should i be good just following instructions if i google how to clear nvram? thanks!
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
20,705
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
oh, i have not done this once, that sounds like it may be it! is there a safe way to do it, or should i be good just following instructions if i google how to clear nvram? thanks!
at the clover boot screen press F11
 
Joined
Oct 16, 2020
Messages
75
Motherboard
Thinkpad T440P
CPU
i7-4710MQ
Graphics
HD 4600
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
at the clover boot screen press F11
yes this worked perfect thanks, funny thing is, connected to external monitor

no my reboot process is basically black screen untill the login page, i swear on old clover it gave me a apple logo with the loading bar, but hey what can ya do, im guessing if i do a reboot with my laptop screen it will show the apple logo and loading bar
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
20,705
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
yes this worked perfect thanks, funny thing is, connected to external monitor

no my reboot process is basically black screen untill the login page, i swear on old clover it gave me a apple logo with the loading bar, but hey what can ya do, im guessing if i do a reboot with my laptop screen it will show the apple logo and loading bar
my laptop does the same when connected to an external monitor, in fact it doesn't work unless i reboot laptop without external screen, but hot plug works fine though... :)
 
Joined
Oct 16, 2020
Messages
75
Motherboard
Thinkpad T440P
CPU
i7-4710MQ
Graphics
HD 4600
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
ok, so having tried @sha1062 's 0.6.3 EFI there was one issue i noticed immediately which is a big problem with opencore for me, and clover does not suffer from this

when the laptop is closed (aka clamshell mode) and connected to an external monitor with clover, it will work unplugged or plugged in. this is actually NOT how normal macbooks work, but its exactly what i want.

in OpenCore if the laptop is in clamshell mode and i unplug power, it immediately sleeps, the same as on a normal macbook pro.

do other uses experience this on OC aswell? and if so is there any easy way for me to change this and make it behave like on clover, perhaps it was because after going to opencore i didnt clear my nvram, i may need to try it again.
 
Joined
Nov 30, 2020
Messages
2
Motherboard
Lenovo t440p
CPU
i5-4300
Graphics
HD 4000
ok, so having tried @sha1062 's 0.6.3 EFI there was one issue i noticed immediately which is a big problem with opencore for me, and clover does not suffer from this

when the laptop is closed (aka clamshell mode) and connected to an external monitor with clover, it will work unplugged or plugged in. this is actually NOT how normal macbooks work, but its exactly what i want.

in OpenCore if the laptop is in clamshell mode and i unplug power, it immediately sleeps, the same as on a normal macbook pro.

do other uses experience this on OC aswell? and if so is there any easy way for me to change this and make it behave like on clover, perhaps it was because after going to opencore i didnt clear my nvram, i may need to try it again.
You need to disable the turnoff of the pc when the lid is closed, there is a setting for that in the power area.
Otherwise use amphetamine command to keep it always up
 
Top