Contribute
Register

[Guide] Lenovo ThinkPad T440P [OpenCore 0.5.9]

Joined
Sep 19, 2019
Messages
5
Motherboard
Lenovo T440p
CPU
i7-4800MQ
Graphics
HD 4600
Back again with a newly updated EFI.

Changes:
- updated to OC 0.6.3 (Support for 11.0 B10/11.0.1+)
- added AirportItlwm 1.2.0-debug (separated Catalina and BS versions through Min-/MaxKernel)
- removed Ultrabay hotplug patch as Big Sur would instantly kernel panic on boot
- Updated Kexts incl. AppleALC (ALCPlugFix actually works now for some reason)
- disabled Broadcom Kexts (re-enable them and delete/disable itlwm if using Broadcom WiFi)
- Updated OpenCanopy with Big Sur style Icons

What doesn't work:
- Bluetooth (injecting IntelBluetoothFirmware/Injector didn't help, not sure if it's a Big Sur issue)

Haven't tested:
- DP video output
- docking station (USB, Audio, Video)

As always, don't forget to transfer your serial

WARNING: Installer may take up to 15 minutes (no joke) to boot, should be back to normal once fully installed

Here's Big Sur running on my machine!

View attachment 494017
Hello Sha,

I have played a bit with your efi and managed to upgrade my catalina install to big sur. Everything seems to be working (everything i need anyway) but i have no working camera and no blueetoth. I also tried with a fresh install on the same machine (different ssd), still no camera. Do you have the same issue?

Thanks.
 
Joined
Dec 18, 2013
Messages
484
Motherboard
Lenovo Yoga C740
CPU
i7-10510U
Graphics
Intel UHD Graphics
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
thanks, but this tutorial sais its for fixing imessage and other services, and i dont care about imessage as i dont use it

thanks, i tried your first suggestion but no luck

i opened my plist and went to smbios but there is no option to pick the model and nothing fills out automagically

View attachment 496720
Of course there is. Right bottom corner, up, up, up: flipped "<>"
 
Joined
Jul 3, 2020
Messages
11
Motherboard
T440P
CPU
4810MQ
Graphics
HD 4600
I used your guide (thank you!!!) and got BigSur up and running. I did save myself some time and trouble by swapping out my wifi card to a new "native" one as opposed to the DW1560 I was previously using. Much easier now and works perfectly. Here is a narrative of what I did with links to my EFI.

https://2000c43.com/
I browsed your blog. It is really helpful to me and it is innovating. You mentioned the m.2 WiFi card selection. I personally think all other instructions should update this part according to yours, even though the BCM94360NG is way beyond the normal price range now. I am using DW1820A card which is cheap and annoying when doing the hackintosh.

I am not a pro so I think I will stay with Catalina.
 
Joined
Oct 16, 2020
Messages
76
Motherboard
Thinkpad T440P
CPU
i7-4710MQ
Graphics
HD 4600
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Back again with a newly updated EFI.

Changes:
- updated to OC 0.6.3 (Support for 11.0 B10/11.0.1+)
- added AirportItlwm 1.2.0-debug (separated Catalina and BS versions through Min-/MaxKernel)
- removed Ultrabay hotplug patch as Big Sur would instantly kernel panic on boot
- Updated Kexts incl. AppleALC (ALCPlugFix actually works now for some reason)
- disabled Broadcom Kexts (re-enable them and delete/disable itlwm if using Broadcom WiFi)
- Updated OpenCanopy with Big Sur style Icons

What doesn't work:
- Bluetooth (injecting IntelBluetoothFirmware/Injector didn't help, not sure if it's a Big Sur issue)

Haven't tested:
- DP video output
- docking station (USB, Audio, Video)

As always, don't forget to transfer your serial

WARNING: Installer may take up to 15 minutes (no joke) to boot, should be back to normal once fully installed

Here's Big Sur running on my machine!

View attachment 494017
Hi,

I was running Clover 5022 on 10.15.7 Supplemental update, im a DJ and i need confirmed Big Sur support on some apps before wasting my time upgrading and having to go back to Catalina.

I decided to switch from Clover to OpenCore in order to better prepare for upgrade to Big Sur when im ready.

just loaded this folder into my EFI and edited the serial number and other info on the plist and booted no issue, wasnt a faster boot than clover for me tho.

I am still having some small issues with my T440P on Clover and Opencore and im curious if other people are having the same issues on Catalina, or Big Sur using OpenCore, Or Clover

1. SD card reader, does anyone have this working?

2. BCM94360NG Wifi - mine will only show 1 spacial stream connnected and a max rate or 434mbps, this is incorrect.
other users reporting 2 spacial stream in Mojave only, displayed as 1NSS or 2NSS in wifi details seems odd this card is constantly recomended if it were having this issue, to check: option click on your wifi and it will show the link rate and 1NSS or 2NSS, in order to get my wifi to work good and keep this card in for airdrop i use wifi on but do not connect to any network and use a netgear A6150 adapter, if i used the BCM94360NG id have terrible speeds, mostly upload, and dropped packets, ill attach pics of speed tests with each wifi adapter to show you.

3. BCM94360NG Bluetooth - using my bluetooth my keychron K2 keeps having lag or massive delay from time to time, its resembling the crap performance of the wifi at best. ive started a return process on ebay for the wifi but it seems that everyone elses behaves the same?

for reference my wired internet speed is 74/17.5 so the netgear adapter is getting every last bit over wifi but the BCM is strugling to get more than 5mbps upload and showing massive packet loss, please test yours!

Screenshot 2020-11-23 at 10.44.12 PM.png
Screenshot 2020-11-23 at 10.44.23 PM.png
 
Last edited:
Joined
Nov 15, 2019
Messages
27
Motherboard
Thinkpad T440p
CPU
Intel Core i7-4810MQ
Graphics
Intel HD Graphic 4600
Mobile Phone
  1. Android
3. BCM94360NG Bluetooth - using my bluetooth my keychron K2 keeps having lag or massive delay from time to time, its resembling the crap performance of the wifi at best. ive started a return process on ebay for the wifi but it seems that everyone elses behaves the same?
You need to connect to 5Ghz wifi to enjoy bluetooth without leg, no matter what wifi card you are using if you ate not using 5g wifi you will always have lag. And my keyboard also keychron k2. Switching to 5g is the solution.
 
Joined
Nov 30, 2020
Messages
2
Motherboard
Lenovo t440p
CPU
i5-4300
Graphics
HD 4000
Hi, i lurked a lot this post in this months.
I installed Big Sur and almost everything is working, the one thing im missing is the kext's to read Hdd in ultrabay.
I found out that AHCPIHotplug and the inject one are a bit weird to use since Catalina, but how about big sur? Are they working fine? How i can install them?
 
Last edited:
Joined
Nov 5, 2020
Messages
4
Motherboard
Lenovo Thinkpad T440p
CPU
i5-4210M
Graphics
Intel HD Graphics 4600
Btw, anyone tried audio over DP? I plugged my TV to the DP-to-HDMI adapter, and it didn't show the audio switch to the TV.

Update: I got the switch, but even I switched to the TV line, there isn't audio at all.
@Sniki
 
Last edited:
Joined
Oct 16, 2020
Messages
76
Motherboard
Thinkpad T440P
CPU
i7-4710MQ
Graphics
HD 4600
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
ive never once had audio over mini display port to hdmi adapter but when i looked into it seems some people pointed to a specific one and said it would work but never bothered to try it
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
20,721
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
ive never once had audio over mini display port to hdmi adapter but when i looked into it seems some people pointed to a specific one and said it would work but never bothered to try it
sometimes using FakePCIID.kext and FakePCIID_Intel_HDMI_Audio.kext can help

my laptop can work without it, but when i boot with hdmi cable plugged in, nothing on laptop apart from using mini dp to hdmi cable but then the audio won't work

hotplugging hdmi cable, i don;t get hdmi audio

using the 2 kexts above, i can hot plug hdmi and / or mini dp and i get hdmi / dp audio working
 

Attachments

  • RehabMan-FakePCIID-2018-1027.zip
    75.1 KB · Views: 7
Joined
Oct 16, 2020
Messages
76
Motherboard
Thinkpad T440P
CPU
i7-4710MQ
Graphics
HD 4600
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
sometimes using FakePCIID.kext and FakePCIID_Intel_HDMI_Audio.kext can help

my laptop can work without it, but when i boot with hdmi cable plugged in, nothing on laptop apart from using mini dp to hdmi cable but then the audio won't work

hotplugging hdmi cable, i don;t get hdmi audio

using the 2 kexts above, i can hot plug hdmi and / or mini dp and i get hdmi / dp audio working
thanks, i tried with catalina 10.15.7 supplemental but it didnt work for me
 
Top