Contribute
Register

[Guide] Lenovo ThinkPad T440

Joined
Nov 10, 2018
Messages
8
Motherboard
Lenovo ThinkPad T440
CPU
i5-4300U
Graphics
HD4400

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,927
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Joined
Nov 10, 2018
Messages
8
Motherboard
Lenovo ThinkPad T440
CPU
i5-4300U
Graphics
HD4400

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,927
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
here I attached debug zip, thanks in advance
Why do you have SSDT-T440.aml *and* DSDT.aml in ACPI/patched?
You're using hotpatch or not?
 
Joined
Nov 10, 2018
Messages
8
Motherboard
Lenovo ThinkPad T440
CPU
i5-4300U
Graphics
HD4400
Why do you have SSDT-T440.aml *and* DSDT.aml in ACPI/patched?
You're using hotpatch or not?
Oh yes, that's the reason, deleted DSDT, and all went well...thanks
 
Joined
Jan 31, 2019
Messages
1
Motherboard
T440
CPU
Core I5
Graphics
Intel HD 4400
I just installed this today. Everything seems to be working. Audio works fine, display works fine. Bought an USB dongle for WiFi which works fine. Bluetooth I don't care about.

There is only one thing that does not work properly and that is the touchpad. A USB mouse works fine. The TrackPoint works fine. It is just the touchpad that is really jerky, laggy, or whatever you want to call it.
It is just not usable this way.

Any idea what could cause this??
 
Joined
Nov 10, 2018
Messages
8
Motherboard
Lenovo ThinkPad T440
CPU
i5-4300U
Graphics
HD4400
thanks
 
Last edited:
Joined
Mar 6, 2019
Messages
1
Motherboard
Lenovo T440
CPU
i5-4300U
Graphics
HD4400
Hi
I have Installed Mac OS Mojave on my Thinkpad T440 sound is not working.

when i used your SSDT.aml which is initially attached for High Sierra in your guide sound is working.

why the sound is not working when i am using SSDT.aml which is downloaded from your GitHub repo. Is there a way I can fix it?

please find the attached debug it is with docking station attached I also have issue when notebook on docking station and I shutdown system it restarts.

Thanks in Advance.
 
Last edited:
Top