Contribute
Register

[Guide] Lenovo ThinkPad L440

Joined
Jun 21, 2017
Messages
50
CPU
i5 4300m.
Graphics
Intel® HD Graphics 4600
hi guys. I have problem on installing this high Sierra on my L440.
My L440 does not contain any bios mod or hardware mod. It is the default . I use wireless adapter for wireless. Rest of my config is shown in my profile

Problem.
1. Audio is not working. 0 sound
2. There is gfx glitch when opening some application like chess and others. I have attached images to show it

Below are the error files

Code:
erics-MBP:~ ericlee$ clear

erics-MBP:~ ericlee$
erics-MBP:~ ericlee$ kextstat|grep -y acpiplat
   14    2 0xffffff7f81f86000 0xa5000    0xa5000    com.apple.driver.AppleACPIPlatform (6.1) FC118BB9-2E67-35DD-BB25-BA6DFAF5AE88 <13 12 11 7 6 5 4 3 1>
erics-MBP:~ ericlee$ kextstat|grep -y appleintelcpu
erics-MBP:~ ericlee$ kextstat|grep -y applelpc
  113    0 0xffffff7f82047000 0x3000     0x3000     com.apple.driver.AppleLPC (3.1) 7C24E741-BD4A-3917-83AC-E956A03ADC20 <112 12 5 4 3>
erics-MBP:~ ericlee$ kextstat|grep -y applehda
  116    1 0xffffff7f81dfe000 0x1f000    0x1f000    com.apple.driver.AppleHDAController (281.51) B33D861B-CBFD-34B8-883C-EBC5F129F824 <115 104 84 12 7 6 5 4 3 1>
  135    0 0xffffff7f82a0d000 0xb7000    0xb7000    com.apple.driver.AppleHDA (999.1.1fc1) 2A0459A7-A15B-33AB-ACF9-971801B4DE7E <134 116 115 114 104 84 6 5 4 3 1>
  136    0 0xffffff7f81e1d000 0x2000     0x2000     com.apple.driver.AppleHDAHardwareConfigDriver (281.51) D20913E3-5B4D-369B-9BD7-8C3D11B46FA0 <4 3>
erics-MBP:~ ericlee$
 

Attachments

  • help files.zip
    4.9 MB · Views: 63
  • IMG_20180430_222609.jpg
    IMG_20180430_222609.jpg
    6 MB · Views: 66
  • MVIMG_20180430_222443.jpg
    MVIMG_20180430_222443.jpg
    8.4 MB · Views: 60

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,506
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
hi guys. I have problem on installing this high Sierra on my L440.
My L440 does not contain any bios mod or hardware mod. It is the default . I use wireless adapter for wireless. Rest of my config is shown in my profile

Problem.
1. Audio is not working. 0 sound
2. There is gfx glitch when opening some application like chess and others. I have attached images to show it

Below are the error files

Code:
erics-MBP:~ ericlee$ clear

erics-MBP:~ ericlee$
erics-MBP:~ ericlee$ kextstat|grep -y acpiplat
   14    2 0xffffff7f81f86000 0xa5000    0xa5000    com.apple.driver.AppleACPIPlatform (6.1) FC118BB9-2E67-35DD-BB25-BA6DFAF5AE88 <13 12 11 7 6 5 4 3 1>
erics-MBP:~ ericlee$ kextstat|grep -y appleintelcpu
erics-MBP:~ ericlee$ kextstat|grep -y applelpc
  113    0 0xffffff7f82047000 0x3000     0x3000     com.apple.driver.AppleLPC (3.1) 7C24E741-BD4A-3917-83AC-E956A03ADC20 <112 12 5 4 3>
erics-MBP:~ ericlee$ kextstat|grep -y applehda
  116    1 0xffffff7f81dfe000 0x1f000    0x1f000    com.apple.driver.AppleHDAController (281.51) B33D861B-CBFD-34B8-883C-EBC5F129F824 <115 104 84 12 7 6 5 4 3 1>
  135    0 0xffffff7f82a0d000 0xb7000    0xb7000    com.apple.driver.AppleHDA (999.1.1fc1) 2A0459A7-A15B-33AB-ACF9-971801B4DE7E <134 116 115 114 104 84 6 5 4 3 1>
  136    0 0xffffff7f81e1d000 0x2000     0x2000     com.apple.driver.AppleHDAHardwareConfigDriver (281.51) D20913E3-5B4D-369B-9BD7-8C3D11B46FA0 <4 3>
erics-MBP:~ ericlee$

"Problem Reporting" files are incomplete.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Joined
Jun 21, 2017
Messages
50
CPU
i5 4300m.
Graphics
Intel® HD Graphics 4600
patchmatic, IORegistryExplorer and clover files are already attached. what is missing?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,506
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
patchmatic, IORegistryExplorer and clover files are already attached. what is missing?

Missing:
- misc/preboot.log
- ACPI/origin/*
- kextcache output

Which is why you should have used the gen_debug.sh script as requested.
 
Joined
Jun 21, 2017
Messages
50
CPU
i5 4300m.
Graphics
Intel® HD Graphics 4600
attached my newly updated file
 

Attachments

  • CLOVER.zip
    4.5 MB · Views: 61
  • debug_26481.zip
    640.3 KB · Views: 58
  • IMG_20180430_222609.jpg
    IMG_20180430_222609.jpg
    6 MB · Views: 55
  • MVIMG_20180430_222443.jpg
    MVIMG_20180430_222443.jpg
    8.4 MB · Views: 52

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,506
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
attached my newly updated file

Problems/suggestions:
- enabling TRIM with APFS is usually a mistake; disable TRIM or install on HFS+J
- USB WiFI not recommended
- try without Shiki.kext
- try with AptioMemoryFix.efi instead of OsxAptioFix*.efi
- your Clover/kexts/Other is a mess (you should NOT have files that are not kexts)
- do EC reset
- MacBookAir6,2 instead of MacBookPro11,1 might be something to try
- kexts installed incorrectly (as per FAQ, kexts are installed to /L/E, not /S/L/E on 10.11 and later)
- for audio, make sure you boot without caches, rebuild cache, reboot
 
Joined
Jun 21, 2017
Messages
50
CPU
i5 4300m.
Graphics
Intel® HD Graphics 4600
Problems/suggestions:
- enabling TRIM with APFS is usually a mistake; disable TRIM or install on HFS+J
- USB WiFI not recommended
- try without Shiki.kext
- try with AptioMemoryFix.efi instead of OsxAptioFix*.efi
- your Clover/kexts/Other is a mess (you should NOT have files that are not kexts)
- do EC reset
- MacBookAir6,2 instead of MacBookPro11,1 might be something to try
- kexts installed incorrectly (as per FAQ, kexts are installed to /L/E, not /S/L/E on 10.11 and later)
- for audio, make sure you boot without caches, rebuild cache, reboot
this is weird. I followed ts post "Install kexts into HDD/SSD (use your favorite kext installer,i personally use Kext Wizard) into System/Library/Extensions or /Library/Extensions , the choice is yours."

on the config.plist the trim is disabled

I also did sudo touch /System/Library/Extensions && sudo kextcache -u / and sudo kextcache -I /. Basically I rebooted multiple times and it still does not work.

For usb wifi, I am not going to change the wireless card anytime soon. I am not going to disassemble the laptop and flash the whitelisted bios.
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,506
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
this is weird. I followed ts post "Install kexts into HDD/SSD (use your favorite kext installer,i personally use Kext Wizard) into System/Library/Extensions or /Library/Extensions , the choice is yours."

Read FAQ:
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/

I also did sudo touch /System/Library/Extensions && sudo kextcache -u / and sudo kextcache -I /. Basically I rebooted multiple times and it still does not work.

Must use boot without caches.
It is available in my version of Clover.

For usb wifi, I am not going to change the wireless card anytime soon. I am not going to disassemble the laptop and flash the whitelisted bios.

Your call.
USB WiFi is known to cause many problems.
 
Joined
Jun 21, 2017
Messages
50
CPU
i5 4300m.
Graphics
Intel® HD Graphics 4600
I have updated with new problem reporting files as attached

this time I moved kext back to /Library/Extensions.

same problem. audio not working and gfx is still glitching
did try without Shiki.kext (removed, sudo kextcache -I / and reboot, no diff gfx still glitching, added them back afterwards)
did ec restart
 

Attachments

  • Archive.zip
    1.3 MB · Views: 60
  • IMG_20180430_222609.jpg
    IMG_20180430_222609.jpg
    6 MB · Views: 53
  • MVIMG_20180430_222443.jpg
    MVIMG_20180430_222443.jpg
    8.4 MB · Views: 62
Last edited:
Top