Contribute
Register

[Guide] Lenovo Legion Y520/Y720 using Clover UEFI

Joined
Mar 2, 2020
Messages
5
Motherboard
Lenovo Legion Y720-15IKB
CPU
Intel(R) Core(TM) i7-7700HQ
Graphics
HD 630 + GTX 1060,1920 x 1080
Mac
MacBook Pro
Mobile Phone
Android
Good Day everyone. Well written guides from both @the-braveknight and @RehabMan. I've read most of the posts here and still have issues passing the first boot screen with the apple logo and 100% load bar. Currently performing first boot after installation using usb before patching. Screenshot of error below and EFI zip for USB attached.
 

Attachments

Joined
Oct 4, 2018
Messages
80
Motherboard
Lenovo Legion Y520-15IKBN-80WK-Clover
CPU
i5-7300HQ
Graphics
HD 630 + GTX 1050 Ti 1920x1080
Mobile Phone
iOS
Good Day everyone. Well written guides from both @the-braveknight and @RehabMan. I've read most of the posts here and still have issues passing the first boot screen with the apple logo and 100% load bar. Currently performing first boot after installation using usb before patching. Screenshot of error below and EFI zip for USB attached.
You have some redundant drivers in drivers64UEFI/ , but they shouldn't cause these issues.

Is your Windows install asleep whilst you're trying to boot macOS?

EDIT: Did you configure your BIOS settings according to the guide?
 
Joined
Mar 2, 2020
Messages
5
Motherboard
Lenovo Legion Y720-15IKB
CPU
Intel(R) Core(TM) i7-7700HQ
Graphics
HD 630 + GTX 1060,1920 x 1080
Mac
MacBook Pro
Mobile Phone
Android
You have some redundant drivers in drivers64UEFI/ , but they shouldn't cause these issues.

Is your Windows install asleep whilst you're trying to boot macOS?

EDIT: Did you configure your BIOS settings according to the guide?
Thanks for the quick reply.
My windows is shutdown. I'll try disabling some of the other power options in windows power management just in case. Yes i configured my bios according to the guide.
though my secure boot status is disabled its state is on custom mode.
SATA mode AHCI
Fastboot Disabled
And I just turned off Fast Startup from power options on my windows partition.
Hope this info helps
 
Joined
Oct 4, 2018
Messages
80
Motherboard
Lenovo Legion Y520-15IKBN-80WK-Clover
CPU
i5-7300HQ
Graphics
HD 630 + GTX 1050 Ti 1920x1080
Mobile Phone
iOS
Thanks for the quick reply.
My windows is shutdown. I'll try disabling some of the other power options in windows power management just in case. Yes i configured my bios according to the guide.
though my secure boot status is disabled its state is on custom mode.
SATA mode AHCI
Fastboot Disabled
And I just turned off Fast Startup from power options on my windows partition.
Hope this info helps
You are running a very old build of Clover (r4701), whilst this version would work with older builds of Mojave, it won't work with the newer ones, this includes Catalina.
Update your Clover from the official repository, latest build as of this reply is r5119.
 
Joined
Mar 2, 2020
Messages
5
Motherboard
Lenovo Legion Y720-15IKB
CPU
Intel(R) Core(TM) i7-7700HQ
Graphics
HD 630 + GTX 1060,1920 x 1080
Mac
MacBook Pro
Mobile Phone
Android
Will do and get back to you on it thanks.
 
Joined
Mar 2, 2020
Messages
5
Motherboard
Lenovo Legion Y720-15IKB
CPU
Intel(R) Core(TM) i7-7700HQ
Graphics
HD 630 + GTX 1060,1920 x 1080
Mac
MacBook Pro
Mobile Phone
Android
I've updated clover and it boots well now.
New issue, how do I set up to boot with clover instead of windows boot manager.
Cheers!
EDIT: Got it to boot. I had the tool already SMH(EasyUEFI).
I'm having a hard time setting up my touch pad and keyboard light.
Still surfing through posts here for a solution though.
 
Last edited:
Joined
Oct 4, 2018
Messages
80
Motherboard
Lenovo Legion Y520-15IKBN-80WK-Clover
CPU
i5-7300HQ
Graphics
HD 630 + GTX 1050 Ti 1920x1080
Mobile Phone
iOS
I've updated clover and it boots well now.
New issue, how do I set up to boot with clover instead of windows boot manager.
Cheers!
EDIT: Got it to boot. I had the tool already SMH(EasyUEFI).
I'm having a hard time setting up my touch pad and keyboard light.
Still surfing through posts here for a solution though.
Should be simple enough, rename bootmgfw.efi to bootmgfw-orig.efi and point your BIOS to boot Clover.

Guide should cover touchpad and keyboard backlight. You have to use RehabMan’s build of VoodooPS2Controller. As for the keyboard backlight, it should be working if you are following the guide.
 
Joined
Mar 2, 2020
Messages
5
Motherboard
Lenovo Legion Y720-15IKB
CPU
Intel(R) Core(TM) i7-7700HQ
Graphics
HD 630 + GTX 1060,1920 x 1080
Mac
MacBook Pro
Mobile Phone
Android
Thanks. Will Do So
 
Joined
Oct 30, 2019
Messages
6
Motherboard
Lenovo Legion Y520
CPU
i5 7300hq
Graphics
UHD 630, GTX1050 2 GB (disabled)
Well.... Just updated to 10.15.6 from 10.15.1 (clover 5119)
After updating mac os i updated efi and others (as it said in guide). Everything is good. But i deleted VoodooPS2Controller.kext from /Library/Extention because with that kext numpad isn't working and touchpad too. I put ApplePS2SmartTouchPad.kext in clover/kexts/other - and now it's ok (NUMPAD working perfectly)
 
Joined
Oct 4, 2018
Messages
80
Motherboard
Lenovo Legion Y520-15IKBN-80WK-Clover
CPU
i5-7300HQ
Graphics
HD 630 + GTX 1050 Ti 1920x1080
Mobile Phone
iOS
Well.... Just updated to 10.15.6 from 10.15.1 (clover 5119)
After updating mac os i updated efi and others (as it said in guide). Everything is good. But i deleted VoodooPS2Controller.kext from /Library/Extention because with that kext numpad isn't working and touchpad too. I put ApplePS2SmartTouchPad.kext in clover/kexts/other - and now it's ok (NUMPAD working perfectly)
Numpad is working, the keys are just not bound to numbers (as if Num Lock wasn’t on), touchpad should be working fine with basic gestures when using RehabMan’s build.

Have you thoroughly tested with that kext?
 
Top