Contribute
Register

[Guide] Lenovo Legion Y520/Y720 using Clover UEFI

Status
Not open for further replies.
Joined
May 1, 2019
Messages
14
Motherboard
Xiaomi MI Notebook Pro 2019 OpenCore
CPU
i7-10510u
Graphics
HD 620 (1920x1080) + mx250
Mobile Phone
  1. iOS
I resolved my problem and is all good, I am currently in mojave 10.14.4, but with acpiBatteryManager the percentage of the battery is 0% even under charge, also i don't have the battery icon.
Any way to resolve?
 
Joined
Sep 10, 2016
Messages
23
Motherboard
Lenovo legion Y520
CPU
i5-7300HQ / HM175
Graphics
RX 560m + HD 630
Mobile Phone
  1. Android
  2. iOS
I resolved my problem and is all good, I am currently in mojave 10.14.4, but with acpiBatteryManager the percentage of the battery is 0% even under charge, also i don't have the battery icon.
Any way to resolve?
How did you solve it?
 
Joined
Oct 4, 2018
Messages
82
Motherboard
Lenovo Legion Y520-15IKBN-80WK-Clover
CPU
i5-7300HQ
Graphics
HD 630 + GTX 1050 Ti 1920x1080
Mobile Phone
  1. iOS
I resolved my problem and is all good, I am currently in mojave 10.14.4, but with acpiBatteryManager the percentage of the battery is 0% even under charge, also i don't have the battery icon.
Any way to resolve?
Attach Problem Reporting Files.
 
Joined
May 1, 2019
Messages
14
Motherboard
Xiaomi MI Notebook Pro 2019 OpenCore
CPU
i7-10510u
Graphics
HD 620 (1920x1080) + mx250
Mobile Phone
  1. iOS
Attach Problem Reporting Files.
NVM after installing correctly with hackintool it worked
But i have another question there is a way to get the egpu to work?
 
Joined
Oct 4, 2018
Messages
82
Motherboard
Lenovo Legion Y520-15IKBN-80WK-Clover
CPU
i5-7300HQ
Graphics
HD 630 + GTX 1050 Ti 1920x1080
Mobile Phone
  1. iOS
NVM after installing correctly with hackintool it worked
But i have another question there is a way to get the egpu to work?
I am going to guess you installed kexts incorrectly to /L/E.
You can’t just copy and paste kexts there like you can in Clover, certain permissions need to be set in order for kextcache to work.

To answer your question, no.
The dGPU runs in Nvidia Optimus mode which is unlikely to ever be supported under macOS.
Currently all we can do is disable it so it doesn’t draw power and run on the Intel integrated gpu.
 
Joined
May 22, 2019
Messages
8
Motherboard
Lenovo Legion Y720-15IKB
CPU
i7-7700HQ
Graphics
HD 630 + GTX 1060
Thank you for the guide. I have MacOS running on my laptop. Wondering if led on keyboard will every work?
 
Joined
Oct 4, 2018
Messages
82
Motherboard
Lenovo Legion Y520-15IKBN-80WK-Clover
CPU
i5-7300HQ
Graphics
HD 630 + GTX 1050 Ti 1920x1080
Mobile Phone
  1. iOS
Thank you for the guide. I have MacOS running on my laptop. Wondering if led on keyboard will every work?
Attach Problem Reporting Files

Keyboard backlight works fine.
 
Joined
May 22, 2019
Messages
8
Motherboard
Lenovo Legion Y720-15IKB
CPU
i7-7700HQ
Graphics
HD 630 + GTX 1060
Attach Problem Reporting Files

Keyboard backlight works fine.

The LED will come on if I boot into windows first then reboot into MacOS. But if I cold boot into MacOS the keyboard backlight is off. Anyway to change the color of the LED while in MacOS or can only be done in Windows?

I have triple boot working of MacOS 10.14.5, Windows 10 1903, and Ubuntu 18.04 LTS.

I have even tried fn+space to see if light will turn on.

Here is my problem reporting files please see attached files.
 

Attachments

  • debug_22598.zip
    1.9 MB · Views: 76
Last edited:

Feartech

Moderator
Joined
Aug 3, 2013
Messages
26,543
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
The LED will come on if I boot into windows first then reboot into MacOS. But if I cold boot into MacOS the keyboard backlight is off. Anyway to change the color of the LED while in MacOS or can only be done in Windows?

I have triple boot working of MacOS 10.14.5, Windows 10 1903, and Ubuntu 18.04 LTS.

Here is my problem reporting files:
please use site attachments as per rules
 
Joined
Oct 4, 2018
Messages
82
Motherboard
Lenovo Legion Y520-15IKBN-80WK-Clover
CPU
i5-7300HQ
Graphics
HD 630 + GTX 1050 Ti 1920x1080
Mobile Phone
  1. iOS
The LED will come on if I boot into windows first then reboot into MacOS. But if I cold boot into MacOS the keyboard backlight is off. Anyway to change the color of the LED while in MacOS or can only be done in Windows?

I have triple boot working of MacOS 10.14.5, Windows 10 1903, and Ubuntu 18.04 LTS.

I have even tried fn+space to see if light will turn on.

Here is my problem reporting files please see attached files.
Your complete IOReg report is missing, are you sure you let the script run uninterrupted?
Do all Y720s come with custom software controlled keyboard backlight?
My Y520 only has red backlight with 3 brightness options (off, medium, full).

EDIT: I doubt there is control for your keyboard backlight under macOS.
 
Last edited:
Status
Not open for further replies.
Top