Contribute
Register

[Guide] Lenovo Legion Y520/Y720 using Clover UEFI

Joined
May 1, 2019
Messages
14
Motherboard
Xiaomi MI Notebook Pro 2019 OpenCore
CPU
i7-10510u
Graphics
HD 620 (1920x1080) + mx250
Mobile Phone
  1. iOS
Don't know what you are doing wrong. Try recreating the macOS USB installer.
still can't boot on mojave installer,
maybe my bios settings is wrong?
 

Attachments

  • CLOVER EFI.zip
    4.7 MB · Views: 40
  • IMG_2412.PNG
    IMG_2412.PNG
    2.1 MB · Views: 36
Last edited:
Joined
Nov 3, 2018
Messages
2
Motherboard
Lenovo
CPU
7700HQ
Graphics
intel 620
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
excellent guide only one note config_install.plist needs to be renamed to only config.plist
 
Joined
May 9, 2019
Messages
1
Motherboard
Lenovo Legion Y520-15IKBN (80WK)
CPU
i5-7300HQ
Graphics
HD 630+GTX 1050 Ti
Mobile Phone
  1. Android
Hi this is my first hackintosh, so probabily I'm doing some things wrong, because I'm getting stuck into the same problem all the time. I followed the Main guide, and I think I have a graphics kernel error. I attach my clover and the image error.

Note: I can't reach the installer
 

Attachments

  • CLOVER.zip
    1.8 MB · Views: 42
  • 81d02ee6-e529-4c71-8d6b-66f20e0bc4b9.jpg
    81d02ee6-e529-4c71-8d6b-66f20e0bc4b9.jpg
    139.8 KB · Views: 168
Last edited:
Joined
Oct 4, 2018
Messages
82
Motherboard
Lenovo Legion Y520-15IKBN-80WK-Clover
CPU
i5-7300HQ
Graphics
HD 630 + GTX 1050 Ti 1920x1080
Mobile Phone
  1. iOS
Hi this is my first hackintosh, so probabily I'm doing some things wrong, because I'm getting stuck into the same problem all the time. I followed the Main guide, and I think I have a graphics kernel error. I attach my clover and the image error.

Note: I can't reach the installer
Why aren't you following this guide?
Your Clover is set up wrong.
 
Joined
Oct 4, 2018
Messages
82
Motherboard
Lenovo Legion Y520-15IKBN-80WK-Clover
CPU
i5-7300HQ
Graphics
HD 630 + GTX 1050 Ti 1920x1080
Mobile Phone
  1. iOS
still can't boot on mojave installer,
maybe my bios settings is wrong?
config.plist is wrong, follow the guide.
USBInjectAll.kext is not used in the guide.
 
Joined
Nov 18, 2013
Messages
15
Motherboard
Lenovo Legion Y520-15IKBN (Clover)
CPU
i7-7700HQ/HM175
Graphics
HD630, NVIDIA GTX 1050Ti, 1920x1080
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
I have been recently having issues upgrading to 10.14.4 and 10.14.5. Following the guide; not sure what's up. Kernel panics occur on graphics. I compiled Lilu and WhateverGreen from their latest source to see if it would help, but the issue persists. I'm on a fresh install now; started with the latest version of High Sierra and upgraded smoothly to Mojave 10.14.3. I upgraded my internal SSD to an Intel 660p, but the issue still occurred on the original SSD. Any assistance would be most helpful. Thank you so much!
 

Attachments

  • debug_23312.zip
    2.2 MB · Views: 38
Last edited:
Joined
Oct 4, 2018
Messages
82
Motherboard
Lenovo Legion Y520-15IKBN-80WK-Clover
CPU
i5-7300HQ
Graphics
HD 630 + GTX 1050 Ti 1920x1080
Mobile Phone
  1. iOS
I have been recently having issues upgrading to 10.14.4 and 10.14.5. Following the guide; not sure what's up. Kernel panics occur on graphics. I compiled Lilu and WhateverGreen from their latest source to see if it would help, but the issue persists. I'm on a fresh install now; started with the latest version of High Sierra and upgraded smoothly to Mojave 10.14.3. I upgraded my internal SSD to an Intel 660p, but the issue still occurred on the original SSD. Any assistance would be most helpful. Thank you so much!
You're using an older version of Clover (r4701), try updating it.
I am on build r4910 and updating to 10.14.4 worked without an issue.
 
Joined
Nov 18, 2013
Messages
15
Motherboard
Lenovo Legion Y520-15IKBN (Clover)
CPU
i7-7700HQ/HM175
Graphics
HD630, NVIDIA GTX 1050Ti, 1920x1080
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
You're using an older version of Clover (r4701), try updating it.
I am on build r4910 and updating to 10.14.4 worked without an issue.

Did you compile RehabMan's fork? Or are you the using the regular one? I'll attempt to use his Build Clover script and see what's happening.
 
Joined
Oct 4, 2018
Messages
82
Motherboard
Lenovo Legion Y520-15IKBN-80WK-Clover
CPU
i5-7300HQ
Graphics
HD 630 + GTX 1050 Ti 1920x1080
Mobile Phone
  1. iOS
Did you compile RehabMan's fork? Or are you the using the regular one? I'll attempt to use his Build Clover script and see what's happening.
Regular build, just copy and paste your current drivers, kexts and config
 
Top